Can't resize apport-collect dialog, can't see what information is being sent

Bug #865754 reported by Martin Albisetti on 2011-10-03
78
This bug affects 9 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt
Oneiric
Medium
Martin Pitt

Bug Description

When using apport-collect, I get a dialog showing me what information will be sent, but I can't resize it to a normal viewing size. Screenshot attached.

Martin Albisetti (beuno) wrote :
Martin Pitt (pitti) on 2011-10-13
Changed in apport:
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → In Progress
summary: - Can't resize dialog, can't see what information is being sent
+ Can't resize apport-collect dialog, can't see what information is being
+ sent
affects: apport → apport (Ubuntu)
Martin Pitt (pitti) wrote :

Fixed in trunk r1991.

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Sam_ (and-sam) wrote :

Seems to be a dupe of Bug #826328

Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package apport - 1.24-0ubuntu1

---------------
apport (1.24-0ubuntu1) precise; urgency=low

  * New upstream release 1.23.1:
    - apport/crashdb.py: Ensure that duplicate table only has one entry per
      report ID.
    - apport-retrace: Pass correct executable path to gdb in --gdb with
      --sandbox mode.
    - apport-retrace: Do not leave behind temporary directories on errors.
    - apport-retrace: Drop assertion failure for existance of "Stacktrace".
      This isn't present in the case of gdb crashing, and there is not much we
      can do about it. This should not break the retracer.
    - apport/report.py: Unwind XError() from stack traces for the
      "StacktraceTop" field, as they take a significant part of the trace.
      This causes bugs to be duplicated which really have different causes.
  * New upstream release 1.24:
   - apport-retrace: Add --timestamp option to prepend a timestamp to log
     messages. This is useful for batch operations.
   - crash-digger: Call apport-retrace with --timestamps, to get consistent
     timestamps in log output.
   - hookutils.py: Add two new functions attach_gsettings_package() and
     attach_gsettings_schema() for adding user-modified gsettings keys to a
     report. (LP: #836489)
   - hookutils.py: Add new function in_session_of_problem() which returns
     whether the given report happened in the currently running XDG session.
     This can be used to determine if e. g. ~/.xsession-errors is relevant and
     should be attached.
   - backends/packaging-apt-dpkg.py, install_packages(): Also copy
     apt/sources.list.d/ into sandbox.
   - backends/packaging-apt-dpkg.py, install_packages(): Install apt keyrings
     from config dir or from system into sandbox. (LP: #856216)
   - packaging.py, backends/packaging-apt-dpkg.py: Define that
     install_packages() should return a SystemError for broken
     configs/unreachable servers etc., and fix the apt/dpkg implementation
     accordingly.
   - apport-retrace: Don't crash, just give a proper error message if servers
     are unreachable, or configuration files are broken. (LP: #859248)
   - backends/packaging-apt-dpkg.py: Fix crash when
     /etc/apport/native-origins.d contains any files. (LP: #865199)
   - hookutils, recent_logfile(): Fix invalid return value if log file is not
     readable. (LP: #819357)
   - test/crash: Fix race condition in the "second instance terminates
     immediately" check.
   - hookutils.py: Replace attach_gconf() with a no-op stub. It used static
     python modules like "gconf" which broke the PyGI GTK user interface, and
     gconf is rather obsolete these days.
   - ui.py, open_url(): Greatly simply and robustify by just using xdg-open.
     This already does the right thing wrt. reading the default browser from
     GNOME, KDE, XCE, and other desktops. (LP: #198449)
   - data/general-hooks/generic.py: Only attach ~/.xsession_errors if the bug
     is reported in the same XDG session as the crash happened. (LP: #869974)
   - Ignore crashes for programs which got updated in between the crash and
     reporting. (LP: #132904)
   - Special-case crashes of 'twistd': Try to determin...

Read more...

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released

Since this bug severely impacts the usability of apport-collect on all Oneiric systems (see these duplicates: bug 826328, bug 855349, bug 876117, bug 876538), it seems to me that this qualifies to have the fix backported as an SRU (https://wiki.ubuntu.com/StableReleaseUpdates) and released in oneiric-updates. Can someone with the power to do so nominate this to be fixed in Oneiric (or explain why I am mistaken)?

tags: added: amd64 i386 oneiric precise
Martin Pitt (pitti) on 2011-10-19
Changed in apport (Ubuntu Oneiric):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

I uploaded an SRU for this to the queue, needs ubuntu-sru review now.

Changed in apport (Ubuntu Oneiric):
status: In Progress → Fix Committed

Hello Martin, or anyone else affected,

Accepted apport into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Alan Jenkins (aj504) wrote :

No joy.

I enabled -proposed, and installed apport_1.23-0ubuntu4.

Apport was apparently not running. ps ax|grep apport showed no related daemons. So I think I've done everything I needed to get the update.

Apport-collect still only showed two lines of data. As before, toggling the "show details" on & off expanded it to a reasonable size, and made the window resizable. But to start with, the window was not resizable, as before.

In case it matters, I'm running an LXDE session at the moment (Openbox window manager from Lubuntu packages).

Martin Pitt (pitti) wrote :

You need apport-gtk_1.23-0ubuntu4. I just tested the package from oneiric-proposed, and it works fine for me. Can you please re-test with apport-gtk? Thanks!

Alan Jenkins (aj504) wrote :

Heh. Yes, after upgrading apport-gtk the window is now resizable. Thanks.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.23-0ubuntu4

---------------
apport (1.23-0ubuntu4) oneiric-proposed; urgency=low

  * apport-gtk: In bug update mode, make details dialog resizable and fix
    default size. Patch cherry-picked from trunk r1991. (LP: #865754)
  * backends/packaging-apt-dpkg.py: Fix crash when
    /etc/apport/native-origins.d contains any files. Patch cherry-picked from
    trunk r1973. (LP: #865199)
  * apport/report.py: Special-case crashes of 'twistd': Try to determine the
    client program and assign the report to that, or fail with an
    UnreportableReason. Patch cherry-picked from trunk r1989. (LP: #755025)
  * hookutils.py, attach_wifi(): Anonymize ESSID and AP MAC from "iwconfig"
    output. Patch cherry-picked from trunk 1993. (LP: #746900)
 -- Martin Pitt <email address hidden> Thu, 20 Oct 2011 12:08:11 +0200

Changed in apport (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers