apport-retrace crashed with FetchFailedException in update()

Bug #859248 reported by Eliah Kagan on 2011-09-25
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Low
Martin Pitt

Bug Description

On an Oneiric i386 system with apport-retrace 1.23-0ubuntu1, I ran "apport-retrace -g -S system 822931" (which I expected to fail later, for the unrelated reason that I was not running it on the system on which the crash had originally occurred). I decided that I didn't want verbose output after all, so while it was downloading package information, I interrupted it by sending SIGINT (by pressing Ctrl+C) a couple of times. This resulted in a FetchFailedException crash. I am unsure if this is really a bug, but generally a crash should not be triggered as a consequence of pressing Ctrl+C, as a non-interactive process should be cleanly interrupted by Ctrl+C.

This looks like a duplicate of bug 856216, but due to the differing circumstances that appeared to trigger the crashes, I am unsure.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: apport-retrace 1.23-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Sun Sep 25 18:19:16 2011
ExecutablePath: /usr/bin/apport-retrace
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-retrace -v -g -S system 822931
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/apport-retrace', '-v', '-g', '-S', 'system', '822931']
SourcePackage: apport
Title: apport-retrace crashed with FetchFailedException in update(): W:GPG error: http://extras.ubuntu.com oneiric Release: No keyring installed in /tmp/tmp8ANBS9/system/apt//etc/apt/trusted.gpg.d/., W:GPG error: http://security.ubuntu.com oneiric-security Release: No keyring installed in /tmp/tmp8ANBS9/system/apt//etc/apt/trusted.gpg.d/., W:GPG error: http://us.archive.ubuntu.com oneiric Release: No keyring installed in /tmp/tmp8ANBS9/system/apt//etc/apt/trusted.gpg.d/., W:GPG error: http://us.archive.ubuntu.com oneiric-updates Release: No keyring installed in /tmp/tmp8ANBS9/system/apt//etc/apt/trusted.gpg.d/., E:Method gzip has died unexpectedly!, E:Sub-process gzip received signal 2., E:Method gpgv has died unexpectedly!, E:Sub-process gpgv received signal 2., E:Method http has died unexpectedly!, E:Sub-process http returned an error code (100), E:Method http has died unexpectedly!, E:Sub-process http returned an error code (100)
UpgradeStatus: Upgraded to oneiric on 2011-06-18 (99 days ago)
UserGroups: adm admin dialout lpadmin plugdev sambashare

visibility: private → public
tags: removed: need-duplicate-check
description: updated

I can reproduce this. It indeed seems to be a different reason than bug 856216, so let's not make this a dupe.

summary: apport-retrace crashed with FetchFailedException in update(): W:GPG
- error: http://extras.ubuntu.com oneiric Release: No keyring installed in
- /tmp/tmp8ANBS9/system/apt//etc/apt/trusted.gpg.d/., W:GPG error:
- http://security.ubuntu.com oneiric-security Release: No keyring
- installed in /tmp/tmp8ANBS9/system/apt//etc/apt/trusted.gpg.d/., W:GPG
- error: http://us.archive.ubuntu.com oneiric Release: No keyring
- installed in /tmp/tmp8ANBS9/system/apt//etc/apt/trusted.gpg.d/., W:GPG
- error: http://us.archive.ubuntu.com oneiric-updates Release: No keyring
- installed in /tmp/tmp8ANBS9/system/apt//etc/apt/trusted.gpg.d/.,
- E:Method gzip has died unexpectedly!, E:Sub-process gzip received signal
- 2., E:Method gpgv has died unexpectedly!, E:Sub-process gpgv received
- signal 2., E:Method http has died unexpectedly!, E:Sub-process http
- returned an error code (100), E:Method http has died unexpectedly!, E
- :Sub-process http returned an error code (100)
+ error: http://extras.ubuntu.com oneiric Release: No keyring installed
Changed in apport (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Martin Pitt (pitti) wrote :

I'll get that fixed after fixing 856216, since as soon as we stop it from crashing we wouldn't get useful apport reports about these any more.

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Bug 856216 is now devoted to the missing keyrings, and I'll use this one for friendlier error messages.

summary: - apport-retrace crashed with FetchFailedException in update(): W:GPG
- error: http://extras.ubuntu.com oneiric Release: No keyring installed
+ apport-retrace crashed with FetchFailedException in update()
Martin Pitt (pitti) wrote :

Fixed in trunk r1972.

Changed in apport (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.3 KiB)

This bug was fixed in the package apport - 1.24-0ubuntu1

---------------
apport (1.24-0ubuntu1) precise; urgency=low

  * New upstream release 1.23.1:
    - apport/crashdb.py: Ensure that duplicate table only has one entry per
      report ID.
    - apport-retrace: Pass correct executable path to gdb in --gdb with
      --sandbox mode.
    - apport-retrace: Do not leave behind temporary directories on errors.
    - apport-retrace: Drop assertion failure for existance of "Stacktrace".
      This isn't present in the case of gdb crashing, and there is not much we
      can do about it. This should not break the retracer.
    - apport/report.py: Unwind XError() from stack traces for the
      "StacktraceTop" field, as they take a significant part of the trace.
      This causes bugs to be duplicated which really have different causes.
  * New upstream release 1.24:
   - apport-retrace: Add --timestamp option to prepend a timestamp to log
     messages. This is useful for batch operations.
   - crash-digger: Call apport-retrace with --timestamps, to get consistent
     timestamps in log output.
   - hookutils.py: Add two new functions attach_gsettings_package() and
     attach_gsettings_schema() for adding user-modified gsettings keys to a
     report. (LP: #836489)
   - hookutils.py: Add new function in_session_of_problem() which returns
     whether the given report happened in the currently running XDG session.
     This can be used to determine if e. g. ~/.xsession-errors is relevant and
     should be attached.
   - backends/packaging-apt-dpkg.py, install_packages(): Also copy
     apt/sources.list.d/ into sandbox.
   - backends/packaging-apt-dpkg.py, install_packages(): Install apt keyrings
     from config dir or from system into sandbox. (LP: #856216)
   - packaging.py, backends/packaging-apt-dpkg.py: Define that
     install_packages() should return a SystemError for broken
     configs/unreachable servers etc., and fix the apt/dpkg implementation
     accordingly.
   - apport-retrace: Don't crash, just give a proper error message if servers
     are unreachable, or configuration files are broken. (LP: #859248)
   - backends/packaging-apt-dpkg.py: Fix crash when
     /etc/apport/native-origins.d contains any files. (LP: #865199)
   - hookutils, recent_logfile(): Fix invalid return value if log file is not
     readable. (LP: #819357)
   - test/crash: Fix race condition in the "second instance terminates
     immediately" check.
   - hookutils.py: Replace attach_gconf() with a no-op stub. It used static
     python modules like "gconf" which broke the PyGI GTK user interface, and
     gconf is rather obsolete these days.
   - ui.py, open_url(): Greatly simply and robustify by just using xdg-open.
     This already does the right thing wrt. reading the default browser from
     GNOME, KDE, XCE, and other desktops. (LP: #198449)
   - data/general-hooks/generic.py: Only attach ~/.xsession_errors if the bug
     is reported in the same XDG session as the crash happened. (LP: #869974)
   - Ignore crashes for programs which got updated in between the crash and
     reporting. (LP: #132904)
   - Special-case crashes of 'twistd': Try to determin...

Read more...

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers