apport-gtk crashed with TypeError in function(): markup_escape_text() takes exactly 2 argument(s) (1 given)

Bug #851450 reported by Alex Mayorga
208
This bug affects 28 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Unassigned

Bug Description

Varant of bug 828010 perhaps?

Happens on apport 1.23-0ubuntu1 here.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: apport-gtk 1.23-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Tue Sep 13 07:25:03 2011
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with TypeError in function(): markup_escape_text() takes exactly 2 argument(s) (1 given)
UpgradeStatus: Upgraded to oneiric on 2011-07-06 (71 days ago)
UserGroups:

Revision history for this message
Alex Mayorga (alex-mayorga) wrote :
tags: removed: need-duplicate-check
Martin Pitt (pitti)
tags: added: need-duplicate-check
tags: removed: need-duplicate-check
Revision history for this message
Martin Pitt (pitti) wrote : Possible regression detected

This crash has the same stack trace characteristics as bug #829635. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer
Revision history for this message
Martin Pitt (pitti) wrote :

This was already fixed, so I suppose this is just noise from a previous version of apport, whose crash report got picked up after a system upgrade.

However, I'll fix the dependencies of apport to be more strict, to further narrow down these crashes.

Changed in apport (Ubuntu):
status: New → Fix Committed
visibility: private → public
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.23-0ubuntu2

---------------
apport (1.23-0ubuntu2) oneiric; urgency=low

  [ Martin Pitt ]
  * debian/control: Bump GIR dependencies to ensure that we don't run this
    against older versions against gir1.2-glib-2.0, which still have a wrong
    API for markup_escape_text(). (LP: #851450)

  [ Brian Murray ]
  * data/general-hooks/ubuntu.py: also check CurrentDmesg for disk errors
    as some package hooks add it
  * data/package-hooks/source_debian-installer.py: for dmraid collection use
    attach_root_command_outputs (LP: #856826)
 -- Martin Pitt <email address hidden> Wed, 28 Sep 2011 07:12:19 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers