apport-retrace crashed with SystemError in open(): E:Could not open file /tmp/tmp83YCIF//var/lib/dpkg/status - open (2: No such file or directory), E:The package lists or status file could not be parsed or opened.

Bug #847951 reported by Fabien Tassin on 2011-09-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt

Bug Description

just trying to retrace a crash with the new sandboxed apport-retracer.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: apport-retrace 1.22.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
NonfreeKernelModules: nvidia
ApportLog:

ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
CrashReports: 600:1000:1000:9472:2011-09-12 17:16:58.611871000 +0200:2011-09-12 17:17:07.355872145 +0200:/var/crash/_usr_bin_apport-retrace.1000.crash
Date: Mon Sep 12 17:16:59 2011
ExecutablePath: /usr/bin/apport-retrace
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-retrace -g -S system /var/crash-preserved/_usr_bin_gs.7-2011-09-09-16:32:48.594655000.crash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/usr/bin/tcsh
 PATH=(custom, user)
PythonArgs: ['/usr/bin/apport-retrace', '-g', '-S', 'system', '/var/crash-preserved/_usr_bin_gs.7-2011-09-09-16:32:48.594655000.crash']
SourcePackage: apport
Title: apport-retrace crashed with SystemError in open(): E:Could not open file /tmp/tmp83YCIF//var/lib/dpkg/status - open (2: No such file or directory), E:The package lists or status file could not be parsed or opened.
UpgradeStatus: Upgraded to oneiric on 2011-05-09 (126 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare wireshark

Fabien Tassin (fta) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Martin Pitt (pitti) wrote :

Ah, this seems to happen when not specifying -C/--cache.

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → In Progress
Martin Pitt (pitti) wrote :

More precisely, when not specifying --cache AND there is extra libraries to be downloaded.

Martin Pitt (pitti) wrote :

Fixed in trunk.

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.23-0ubuntu1

---------------
apport (1.23-0ubuntu1) oneiric; urgency=low

  [ Brian Murray ]
  * data/package-hooks/source_ubiquity.py: Do not create a DuplicateSignature
    for bugs with a Traceback included as it is redundant

  [ Martin Pitt ]
  * New upstream release:
    - crashdb.py, crash-digger, dupdb-admin: Drop the concept of "duplicate DB
      consolidation". Such massive queries cause timeouts with e. g.
      Launchpad. Instead, update the status of potential master bugs in the
      crash DB whenever check_duplicate() is called. Note that this does not
      affect Ubuntu itself, just the retracers in the data center.
    - launchpad.py: Fix crash in close_duplicate() if master bug was already
      marked as a duplicate of the examined bug.
    - problem_report.py, load(): Fix missing last character if the last line
      in a multi-line field is not terminated with a newline.
    - launchpad.py: Fix test_marking_python_task_mangle() check to work with
      current Launchpad.
    - apport-retrace: If the user did not specify a --cache directory, create
      a shared one instead of letting the two install_packages() calls create
      their own. This ensures that the apt and dpkg status is up to date, and
      avoids downloading the package indexes multiple times. (LP: #847951)
    - apport-retrace: Give proper error mesage instead of AssertionError crash
      if a report does not contain standard Apport format data. (LP: #843221)
    - fileutils.py, get_new_reports(): Fix crash if report file disappears in
      the middle of the operation. (LP: #640216)
    - apport/ui.py, load_report(): Intercept another case of broken report
      files. (LP: #445142)
    - apport/report.py, standard_title(): Escape regular expression control
      characters in custom exception names. (LP: #762998)
  * data/package-hooks/source_ubiquity.py: Fix crash if
    prepare_duplicate_signature() does not return anything. (LP: #843911)
  * debian/control: Bump Standards-Version to 3.9.2 (no changes necessary).
 -- Martin Pitt <email address hidden> Wed, 14 Sep 2011 08:29:03 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers