apport-retrace crashed with AssertionError in download(): bug description must contain standard apport format data

Bug #843221 reported by GaaL on 2011-09-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Martin Pitt

Bug Description

trying to retrace bug 841201 that is not mine.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: apport-retrace 1.22.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
Date: Tue Sep 6 22:22:52 2011
ExecutablePath: /usr/bin/apport-retrace
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-retrace -s 841201
PythonArgs: ['/usr/bin/apport-retrace', '-s', '841201']
SourcePackage: apport
Title: apport-retrace crashed with AssertionError in download(): bug description must contain standard apport format data
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

GaaL (gaal33) wrote :
tags: removed: need-duplicate-check
Martin Pitt (pitti) on 2011-09-14
visibility: private → public
Changed in apport (Ubuntu):
status: New → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.23-0ubuntu1

---------------
apport (1.23-0ubuntu1) oneiric; urgency=low

  [ Brian Murray ]
  * data/package-hooks/source_ubiquity.py: Do not create a DuplicateSignature
    for bugs with a Traceback included as it is redundant

  [ Martin Pitt ]
  * New upstream release:
    - crashdb.py, crash-digger, dupdb-admin: Drop the concept of "duplicate DB
      consolidation". Such massive queries cause timeouts with e. g.
      Launchpad. Instead, update the status of potential master bugs in the
      crash DB whenever check_duplicate() is called. Note that this does not
      affect Ubuntu itself, just the retracers in the data center.
    - launchpad.py: Fix crash in close_duplicate() if master bug was already
      marked as a duplicate of the examined bug.
    - problem_report.py, load(): Fix missing last character if the last line
      in a multi-line field is not terminated with a newline.
    - launchpad.py: Fix test_marking_python_task_mangle() check to work with
      current Launchpad.
    - apport-retrace: If the user did not specify a --cache directory, create
      a shared one instead of letting the two install_packages() calls create
      their own. This ensures that the apt and dpkg status is up to date, and
      avoids downloading the package indexes multiple times. (LP: #847951)
    - apport-retrace: Give proper error mesage instead of AssertionError crash
      if a report does not contain standard Apport format data. (LP: #843221)
    - fileutils.py, get_new_reports(): Fix crash if report file disappears in
      the middle of the operation. (LP: #640216)
    - apport/ui.py, load_report(): Intercept another case of broken report
      files. (LP: #445142)
    - apport/report.py, standard_title(): Escape regular expression control
      characters in custom exception names. (LP: #762998)
  * data/package-hooks/source_ubiquity.py: Fix crash if
    prepare_duplicate_signature() does not return anything. (LP: #843911)
  * debian/control: Bump Standards-Version to 3.9.2 (no changes necessary).
 -- Martin Pitt <email address hidden> Wed, 14 Sep 2011 08:29:03 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers