apport-gtk crashed with TypeError in function(): markup_escape_text() takes exactly 2 argument(s) (1 given)

Bug #828010 reported by Jean-Baptiste Lallement
136
This bug affects 31 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt

Bug Description

apport crashes when it is launched on another application crash

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: apport-gtk 1.21.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic i686
Architecture: i386
CrashReports:
 600:0:0:8826:2011-08-17 10:49:24.746874000 +0200:2011-08-17 12:45:02.352668894 +0200:/var/crash/_usr_bin_fontconfig-voodoo.0.crash
 600:1000:1000:31692:2011-08-17 12:51:39.249610000 +0200:2011-08-17 12:51:40.249610000 +0200:/var/crash/_usr_share_software-center_piston_get_reviews_helper.py.1000.crash
 600:1000:1000:28908:2011-08-17 14:49:17.184227000 +0200:2011-08-17 14:49:22.560227146 +0200:/var/crash/_usr_share_apport_apport-gtk.1000.crash
 600:1000:1000:10533579:2011-08-17 14:45:17.596232000 +0200:2011-08-17 14:47:02.644230723 +0200:/var/crash/_usr_bin_compiz.1000.crash
Date: Wed Aug 17 14:49:18 2011
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with TypeError in function(): markup_escape_text() takes exactly 2 argument(s) (1 given)
UpgradeStatus: Upgraded to oneiric on 2011-08-17 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
visibility: private → public
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Could be caused by the change from glib to GLib

Changed in apport (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → High
Martin Pitt (pitti)
Changed in apport (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
status: New → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in trunk r1924.

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.21.3-0ubuntu3

---------------
apport (1.21.3-0ubuntu3) oneiric; urgency=low

  * Fix crash in GLib.markup_escape_text() call. Patch cherrypicked from
    trunk. (LP: #828010)
 -- Martin Pitt <email address hidden> Wed, 17 Aug 2011 15:52:22 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers