package apport 1.20.1-0ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #767498 reported by Guilherme Salgado
This bug affects 235 people
Affects Status Importance Assigned to Milestone
Apport
Undecided
Unassigned
apport (Ubuntu)
Critical
Unassigned
Natty
Critical
Unassigned

Bug Description

Binary package hint: apport

Got this when running dist-upgrade:

[...]
Setting up ubuntuone-control-panel-gtk (1.0.0-0ubuntu1) ...
Setting up apport (1.20.1-0ubuntu3) ...
Installing new version of config file /etc/default/apport ...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed.
dpkg: error processing apport (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apport-gtk:
 apport-gtk depends on apport (>= 0.41); however:
  Package apport is not configured yet.
dpkg: error processing apport-gtk (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
No apport report written because the error message indicates its a followup error from a previous failure.
                           Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.38-8-generic
Processing triggers for python-support ...
Errors were encountered while processing:
 apport
 apport-gtk
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: apport 1.20.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
ApportLog:

Architecture: amd64
Date: Wed Apr 20 16:12:52 2011
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
SourcePackage: apport
Title: package apport 1.20.1-0ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to natty on 2011-04-15 (5 days ago)

Related branches

Revision history for this message
Guilherme Salgado (salgado) wrote :
Revision history for this message
Colin Mills (cm006a5077) wrote :

I think that this is the same bug that I noticed when I updated my 64 bit natty machine a few minutes ago:-

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up apport (1.20.1-0ubuntu3) ...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed.
dpkg: error processing apport (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apport-gtk:
 apport-gtk depends on apport (>= 0.41); however:
  Package apport is not configured yet.
dpkg: error processing apport-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates it's a follow-up error from a previous failure.
                            Errors were encountered while processing:
 apport
 apport-gtk
E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
Krad Radio (kradradio) wrote :

I guess I better not reboot, I fear doom!

Revision history for this message
Cross (strokemeister) wrote :

The same for Natty 32 Bits, Don't panic! Apport just recollect data from crashes, nothing to do with kernel.

Revision history for this message
Cross (strokemeister) wrote :

Tried manually forcing it to install apport and apport-gtk with aptitude gives you.

Setting up apport (1.20.1-0ubuntu3) ...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed.
dpkg: error processing apport (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apport-gtk:
 apport-gtk depends on apport (>= 0.41); however:
  Package apport is not configured yet.
dpkg: error processing apport-gtk (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 apport
 apport-gtk

Revision history for this message
David Strauss (davidstrauss) wrote :

From syslog:
Apr 20 12:42:07 titan init: apport pre-start process (12126) terminated with status 1
Apr 20 12:42:07 titan init: apport post-stop process (12128) terminated with status 1

Changed in apport (Ubuntu):
status: New → Confirmed
Revision history for this message
Ron Steed (ronsteed) wrote :

Also getting this:

Setting up apport (1.20.1-0ubuntu3) ...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed.
dpkg: error processing apport (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 apport
E: Sub-process /usr/bin/dpkg returned an error code (1)

With 11.04 Natty.

Revision history for this message
Andreas Moog (ampelbein) wrote :

raising importance due to number of duplicates.

Changed in apport (Ubuntu):
importance: Undecided → Critical
Revision history for this message
David Strauss (davidstrauss) wrote :

This error also appears if I apt-get remove --purge apport and then apt-get install apport.

Revision history for this message
John H. (john-hawk) wrote :

Add me to list

Revision history for this message
Radu Cristescu (radu.c) wrote :

Same problem here. Must be the Natty release rush, as this is the second bug in a almost-natty upload that fails in a postinstall script :)

Revision history for this message
Jack Ciezak (jack-ciezak) wrote :

Same problem, please add me to the list

Revision history for this message
Marco Giannini (marco-giannini) wrote :

Same problem with natty

Revision history for this message
Radu Cristescu (radu.c) wrote :

For reference, in 1.14.1-0ubuntu8.1 you have this:

# Automatically added by dh_installinit
if [ -e "/etc/init/apport.conf" ]; then
        # start fails if already running
        start apport || :
fi
# End automatically added section

while in 1.20.1-0ubuntu3 you have this instead:

# Automatically added by dh_installinit
if [ -e "/etc/init/apport.conf" ]; then
    invoke-rc.d apport start || exit $?
fi
# End automatically added section

I'm not sure, but that looks like a regression to me, moving away from upstart's "start" to "invoke-rc.d", so it may have come from old code. The old code hypothesis is kind of confirmed by the bad idea of exiting with a non-zero code in a postinstall script for no good reason when the 10.10 package just didn't care if the script failed.

Revision history for this message
pauljwells (pauljwells) wrote :

temporary fix, downgrade:

[CODE]sudo dpkg -i apport_1.20.1-0ubuntu2_all.deb apport-gtk_1.20.1-0ubuntu2_all.deb[/CODE]

Revision history for this message
Varun Vijayaraghavan (varun-kvv) wrote :

@pauljwells,

I am guessing that doesn't work if I did a dist-upgrade?

Revision history for this message
Radu Cristescu (radu.c) wrote :

The other hypothesis is that something was pulled from Debian, which doesn't use upstart and may have a very different startup script for apport.

@varun: temporary fix: edit /var/lib/dpkg/info/apport.postinst and replace "exit $?" with "/bin/true" and apt-get -f install

Revision history for this message
Daniel Holbach (dholbach) wrote :

Could it be this change http://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu/natty/apport/natty/revision/1570 now that "enabled" was set to 0?

Revision history for this message
Brian Murray (brian-murray) wrote :

This is currently being worked on.

13:33 < cjwatson> stgraber,kees: or perhaps --error-handler=true ...
13:33 -!- chrisccoulson [~chr1s@ubuntu/member/chrisccoulson] has joined
          #ubuntu-devel
13:33 < kees> cjwatson: yeah, that might be the better approach, since "start"
              really should fail if it's disabled, imo
13:34 -!- bryceh [~<email address hidden>] has
          joined #ubuntu-devel
13:34 < cjwatson> kees: IIRC, it might need to be '|| { stop; exit 0; }' or
                  some such, if we were going for exit 0
13:34 < cjwatson> though I'd have to check - error-handler is simpler
13:34 < stgraber> yeah, I guess it makes sense for start to fail when the
                  service is disabled as it didn't start :)
13:34 -!- tremolux [~<email address hidden>] has
          quit [Quit: Bye]
13:35 < cjwatson> does one of you want to take care of this, or should I?
13:35 < cjwatson> if somebody else does, I can accept it through the queue :-)
13:36 < stgraber> I can do it

Changed in apport (Ubuntu Natty):
status: Confirmed → In Progress
Revision history for this message
pauljwells (pauljwells) wrote :

@varun

download from here

https://launchpad.net/ubuntu/+source/apport/1.20.1-0ubuntu2/+buildjob/2485347

run dpkg from wherever you save them. I needed both apport and apport-gtk

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.20.1-0ubuntu4

---------------
apport (1.20.1-0ubuntu4) natty; urgency=low

  * Ignore return code on startup (LP: #767498)
 -- Stephane Graber <email address hidden> Wed, 20 Apr 2011 16:55:58 -0400

Changed in apport (Ubuntu Natty):
status: In Progress → Fix Released
Revision history for this message
Pushkin (kovshovik-alexandr) wrote :

Same problem here. Installed the apport and apport-gtk from that URL - it worked.

Revision history for this message
William Blake Galbreath (billygalbreath) wrote :

Same problem here. Ran a regular daily update using GUI Update Manager.

Revision history for this message
David Strauss (davidstrauss) wrote :

This says "fix released," but it's not clear where it's been released to. I'm not interested in waiting hours to days to verify this.

Revision history for this message
michael da cova (michael-dacova) wrote :

if this helps

Do you want to continue [Y/n]? y
Setting up apport (1.20.1-0ubuntu3) ...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed.
dpkg: error processing apport (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apport-gtk:
 apport-gtk depends on apport (>= 0.41); however:
  Package apport is not configured yet.
dpkg: error processing apport-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates it's a follow-up error from a previous failure.
                                                                                                            Errors were encountered while processing:
 apport
 apport-gtk
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
Presianbg (presianbg) wrote :

presque@presque-Aspire-6920:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up apport (1.20.1-0ubuntu3) ...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed.
dpkg: error processing apport (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of apport-gtk:
 apport-gtk depends on apport (>= 0.41); however:
  Package apport is not configured yet.
dpkg: error processing apport-gtk (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 apport
 apport-gtk
E: Sub-process /usr/bin/dpkg returned an error code (1)

 Here what i have got :)

Revision history for this message
Embridioum (embridioum) wrote : [Bug 767498] Re: package apport 1.20.1-0ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

I ran update through terminal when it crashed, but then I found that the
Update Manager had opened. Closed it, then ran my script again without
hassle.

Sorry for not making this statement the first time around. Didn't see the UM
until later.

/Mattias Janebrink via HTC Legend
Den 20 apr 2011 23.16 skrev "William Blake Galbreath" <
<email address hidden>>:
> Same problem here. Ran a regular daily update using GUI Update Manager.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (767682).
> https://bugs.launchpad.net/bugs/767498
>
> Title:
> package apport 1.20.1-0ubuntu3 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1
>
> Status in Apport crash detection/reporting:
> New
> Status in “apport” package in Ubuntu:
> Fix Released
> Status in “apport” source package in Natty:
> Fix Released
>
> Bug description:
> Binary package hint: apport
>
> Got this when running dist-upgrade:
>
> [...]
> Setting up ubuntuone-control-panel-gtk (1.0.0-0ubuntu1) ...
> Setting up apport (1.20.1-0ubuntu3) ...
> Installing new version of config file /etc/default/apport ...
> start: Job failed to start
> invoke-rc.d: initscript apport, action "start" failed.
> dpkg: error processing apport (--configure):
> subprocess installed post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of apport-gtk:
> apport-gtk depends on apport (>= 0.41); however:
> Package apport is not configured yet.
> dpkg: error processing apport-gtk (--configure):
> dependency problems - leaving unconfigured
> Processing triggers for libc-bin ...
> ldconfig deferred processing now taking place
> No apport report written because the error message indicates its a
followup error from a previous failure.
> Processing triggers for initramfs-tools ...
> update-initramfs: Generating /boot/initrd.img-2.6.38-8-generic
> Processing triggers for python-support ...
> Errors were encountered while processing:
> apport
> apport-gtk
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> ProblemType: Package
> DistroRelease: Ubuntu 11.04
> Package: apport 1.20.1-0ubuntu3
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic x86_64
> ApportLog:
>
> Architecture: amd64
> Date: Wed Apr 20 16:12:52 2011
> ErrorMessage: subprocess installed post-installation script returned error
exit status 1
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64
(20101007)
> PackageArchitecture: all
> SourcePackage: apport
> Title: package apport 1.20.1-0ubuntu3 failed to install/upgrade:
subprocess installed post-installation script returned error exit status 1
> UpgradeStatus: Upgraded to natty on 2011-04-15 (5 days ago)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/apport/+bug/767498/+subscribe

Revision history for this message
Philip Muškovac (yofel) wrote :

It's fixed in 1.20.1-0ubuntu4 which now needs to be built, published and synced to mirrors. That can take less than an hour to several hours.

Revision history for this message
David Strauss (davidstrauss) wrote :

@Philip If the fixed package hasn't even been built yet, it seems this issue is much closer to "fix committed" than "fix released."

Revision history for this message
Matthias Andree (matthias-andree) wrote :

Re comment #21: I'm not sure what exactly has been changed yet (haven't seen the new package), but the /etc/init/apport.conf was bogus:

pre-start script
    . /etc/default/apport
    [ "$enabled" = "1" ] || [ "$force_start" = "1" ]
...

This fails if neither enabled is 1 nor force_start is 1. It should be:

pre-start script
    . /etc/default/apport
    [ "$enabled" = "1" ] || [ "$force_start" = "1" ] || exit 0
...

Revision history for this message
Philip Muškovac (yofel) wrote :

@David: launchpad doesn't make a difference there as it tracks source packages, and the source package has been released.

Revision history for this message
Nathan Haines (nhaines) wrote :

@David "fix committed" means the appropriate development code has been patched but the version that will incorporate this patch has not been released yet. "fix released" means that the version has been locked off and... released. It's in the build phase, but short of running 'apt-get source apport' and patching it yourself then building your own Debian package and installing that there's not really anything that can be done to speed things up at this point.

Revision history for this message
Jack E (jackebob) wrote :

I've got it too

Revision history for this message
null (domfiore) wrote :

Same problem here.

Revision history for this message
cokekid (cokekid) wrote :

same problem here after clean install I did updates and some failed.

Revision history for this message
Angeloribas (angeloribas) wrote :

@ Radu Cristescu #17

" temporary fix: edit /var/lib/dpkg/info/apport.postinst and replace "exit $?" with "/bin/true" and apt-get -f install"

I can confirm that it worked for me.

Revision history for this message
Javi Molina (javich) wrote :

This is what I saw this morning when trying to update.

Extracting templates from packages: 47%%
Extracting templates from packages: 95%%
Extracting templates from packages: 100%%

Preconfiguring packages ...

Extracting templates from packages: 47%%
Extracting templates from packages: 95%%
Extracting templates from packages: 100%%

Preconfiguring packages ...

(Reading database ...
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 211713 files and directories currently installed.)

Preparing to replace libbamf0 0.2.90-0ubuntu1 (using .../libbamf0_0.2.90-0ubuntu2_i386.deb) ...

Unpacking replacement libbamf0 ...

Preparing to replace bamfdaemon 0.2.90-0ubuntu1 (using .../bamfdaemon_0.2.90-0ubuntu2_i386.deb) ...

Unpacking replacement bamfdaemon ...

Preparing to replace libtiff4 3.9.4-5ubuntu5 (using .../libtiff4_3.9.4-5ubuntu6_i386.deb) ...

Unpacking replacement libtiff4 ...

Preparing to replace ure 1.7.0+LibO3.3.2-1ubuntu3 (using .../ure_1.7.0+LibO3.3.2-1ubuntu4_i386.deb) ...

Unpacking replacement ure ...

Revision history for this message
Craig Barnes (craigbarnes-deactivatedaccount) wrote :

Also having the same issue on 64-bit arch. I had already cleaned my package cache so following the instructions in comment #15 reported non-existent package but downloading it anew as suggested in comment #20 seems to have fixed it. Thanks @pauljwells.

I've just updated apt and the "1.20.1-0ubuntu4" packages claiming to have fixed the issue are still not available. I'll come back and confirm the fix when they roll out.

Revision history for this message
Lojjik Braughler (llbraughler) wrote :

Errors were encountered while processing:
 apport
 apport-gtk
E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
Lojjik Braughler (llbraughler) wrote :

@Angeloribas
"@ Radu Cristescu #17

" temporary fix: edit /var/lib/dpkg/info/apport.postinst and replace "exit $?" with "/bin/true" and apt-get -f install"

I can confirm that it worked for me.
"

Confirmed here as well.

Revision history for this message
Craig Barnes (craigbarnes-deactivatedaccount) wrote :

The supposedly fixed packages were rolled out as I was typing my last comment but they still don't appear to have fix the issue. I checked the version numbers and changelog to make sure it was safe to upgrade again but apt is still not liking it. I'm reverting again until it's fixed.

Attached the terminal output in case it's of any help.

Revision history for this message
Toad213 (pikachu32) wrote :

If you use "sudo start apport force_start=1" after it tells you that it failed to start and then reinstall it, it shouldn't error out. The new packages are available, but you have to download them manually using a web browser.

Revision history for this message
Matthieu Baerts (matttbe) wrote :

About the new version (1.20.1-0ubuntu4), there is another bug report: bug #767829

Revision history for this message
Toad213 (pikachu32) wrote :

That bug also shows up on version (1.20.1-0ubuntu3).

Revision history for this message
Craig Barnes (craigbarnes-deactivatedaccount) wrote :

Thanks @Toad213, that worked. I have version 1.20.1-0ubuntu4 installed and apt is now behaving post-update.

I guess this issue is resolved, or rather replaced by bug #767829 as mentioned above.

Revision history for this message
Toad213 (pikachu32) wrote :

That bug, I think, is part of this one as it shows up after apport fails to start without forcing.

Revision history for this message
Andy Hill (neoshades) wrote :

+1

Revision history for this message
Martin (mbattiti) wrote :

And version 1.20.1-0ubuntu4 too

El mié, 20-04-2011 a las 23:15 +0000, Toad213 escribió:

> That bug also shows up on version (1.20.1-0ubuntu3).
>

Revision history for this message
Freyr Gunnar Ólafsson (gnarlin) wrote :

This is also in version 1.20.1-0ubuntu4.

Revision history for this message
bash321 (bash321) wrote :

This is also in version 1.20.1-0ubuntu4.

same problem in 64 bit architecture.

Revision history for this message
Luiz Augusto (luizaugustopc) wrote :

I got that error: package apport 1.20.1-0ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
I have updated Natty at 2011/04/20

Revision history for this message
Davide Alberelli (dadexix86) wrote :

The problem is also in 1.20.1-0ubuntu4:
__________
$
[...]
Configurazione di apport (1.20.1-0ubuntu4)...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed.
dpkg: errore nell'elaborare apport (--configure):
 il sottoprocesso vecchio script di post-installation ha restituito lo stato di errore 1
dpkg: problemi con le dipendenze impediscono la configurazione di apport-gtk:
 apport-gtk dipende da apport (>= 0.41), ma:
  Il pacchetto apport non è ancora configurato.
dpkg: errore nell'elaborare apport-gtk (--configure):
 problemi con le dipendenze - lasciato non configurato
Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
           Si sono verificati degli errori nell'elaborazione:
 apport
 apport-gtk
E: Sub-process /usr/bin/dpkg returned an error code (1)
_________________
AND trying manually:
_________________
$ sudo dpkg --configure apport-gtk
dpkg: problemi con le dipendenze impediscono la configurazione di apport-gtk:
 apport-gtk dipende da apport (>= 0.41), ma:
  Il pacchetto apport non è ancora configurato.
dpkg: errore nell'elaborare apport-gtk (--configure):
 problemi con le dipendenze - lasciato non configurato
Si sono verificati degli errori nell'elaborazione:
 apport-gtk

Revision history for this message
Toad213 (pikachu32) wrote :

If you open /etc/default/apport with gedit, you will see "enabled=0". Change this to "enabled=1" and try installing apport again.

Revision history for this message
Richard Merren (richard-merren) wrote :

I just did an update and an upgrade and a new version of apport and apport-gtk were available. The problem was resolved, though the upgrade did throw a warning that apport failed to start. I rebooted, and all seems well. I was able to launch apport-gtk from the command line, so I think it is functioning normally.

Revision history for this message
Jeffrey Minton (jeffrey-minton) wrote :

Just reinstalled apport-gtk and apport. Worked fine, installed apport (1.20.1-0ubuntu5) and apport-gtk (1.20.1-0ubuntu5)

Revision history for this message
anipet (anipet) wrote :

I just used

sudo service apport start force_start=1 # as suggested in /etc/default/apport and then

sudo apt-get update

sudo apt-get upgrade

and the problem seemed to have been solved now, my version is 1.20.1-ubuntu3

thanks for the output tho :)

Revision history for this message
Stolen (colin-shaw) wrote :

Just tried Toad213's fix, and it worked here with 1.20.1-ubuntu3

Revision history for this message
Observer (dbvweb) wrote :

Ah Toad213's fix worked. I added the '1', removed and installed apport, and everything worked just fine.

Revision history for this message
michael da cova (michael-dacova) wrote :

Seems to be a different error now, did a update/upgrade

Processing triggers for python-central ...
Setting up python-apport (1.20.1-0ubuntu5) ...
Processing triggers for python-central ...
Setting up apport (1.20.1-0ubuntu5) ...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed

anything else I could provide to which may help

Revision history for this message
Toad213 (pikachu32) wrote :

If you read my post #53, it should solve your problem.

Revision history for this message
susema (susema) wrote :

Same here and " temporary fix: edit /var/lib/dpkg/info/apport.postinst and replace "exit $?" with "/bin/true" and apt-get -f install" worked for me. Thank you @varun.

Revision history for this message
Ant Dickens (antonydickens) wrote :

Happened during running an update from the Update Manager

Revision history for this message
Davide Alberelli (dadexix86) wrote :

Solved with Toad213 workaround in post #53:
___
If you open /etc/default/apport with gedit, you will see "enabled=0".
Change this to "enabled=1" and try installing apport again.
___

Many thanks!!

Revision history for this message
Bill Pearce (pearceg) wrote :

Toad123's fix worked for me. Thanks.
 Was this the result of forgetting to re-enable after some work or should the line be 'enabled=0' by default? (i.e. is this a workaround or a solution?)

Revision history for this message
wizard10000 (wizard10000) wrote :

"Solved with Toad213 workaround in post #53:"

Ditto.

Revision history for this message
Ir0nsh007er (ir0n) wrote :

TY FOR ALL

**Toad213 wrote 13 hours ago: #53

If you open /etc/default/apport with gedit, you will see "enabled=0". Change this to "enabled=1" and try installing apport again.
**

WORK FOR ME

Revision history for this message
Richard Merren (richard-merren) wrote :

I wrote in comment #54 that I saw no additional problems, but I should add that on my next upgrade (I used update-manager, if that matters to anyone) I got a warning about needing a partial upgrade. I performed the partial upgrade and everything processed without issues. I don't see any signs of problems now.

For the record, I didn't do the workaround with "enabled" mentioned in #53. It may not be necessary with the latest version of apport being installed--it would be useful for others if those experiencing this error tried an upgrade without changing the file and posted whether or not the file change was necessary.

Revision history for this message
Philip Muškovac (yofel) wrote :

Folks, the ubuntu5 update will work even without the workaround, and if apport gives you a report about ubuntu5 failing to upgrade that's a wrongly titled bug for the ubuntu3 or ubuntu4 failures. You can ignore those by now.

Changed in apport:
status: New → Fix Committed
Revision history for this message
Alan Lord (theopensourcerer) wrote :

I just ran apt-get update, apt-get dist-upgrade on a Natty 64bit server...

Unpacking replacement python-problem-report ...
Preparing to replace python-apport 1.20.1-0ubuntu5 (using .../python-apport_1.20.1-0ubuntu5.1_all.deb) ...
Unpacking replacement python-apport ...
Preparing to replace apport 1.20.1-0ubuntu5 (using .../apport_1.20.1-0ubuntu5.1_all.deb) ...
Unpacking replacement apport ...
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for shared-mime-info ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up python-problem-report (1.20.1-0ubuntu5.1) ...
Processing triggers for python-central ...
Setting up python-apport (1.20.1-0ubuntu5.1) ...
Processing triggers for python-central ...
Setting up apport (1.20.1-0ubuntu5.1) ...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed.
Processing triggers for python-central ...

Sure this is fixed?

Revision history for this message
Anthony Harrington (linuxchemist) wrote :

As comment 67 said:
Folks, the ubuntu5 update will work even without the workaround, and if apport gives you a report about ubuntu5 failing to upgrade that's a wrongly titled bug for the ubuntu3 or ubuntu4 failures. You can ignore those by now.

So, this specific bug was fixed in 1.20.1-0ubuntu5.

Since your bug isn't related to 1.20.1-ubuntu4 or 1.20.1-ubuntu3 (like the title of this report), you could file a new one. Although i'd seriously urge you to read the above comments for solutions. Back when i had this issue, completely removing apport packages and then reinstalling them fixed the issue. Good luck!

Revision history for this message
Anthony Harrington (linuxchemist) wrote :

Sorry, comment 68*

Revision history for this message
David Cumps (cppege43-david) wrote :

I don't quite understand comment 68 & 70, are you saying we can ignore the "Job failed to start" in the upgrade of 1.20.1-0ubuntu5.1 which was rolled out today?

Because I'm getting this on an apt-get upgrade:

Setting up python-problem-report (1.20.1-0ubuntu5.1) ...
Processing triggers for python-central ...
Setting up python-apport (1.20.1-0ubuntu5.1) ...
Processing triggers for python-central ...
Setting up apport (1.20.1-0ubuntu5.1) ...
start: Job failed to start
invoke-rc.d: initscript apport, action "start" failed.
Processing triggers for python-central ...

And in syslog:
Sep 22 06:55:51 ip-10-234-34-27 init: apport pre-start process (16165) terminated with status 1
Sep 22 06:55:51 ip-10-234-34-27 init: apport post-stop process (16166) terminated with status 1

Revision history for this message
Anthony Harrington (linuxchemist) wrote :

Comment 68 advises us to open a new bug, since the title for this bug is very specific and your problem is not related to 1.20.1-0ubuntu3/1.20.1-oubuntu4. Nothing is being ignored: file a new bug ;)

Martin Pitt (pitti)
Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers