apport-gtk crashed with error in _compile(): bad character range

Bug #762998 reported by Steve Langasek on 2011-04-16
72
This bug affects 8 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: apport

tried to report a bug on update-manager, and apport itself crashed. Whoops. :-)

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: apport-gtk 1.20.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
ApportLog:

Architecture: amd64
CrashReports:
 600:0:0:1073796:2011-04-15 01:37:09.290632897 -0700:2011-04-15 01:41:01.442256349 -0700:/var/crash/libattr1.0.crash
 600:1000:1000:56815:2011-04-16 11:34:01.698091000 -0700:2011-04-16 11:34:43.218327532 -0700:/var/crash/_usr_bin_update-manager.1000.crash
 600:1000:1000:50415:2011-04-16 11:34:54.258397000 -0700:2011-04-16 11:39:29.539991360 -0700:/var/crash/_usr_share_apport_apport-gtk.1000.crash
 600:1000:1000:10911:2011-04-11 00:29:06.761473000 -0700:2011-04-11 00:29:33.681692290 -0700:/var/crash/_usr_bin_update-maintainer.1000.crash
Date: Sat Apr 16 11:34:55 2011
ExecutablePath: /usr/share/apport/apport-gtk
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with error in _compile(): bad character range
UpgradeStatus: Upgraded to natty on 2011-03-24 (22 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin mythtv plugdev sambashare src

Steve Langasek (vorlon) wrote :
tags: removed: need-duplicate-check
Changed in apport (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2011-09-14
visibility: private → public
Martin Pitt (pitti) on 2011-09-14
Changed in apport (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.23-0ubuntu1

---------------
apport (1.23-0ubuntu1) oneiric; urgency=low

  [ Brian Murray ]
  * data/package-hooks/source_ubiquity.py: Do not create a DuplicateSignature
    for bugs with a Traceback included as it is redundant

  [ Martin Pitt ]
  * New upstream release:
    - crashdb.py, crash-digger, dupdb-admin: Drop the concept of "duplicate DB
      consolidation". Such massive queries cause timeouts with e. g.
      Launchpad. Instead, update the status of potential master bugs in the
      crash DB whenever check_duplicate() is called. Note that this does not
      affect Ubuntu itself, just the retracers in the data center.
    - launchpad.py: Fix crash in close_duplicate() if master bug was already
      marked as a duplicate of the examined bug.
    - problem_report.py, load(): Fix missing last character if the last line
      in a multi-line field is not terminated with a newline.
    - launchpad.py: Fix test_marking_python_task_mangle() check to work with
      current Launchpad.
    - apport-retrace: If the user did not specify a --cache directory, create
      a shared one instead of letting the two install_packages() calls create
      their own. This ensures that the apt and dpkg status is up to date, and
      avoids downloading the package indexes multiple times. (LP: #847951)
    - apport-retrace: Give proper error mesage instead of AssertionError crash
      if a report does not contain standard Apport format data. (LP: #843221)
    - fileutils.py, get_new_reports(): Fix crash if report file disappears in
      the middle of the operation. (LP: #640216)
    - apport/ui.py, load_report(): Intercept another case of broken report
      files. (LP: #445142)
    - apport/report.py, standard_title(): Escape regular expression control
      characters in custom exception names. (LP: #762998)
  * data/package-hooks/source_ubiquity.py: Fix crash if
    prepare_duplicate_signature() does not return anything. (LP: #843911)
  * debian/control: Bump Standards-Version to 3.9.2 (no changes necessary).
 -- Martin Pitt <email address hidden> Wed, 14 Sep 2011 08:29:03 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers