apport displays empty dialog, demands an answer

Bug #750870 reported by Glen Ditchfield
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: apport

While I was using /usr/share/checkbox/scripts/suspend_test to test Natty suspend/resume, apport announced that a problem had been detected and attempted to report it. Eventually apport put up a dialog box with no title and no message, just No and Yes buttons. (Screen shot attached.) I guessed "no". AFAICT, the bug report was not submitted.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: apport 1.20-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CrashReports:
 644:108:4:0:2011-04-04 17:43:06.501481262 -0500:2011-04-04 17:43:06.501481262 -0500:/var/crash/linux-image-2.6.38-7-generic.135247.crash
 600:108:4:4339:2011-04-03 21:34:29.951899000 -0500:2011-04-03 21:34:30.951899000 -0500:/var/crash/linux-image-2.6.38-7-generic.139923.crash
 600:108:4:3309594:2011-04-04 18:49:51.175622000 -0500:2011-04-04 18:49:52.175622000 -0500:/var/crash/linux-image-2.6.38-7-generic.135086.crash
Date: Mon Apr 4 19:00:36 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64 (20110330)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: apport
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Glen Ditchfield (gjditchfield) wrote :
Revision history for this message
Martin Pitt (pitti) wrote :

Can you please attach any of the /var/crash/linux*.crash files that caused this?

Thanks!

Changed in apport (Ubuntu):
status: New → Incomplete
Revision history for this message
Serge Hallyn (serge-hallyn) wrote :

I get this too, and see

(apport-gtk:4501): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 14 char 10: Element 'markup' was closed, but the currently open element is 'ffffffff811842e0'

in the terminal.

Revision history for this message
Serge Hallyn (serge-hallyn) wrote :

Here is a crash image which causes that to happen

Revision history for this message
Martin Pitt (pitti) wrote :

This reproduces it nicely, thanks!

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: Incomplete → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in trunk.

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.20.1-0ubuntu2

---------------
apport (1.20.1-0ubuntu2) natty; urgency=low

  [ Brad Figg ]
  * The kernel team has decided that asking the user for a bunch of
    information which they may not be able to answer is the wrong thing to do.
    Therefore, all the propmpting of the user for said information has been
    removed. Also removed is the tagging of "needs-upstream-testing".

  [ Martin Pitt ]
  * Merge bug fixes from trunk:
    - apport-gtk: HTML-escape text for dialogs with URLs. (LP: #750870)
    - dump_acpi_tables.py: Check to see if acpi/tables dir is mounted first.
      Thanks Brian Murray. (LP: #729622)
    - man/apport-cli.1: Document recently added -w/--window option. Thanks
      Abhinav Upadhyay. (LP: #765600)
 -- Martin Pitt <email address hidden> Tue, 19 Apr 2011 11:04:57 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers