notifying users of assertion failures is confusing

Bug #729223 reported by Brian Murray
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: apport

I can understand the reasoning behind not reporting assertion failures (https://bugs.launchpad.net/ubuntu/+source/apport/+bug/479365/comments/2) however I think it creates a confusing experience for users. They get notified of a crash only to be told they can't report it? Ideally I don't think the user should be notified of these crashes if they will not be reported. Barring that more detailed information should be given as to why they aren't reported to better educate people and avoid this confusion.

Robert Roth (evfool)
Changed in apport (Ubuntu):
status: New → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in bzr, as per discussion with Sebastien.

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Low
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.20-0ubuntu1

---------------
apport (1.20-0ubuntu1) natty; urgency=low

  * New upstream release. Changes since our previous snapshot:
    - Add support for -w/--window option which will enable user to select a
      window as a target for filing a problem report. Thanks Abhinav Upadhyay.
      (LP: #357847)
    - Disable the filtering on SIGABRT without assertion messages. Turns out
      that developers want these crash reports after all. (LP: #729223)
    - Add support for a "DuplicateSignature" report fields. This allows
      package hooks to implement custom duplicate problem handling which
      doesn't need to be hardcoded in Apport itself. Update the launchpad
      backend to tag such bugs as "need-duplicate-check".
    - hookutils.py Update WifiSyslog regex to correctly catch application log
      messages in syslog. Thanks Mathieu Trudel-Lapierre. (LP: #732917)
    - hookutils.py, attach_hardware(): Avoid error message if machine does not
      have a PCI bus. Thanks Marcin Juszkiewicz. (LP: #608449)
    - backends/packaging-apt-dpkg.py: Replace deprecated getChanges() call
      with get_changes().
    - apport-gtk: Fix broken dialog heading if the name of the crashed program
      contains an & or other markup specific characters.
    - apport-gtk: Don't crash if GTK cannot be initialized. This usually
      happens without a $DISPLAY or when the session is being shut down. Just
      print an error message. If there are pending crashes, they will be shown
      again the next time a session starts. (LP: #730569)
  * debian/local/apport-chroot: In retracing mode, fix the passed --auth and
    --duplicate-db arguments to be paths within the fakechroot.
  * debian/local/apport-chroot: Apply the same absolute path fix to retracing
    mode that we already applied to login mode in 1.19-0ubuntu1.
 -- Martin Pitt <email address hidden> Fri, 18 Mar 2011 16:39:07 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers