apport fails to create crash file during upgrade to 11.04

Bug #683367 reported by Jean-Baptiste Lallement on 2010-11-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt
Natty
High
Martin Pitt

Bug Description

Binary package hint: apport

I've got bug 682843 during an upgrade from kubuntu 10.10 to 11.04 but apport failed to create the crash file.

The following error is displayed on the console:
Traceback (most recent call last):
  File "/usr/share/apport/package_hook", line 59, in <module>
    pr.write(open(apport.fileutils.make_report_path(pr), 'w'))
IOError: [Errno 2] No such file or directory: '/var/crash/base-files.0.crash'

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: apport 1.16-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-7.18-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
ApportLog:

Architecture: i386
CrashReports: 600:1000:1000:13365006:2010-11-30 01:02:20.000000000 +0100:2010-11-30 01:02:26.000000000 +0100:/var/crash/_usr_lib_thunderbird-3.1.6_thunderbird-bin.1000.crash
Date: Tue Nov 30 22:04:28 2010
EcryptfsInUse: Yes
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: apport

Jean-Baptiste Lallement (jibel) wrote :
tags: added: iso-testing
Changed in apport (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in apport (Ubuntu Natty):
importance: Undecided → High
Colin Watson (cjwatson) on 2010-12-01
Changed in apport (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

It seems /var/crash directory does not exist for you? Can you please give me the output of "ls -ld /var/crash"?

This directory is created at each start of apport, so I guess by now you would have rebooted your machine, so that the directory is back now? Do you happen to review if you did something like "sudo rm -r /var/crash", perhaps in an effort to clean up old reports?

Changed in apport (Ubuntu Natty):
assignee: Martin Pitt (pitti) → nobody
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

I can't reproduce the test now (not because it is not reproducible but because of the lack of available resources) but I noticed that /var/crash doesn't exist on a fresh install and enabled=0 in /etc/default/apport

This is a guess, but would it be possible that a crash during a release upgrade just after a fresh installation with apport disabled could cause this issue? But that would mean that apport is activated during a release upgrade, and of this, I am not sure.

Martin Pitt (pitti) wrote :

I'll create /var/crash/ in the postinst as well, that should do it.

Changed in apport (Ubuntu Natty):
assignee: nobody → Martin Pitt (pitti)
status: Incomplete → In Progress
Martin Pitt (pitti) wrote :

Fixed in bzr.

Changed in apport (Ubuntu Natty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.17.2-0ubuntu1

---------------
apport (1.17.2-0ubuntu1) natty; urgency=low

  * New upstream bug fix release:
    - Be more Python 3 compatible (not fully working with Python 3 yet,
      though).
    - apt/dpkg backend: Drop support for pre-0.7.9 python-apt API.
    - Add --tag option to add extra tags to reports. (LP: #572504)
    - hookutils.py, attach_dmesg(): Do not overwrite already existing dmesg.
    - hookutils.py: Be more robust against file permission errors.
      (LP: #444678)
    - ui.py: Do not show all the options in --help when invoked as *-bug.
      (LP: #665953)
    - launchpad.py: Adapt test cases to current standard_title() behaviour.
  * debian/control: Bump python-apt dependency to >= 0.7.9 to ensure that we
    have the current API. Trunk dropped support for the old API.
  * data/general-hooks/ubuntu.py: Ignore obsolete packages when filing bugs
    against update-manager. (LP: #397519)
  * data/general-hooks/ubuntu.py: Do not file a package install failure if
    DpkgTerminalLog doesn't have any data. (LP: #695887)
  * Add debian/apport.postinst: Create /var/crash. This directory is required
    for package failures even if apport is disabled and thus the upstart job
    does not run. (LP: #683367)
 -- Martin Pitt <email address hidden> Fri, 04 Feb 2011 15:46:40 +0100

Changed in apport (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers