ubuntu-bug should save reports offline automatically rather than giving a cryptic error message

Bug #657275 reported by Jack Leigh on 2010-10-09
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Apport
Medium
Unassigned
Contributor Console
Wishlist
Unassigned
apport (Ubuntu)
Wishlist
Unassigned

Bug Description

apport 1.13.3-0ubuntu2, Ubuntu 10.04

If trying to file a bug when there is no internet connection, apport gives some silly error message.
It would be better if the reports were automatically saved to disk with --save for later reporting.
Reporting could be timed to happen with Update Manager or something?
The error message could be more human in the mean-time.

<https://wiki.ubuntu.com/ContributorConsole#bugs>: "“Send _ Pending Reports” should be sensitive whenever Apport has at least one bug report queued for sending."

Jack Leigh (leighman) wrote :
Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

 - Bug reporting is not an end-user task. Ideally, we should not need apport ;-) . Not a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.
Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
affects: hundredpapercuts → apport
Changed in apport:
status: Invalid → New
Changed in apport (Ubuntu):
importance: Undecided → Wishlist
Philip Muškovac (yofel) wrote :

This would be useful indeed.

Changed in apport (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) wrote :

Right now it says

  Cannot connect to crash database, please check your Internet connection.

   <urlopen error [Errno -2] Name or service not known>

So it's not that "silly" IMHO, the first part is exactly saying what the problem is. However, it could instead say

    Do you want to save the report into a file for reporting later?

    [Save] [Cancel]

Changed in apport:
status: New → Triaged
tags: added: bitesize
Michael Spencer (ibelieve) wrote :

I think the message should also state that it can't send the report because there is no Internet connection.

How about merging the original and Martin Pitt's suggestion:

    Cannot connect to crash database, please check your Internet connection.
    Do you want to save the report into a file for reporting later?

    [Save] [Cancel]

Changed in apport (Ubuntu):
assignee: nobody → Michael Spencer (mdspencer)
status: Triaged → In Progress
Matthew Paul Thomas (mpt) wrote :

"Cannot connect to crash database, please check your Internet connection." is improvable in two ways. First, it's a run-on sentence. And second, the bug tracker is not a crash database. Error reports are sent to a database, but if you're offline they're queued silently, so this alert doesn't apply to that. This is just about bug reports sent to the bug tracker.

I suggest: "You can’t report a bug right now because there is no Internet connection. Do you want to save the report for later?" Make the alert disappear automatically if the Internet becomes connected while it's open.

Separately, you'd need a UI to list previously saved reports and submit a selected report, and an access point for displaying that list. The "Bugs" pane of the Contributor Console <https://wiki.ubuntu.com/ContributorConsole> would be one possible home for the list.

Evan (ev) on 2012-11-30
Changed in apport:
importance: Undecided → Medium
Changed in contributor-console:
assignee: nobody → Matthew Paul Thomas (mpt)
Changed in contributor-console:
status: New → Triaged
importance: Undecided → Wishlist
Changed in apport (Ubuntu):
assignee: Michael Spencer (mdspencer) → nobody
Michael Spencer (ibelieve) wrote :

Sorry I've taken so long on this and haven't fixed it. I haven't add much time and I'm still trying to learn Gtk. If no one else fixes this first, I'll still keep working on it, though. I'll also continue to work on the UI to display unreported bugs in Contributor Console. Sorry again that I've not been able to fix this yet.

Daniel Manrique (roadmr) on 2013-01-18
Changed in apport (Ubuntu):
status: In Progress → Triaged
Matthew Paul Thomas (mpt) wrote :
Changed in contributor-console:
assignee: Matthew Paul Thomas (mpt) → nobody
description: updated
Changed in apport (Ubuntu):
status: Triaged → Invalid
Changed in apport (Ubuntu):
status: Invalid → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers