apport-checkreports crashed with OSError in seen_report()

Bug #640216 reported by UpsI Forgot on 2010-09-16
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: apport

just booted my notebook, closed pidgin, started empathy, started opera - then the bug window appeared.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: apport 1.14.1-0ubuntu7
ProcVersionSignature: Ubuntu 2.6.35-21.31-generic 2.6.35.4
Uname: Linux 2.6.35-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Sep 16 08:49:32 2010
ExecutablePath: /usr/share/apport/apport-checkreports
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-checkreports
ProcEnviron:
 LANG=de_AT.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/apport/apport-checkreports']
SourcePackage: apport
Title: apport-checkreports crashed with OSError in seen_report()
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare video

UpsI Forgot (123itsame) wrote :
tags: removed: need-duplicate-check
Philip Muškovac (yofel) on 2011-03-19
visibility: private → public
Changed in apport (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2011-09-14
Changed in apport (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.23-0ubuntu1

---------------
apport (1.23-0ubuntu1) oneiric; urgency=low

  [ Brian Murray ]
  * data/package-hooks/source_ubiquity.py: Do not create a DuplicateSignature
    for bugs with a Traceback included as it is redundant

  [ Martin Pitt ]
  * New upstream release:
    - crashdb.py, crash-digger, dupdb-admin: Drop the concept of "duplicate DB
      consolidation". Such massive queries cause timeouts with e. g.
      Launchpad. Instead, update the status of potential master bugs in the
      crash DB whenever check_duplicate() is called. Note that this does not
      affect Ubuntu itself, just the retracers in the data center.
    - launchpad.py: Fix crash in close_duplicate() if master bug was already
      marked as a duplicate of the examined bug.
    - problem_report.py, load(): Fix missing last character if the last line
      in a multi-line field is not terminated with a newline.
    - launchpad.py: Fix test_marking_python_task_mangle() check to work with
      current Launchpad.
    - apport-retrace: If the user did not specify a --cache directory, create
      a shared one instead of letting the two install_packages() calls create
      their own. This ensures that the apt and dpkg status is up to date, and
      avoids downloading the package indexes multiple times. (LP: #847951)
    - apport-retrace: Give proper error mesage instead of AssertionError crash
      if a report does not contain standard Apport format data. (LP: #843221)
    - fileutils.py, get_new_reports(): Fix crash if report file disappears in
      the middle of the operation. (LP: #640216)
    - apport/ui.py, load_report(): Intercept another case of broken report
      files. (LP: #445142)
    - apport/report.py, standard_title(): Escape regular expression control
      characters in custom exception names. (LP: #762998)
  * data/package-hooks/source_ubiquity.py: Fix crash if
    prepare_duplicate_signature() does not return anything. (LP: #843911)
  * debian/control: Bump Standards-Version to 3.9.2 (no changes necessary).
 -- Martin Pitt <email address hidden> Wed, 14 Sep 2011 08:29:03 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers