Apport refuses to submit a bug because some packages are out of date. It should let the user decide.

Bug #546407 reported by Ævar Arnfjörð Bjarmason on 2010-03-24
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
apport (Debian)
Fix Released
Unknown
apport (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: apport

This is probably a duplicate, but I couldn't find anything already reported while searching around.

I just had a program crash and apport refused to submit a bug because some packages on my system were obsolete. Sometimes when this happens I know for sure that the packages that were not up to date were irrelevant to the bug that just happened.

There's APPORT_IGNORE_OBSOLETE_PACKAGES but that doesn't help you if the issue can't easily be reproduced and apport has just thrown away your report data.

Apport should say that packages aren't up to date and so this issue /might/ be fixed, but leave the choice of whether to send a bug or not up to the user.

ProblemType: Bug
ApportLog:

Architecture: i386
CheckboxSubmission: 0169f76fbe64c26c287457397cc58891
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Wed Mar 24 21:25:06 2010
DistroRelease: Ubuntu 10.04
Package: apport 1.13.1-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: apport
Uname: Linux 2.6.32-16-generic i686

MarcRandolph (mrand) wrote :

Howdy, and thank you for helping to improve Ubuntu by opening this ticket. This is similar to Bug #267488, but that one simply requests the user to be able to view the crash information.
This ticket requests the ability to override and submit the ticket anyway. I know that I personally need this as ability as well - mythtv auto-build packages get updated very frequently with very small changes and when a rare crash comes along, I need it submitted, not tossed because typo fix in a theme got pushed last night that I haven't had a chance to upgrade to.

Changed in apport (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in apport (Debian):
status: Unknown → New
Changed in apport (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.