apport-collect -p does not work any more

Bug #538944 reported by Martin Pitt
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt
Lucid
High
Martin Pitt

Bug Description

Binary package hint: apport

$ apport-collect -p linux 408991
Usage: apport-gtk <report number>

apport-gtk: error: no such option: -p

Martin Pitt (pitti)
Changed in apport (Ubuntu Lucid):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Martin Pitt (pitti)
Revision history for this message
Martin Pitt (pitti) wrote :

fixed in trunk r1730

Changed in apport (Ubuntu Lucid):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.13.1-0ubuntu1

---------------
apport (1.13.1-0ubuntu1) lucid; urgency=low

  [ Martin Pitt ]
  * New upstream bug fix release:
    - Update parse-segv to handle gdb 7.1 output.
    - Enhance test suite to work with gdb 7.1 as well, and catch future
      outputs.
    - UI: Add exception string to the "network error" dialog, to better tell
      what the problem is.
    - UI: Add back -p option to apport-collect/apport-update-bug (regression
      from 1.13). (LP: #538944)
    - launchpad.py: Add yet another workaround for LP#336866. (LP: #516381)
    - launchpad.py, download(): Ignore attachments with invalid key names.
    - Fix regression from 1.10 which made it impossible for a package hook to
      set a third-party crash database for non-native packages. (LP: #517272)
    - apport-cli: Create the 'details' string only if user wants to view
      details, and do not show files larger than 1MB. Thanks Scott Moser!
      (LP: #486122)
    - packaging-apt-dpkg.py: Silence apt.Cache() spewage to stdout with newer
      python-apt versions. (LP: #531518)
    - unkillable_shutdown: Add list of running processes and blacklisted pids
      to report. (LP: #537262)
    - Sort the report by key in the details view. (LP: #519416)

  [ Evan Dandrea ]
  * Move ubiquity's package-hook into apport, so that it can be used
    from the installed system to grab the logs in /var/log/installer.
 -- Martin Pitt <email address hidden> Sat, 20 Mar 2010 22:28:44 +0100

Changed in apport (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers