ubuntu-bug gives python stacktrace on ec2 instance

Bug #494615 reported by Scott Moser on 2009-12-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Thierry Carrez

Bug Description

Binary package hint: apport

running 'ubuntu-bug apport' on ec2 instance of lucid gives the following

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.
.hook /usr/share/apport/general-hooks/ubuntu.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/apport/report.py", line 599, in add_hooks_info
    symb['add_info'](self)
  File "/usr/share/apport/general-hooks/ubuntu.py", line 113, in add_info
    report['Ec2Ramdisk'] = urlopen(urljoin(metadata_url, 'ramdisk-id')).read()
  ---<snip>----
  File "/usr/lib/python2.6/urllib2.py", line 516, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
HTTPError: HTTP Error 404: Not Found

The problem is that the lucid images do not have a ramdisk. ramdisk-id in the metadata service returns 404.

ProblemType: Bug
Architecture: i386
Date: Wed Dec 9 17:27:25 2009
DistroRelease: Ubuntu 10.04
Ec2AMI: ami-033f6e46
Ec2AMIManifest: ubuntu-images-testing-us-west-1/ubuntu-lucid-daily-i386-server-20091209.manifest.xml
Ec2AvailabilityZone: us-west-1b
Ec2InstanceType: m1.small
Ec2Kernel: aki-633c6d26
Ec2Ramdisk: unavailable
Package: apport 1.9.6-0ubuntu1 [modified: usr/share/apport/general-hooks/ubuntu.py]
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: User Name 2.6.32-300.1-ec2
SourcePackage: apport
Tags: lucid ec2-images
Uname: Linux 2.6.32-300-ec2 i686

Scott Moser (smoser) wrote :
Scott Moser (smoser) wrote :

Here is a proposed patch for ubuntu.py.

Scott Moser (smoser) wrote :

Note, this bug was actually reported using the above patch, so its at least functionally tested.

Scott Moser (smoser) wrote :

Please see/review/sponsor above patch for apport.

Scott Moser (smoser) on 2009-12-16
Changed in apport (Ubuntu):
importance: Undecided → Medium
Thierry Carrez (ttx) on 2010-01-12
Changed in apport (Ubuntu):
assignee: nobody → Thierry Carrez (ttx)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.11-0ubuntu5

---------------
apport (1.11-0ubuntu5) lucid; urgency=low

  * ubuntu.py: Avoid errors when running on ramdiskless EC2 images, by only
    attaching available EC2 information. Patch from Scott Moser (LP: #494615)
 -- Thierry Carrez <email address hidden> Tue, 12 Jan 2010 12:19:32 +0100

Changed in apport (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers