kernel_crashdump crashed with OSError in <module>()

Bug #450295 reported by Mark Bodenstein
76
This bug affects 10 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: apport

Xubuntu 9,10 upgraded from 9.04
apport 1.9.2-0ubuntu2
system surprisingly shut down

ProblemType: Crash
Architecture: i386
Date: Tue Oct 13 13:11:58 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/share/apport/kernel_crashdump
InterpreterPath: /usr/bin/python2.6
Package: apport 1.9.2-0ubuntu2
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/kernel_crashdump
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-13.45-generic
PythonArgs: ['/usr/share/apport/kernel_crashdump']
SourcePackage: apport
Title: kernel_crashdump crashed with OSError in <module>()
Traceback:
 Traceback (most recent call last):
   File "/usr/share/apport/kernel_crashdump", line 34, in <module>
     os.unlink(vmcore_path)
 OSError: [Errno 2] No such file or directory: '/var/crash/vmcore'
Uname: Linux 2.6.31-13-generic i686
UserGroups:

Revision history for this message
Mark Bodenstein (m-bodenstein) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. If you could test the current Ubuntu development version, this would help us a lot. If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect 450295, and any other logs that are relevant for this particular issue.

visibility: private → public
Changed in apport (Ubuntu):
status: New → Incomplete
Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

Based on a duplicate from 2010-03-08, this bug is still valid. Thanks for taking the time to make Ubuntu better!

Changed in apport (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in trunk.

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.20.1-0ubuntu1

---------------
apport (1.20.1-0ubuntu1) natty; urgency=low

  * New upstream bug fix release:
    - Add bash completion support for new -w/--window option that was
      introduced in 1.20. Thanks Philip Muškovac.
    - apport-unpack: Fix crash if target directory already exists.
    - Fix crash if UnreportableReason is a non-ASCII string. (LP: #738632)
    - Fix crash if application from desktop name is a non-ASCII string.
      (LP: #737799)
    - unkillable_shutdown: Fix rare crash if ExecutablePath does not exist
      (any more). (LP: #537904)
    - kernel_crashdump: Fix crash if the vmcore file disappeared underneath
      us. (LP: #450295)
    - unkillable_shutdown: Fix crash if the checked process terminated
      underneath us. (LP: #540436)
    - ui.py: Properly raise exceptions from the upload thread that happen at
      its very end. (LP: #469943)
  * data/package-hooks/source_ubiquity.py: Read root-only accessible log files
    as root. (LP: #745455)
 -- Martin Pitt <email address hidden> Thu, 31 Mar 2011 17:37:16 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers