fire fox crash (apport assertion error: "assert (key != None and value != None)")

Bug #445142 reported by knightshade on 2009-10-07
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: apport

firefox crashed due to install at same time

ProblemType: Crash
Architecture: i386
CrashReports:
 600:0:0:25077:2009-10-07 00:47:04.618244000 +0000:2009-10-07 00:47:05.618244000 +0000:/var/crash/_usr_share_apport_apport-gtk.0.crash
 600:0:0:185034:2009-10-07 00:42:49.897224000 +0000:2009-10-07 00:42:50.897224000 +0000:/var/crash/kcachegrind.0.crash
 600:0:0:0:2009-10-07 00:42:50.846246058 +0000:2009-10-07 00:42:50.842245969 +0000:/var/crash/kbugbuster.0.crash
 600:0:0:0:2009-10-07 00:42:50.798224665 +0000:2009-10-07 00:42:50.794226601 +0000:/var/crash/kbruch.0.crash
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/share/apport/apport-gtk
InterpreterPath: /usr/bin/python2.6
MediaBuild: Ubuntu 9.04 "Jaunty Jackalope" - Release i386 (20090420.1)
Package: apport-gtk 1.0-0ubuntu5
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with AssertionError in load()
Uname: Linux 2.6.28-11-generic i686
UserGroups:

knightshade (highlnder93) wrote :
tags: removed: need-duplicate-check
Daniel Hahler (blueyed) on 2010-03-05
Changed in apport (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
visibility: private → public
summary: - fire fox crash
+ fire fox crash (apport assertion error: "assert (key != None and value
+ != None)")
Martin Pitt (pitti) on 2011-09-14
Changed in apport (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.23-0ubuntu1

---------------
apport (1.23-0ubuntu1) oneiric; urgency=low

  [ Brian Murray ]
  * data/package-hooks/source_ubiquity.py: Do not create a DuplicateSignature
    for bugs with a Traceback included as it is redundant

  [ Martin Pitt ]
  * New upstream release:
    - crashdb.py, crash-digger, dupdb-admin: Drop the concept of "duplicate DB
      consolidation". Such massive queries cause timeouts with e. g.
      Launchpad. Instead, update the status of potential master bugs in the
      crash DB whenever check_duplicate() is called. Note that this does not
      affect Ubuntu itself, just the retracers in the data center.
    - launchpad.py: Fix crash in close_duplicate() if master bug was already
      marked as a duplicate of the examined bug.
    - problem_report.py, load(): Fix missing last character if the last line
      in a multi-line field is not terminated with a newline.
    - launchpad.py: Fix test_marking_python_task_mangle() check to work with
      current Launchpad.
    - apport-retrace: If the user did not specify a --cache directory, create
      a shared one instead of letting the two install_packages() calls create
      their own. This ensures that the apt and dpkg status is up to date, and
      avoids downloading the package indexes multiple times. (LP: #847951)
    - apport-retrace: Give proper error mesage instead of AssertionError crash
      if a report does not contain standard Apport format data. (LP: #843221)
    - fileutils.py, get_new_reports(): Fix crash if report file disappears in
      the middle of the operation. (LP: #640216)
    - apport/ui.py, load_report(): Intercept another case of broken report
      files. (LP: #445142)
    - apport/report.py, standard_title(): Escape regular expression control
      characters in custom exception names. (LP: #762998)
  * data/package-hooks/source_ubiquity.py: Fix crash if
    prepare_duplicate_signature() does not return anything. (LP: #843911)
  * debian/control: Bump Standards-Version to 3.9.2 (no changes necessary).
 -- Martin Pitt <email address hidden> Wed, 14 Sep 2011 08:29:03 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers