apport-gtk crashed with ImportError in <module>()

Bug #433087 reported by jccochez on 2009-09-19
128
This bug affects 26 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: apport

it crashed just when it was sending a report for another bug... ironical isn't it?

ProblemType: Crash
Architecture: i386
Date: Sun Sep 13 17:54:13 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/share/apport/apport-gtk
InterpreterPath: /usr/bin/python2.6
Package: apport-gtk 1.9-0ubuntu6
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.34-generic
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with ImportError in <module>()
Traceback:
 Traceback (most recent call last):
   File "/usr/share/apport/apport-gtk", line 16, in <module>
     from apport import unicode_gettext as _
 ImportError: cannot import name unicode_gettext
Uname: Linux 2.6.31-10-generic i686
UserGroups:

jccochez (beretfantasy) wrote :
tags: removed: need-duplicate-check
C de-Avillez (hggdh2) on 2009-11-09
visibility: private → public
tags: added: hw-specifc
Martin Pitt (pitti) wrote :

What is the output of

  python -c 'from apport import unicode_gettext'

in a Terminal for you? I cannot reproduce this. Thanks!

Changed in apport (Ubuntu):
status: New → Incomplete
tags: added: bugpattern-needed
Eyad Salah (eyad-salah) wrote :

I'm getting the same error but running the command python -c 'from apport import unicode_gettext' does nothing for me

Ben Bates (cryptision) wrote :

There is obviously a glitch in the python stacks. I am getting alot of importer and indicator apport reports popping up. After running update manager (and that even popped up a apport python crash report) Am still rather new at bug hunting and programming,but does 10.10 maverick still use dbus?

Ben Bates (cryptision) wrote :

I forgot to add I noticed in the last update manager session the indicator session services was updated,thats when the other apport reports started cascading on me.

Ben Bates (cryptision) wrote :

Apport just crashed on me again. New definition for irony, a crash reporting system reporting itself crashing.

tags: added: amd64
Ben Bates (cryptision) wrote :

Yet another schizophrenic apport crash report on apport crashing ( I think thats my third or fourth one dealing with this bug). I do think this is one of the first apport crash that was buried underneath all the other crash reports that popped up.

aviramof (aviramof) wrote :

 python -c 'from apport import unicode_gettext' does nothing for me but i think it's fine now i did this sudo apt-get install --reinstall python-cups because someone told me about it in a different bug and now everything looks fine for now at least.

Philip Muškovac (yofel) wrote :

Notice: the apport-gtk crash in maverick is tracked in bug 603919 - the duplicate check of the retracer made a mistake there. That crash has nothing to do with this bug.

Confirmed also in 10.10 alpha 2...

Changed in apport (Ubuntu):
status: Incomplete → Invalid
Changed in apport (Ubuntu):
status: Invalid → Confirmed
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

Since at least 10.04 Apport now uses pycentral's --include-links, which should prevent this kind of crash, as the modules are always available during upgrade.

Changed in apport (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers