"ubuntu-bug xserver-xorg-video-intel" hangs after X server freeze

Bug #384408 reported by reini on 2009-06-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by reini

Bug Description

Binary package hint: apport

After an X server freeze related to bug 359392, ssh'ed into the machine (ssh -x user@machine) and ran "ubuntu-bug xserver-xorg-video-intel". After it had run for >40 mins, the output was as follows:

<output>

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.
...............Can't open display
.xdpyinfo: unable to open display "".
Error: unable to open display
Cannot open display ""
............................................................................................................................................................<snip: lots and lots of dots>
</output>

When I looked at the process list (ps aux), there were a lot of instances of "/usr/lib/ConsoleKit/ck-get-x11-server-pid" (way more than ten).
There is no crash report in /var/crash (neither for apport nor for X).

ProblemType: Bug
ApportLog:
 apport (pid 15155) Sat Jun 6 21:42:34 2009: called for pid 2883, signal 11
 apport (pid 15155) Sat Jun 6 21:42:36 2009: executable: /home/reini/distributed_computing/boinc-client/projects/climateprediction.net/hadcm3trans_6.04_i686-pc-linux-gnu (command line "hadcm3trans_6.04_i686-pc-linux-gnu hadcm3istd_css6_1920_160_06021434 1042_ocean.year yafbg.astart spec3a_sw_3_asol2b_hadcm3 spec3a_lw_3_asol2c_hadcm3 1042_flux_corr.anc hejihdck_0308_nickfluxcorr.anc def NAT_VOLC def DMSallNH3SO21900 SULPC_OXIDANTS_19_A2_1990.mod SULPC_OXIDANTS_19_A2_1990 def ozone_hadcm3_1900 solar_v00 ghg_cntrl volc_v00 def def def")
 apport (pid 15179) Sat Jun 6 21:42:34 2009: another apport instance is already running, aborting
 apport (pid 15155) Sat Jun 6 21:42:36 2009: executable does not belong to a package, ignoring
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: apport 1.0-0ubuntu5.2
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: apport
Uname: Linux 2.6.28-12-generic i686

reini (rrumberger) wrote :
reini (rrumberger) wrote :

Not a duplicate of 388143!
This one occurs in the cli, when run using "ssh -x" (i.e. *NO* X).

Martin Pitt (pitti) wrote :

I think it is a dupe, since something in the hooks tries to access X stuff. It's not inherently a problem of apport-gtk, but something in the package hooks, I believe. But *shrug*, let's keep this undup'ed until I found a solution for the other bug.

Am Freitag 19 Juni 2009 schrieb Martin Pitt:
> I think it is a dupe, since something in the hooks tries to access
> X stuff. It's not inherently a problem of apport-gtk, but
> something in the package hooks, I believe. But *shrug*, let's keep
> this undup'ed until I found a solution for the other bug.

Are you quite sure? The other bugreport seemed to be about ubuntu-bug
calling the wrong apport-*, resulting in a completely different
error, whereas in this bugreport apport-cli tries to do X server
stuff.

Marco Rodrigues (gothicx) wrote :

There is an improved version of ubuntu-bug, could you try again to see if it still gives the error about "display" ?

Thank you

reini (rrumberger) wrote :

Am Sonntag 13 September 2009 schrieb Marco Rodrigues:
> There is an improved version of ubuntu-bug, could you try again to
> see if it still gives the error about "display" ?

I can't seem to reproduce the X server freeze, so I'm afraid I can't
test this. (I will if another freeze happens, but I haven't had one
for ages now.)

Changed in apport (Ubuntu):
status: New → Fix Released
reini (rrumberger) wrote :

Managed to reproduce the X server hang: the bug in ubuntu-bug persists as described above.

Changed in apport (Ubuntu):
status: Fix Released → Confirmed
Marco Rodrigues (gothicx) wrote :

Looks like you're not using updates repository. Go to menu System -> Administration -> Software Sources and go to Updates Tab and select "Recommended updates (jaunty-updates)".

After run update-manager again and update your system.

reini (rrumberger) wrote :

What makes you think I wasn't using updates? I'm using updates, backports and proposed, as well as security.

Marco Rodrigues (gothicx) wrote :

Ups.. I'm sorry.. I was looking at Package: apport 1.0-0ubuntu5.2, but didn't look at the bug report date.

reini (rrumberger) wrote :

Am Mittwoch 14 Oktober 2009 schrieb Marco Rodrigues:
> Ups.. I'm sorry.. I was looking at Package: apport 1.0-0ubuntu5.2,
> but didn't look at the bug report date.

I see. :-)
Current info:

me@localhost> dpkg -s apport
Package: apport
Status: install ok installed
Priority: optional
Section: utils
Installed-Size: 540
Maintainer: Martin Pitt <email address hidden>
Architecture: all
Version: 1.0-0ubuntu5.4
Replaces: apport-cli, apport-gtk (<< 0.51)
Depends: python (>= 2.4), python-apport (>= 0.120), lsb-base (>=
3.0-6), sysv-rc (>= 2.86.ds1-14.1ubuntu2), python-xdg
Suggests: apport-gtk | apport-qt, python-launchpadlib
Conflicts: apport-cli, apport-gtk (<< 0.51)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers