could tag file conflicts installation issues

Bug #368435 reported by Sebastien Bacher on 2009-04-28
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Wishlist
Brian Murray
dpkg (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: apt

The file conflicts bugs are usually real issues easy to fix, having those auto-tagged for easier triaging would be useful

Related branches

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I looked into this today and its unfortunately not easy. Dpkg send error messages localized over its status pipe, this means that apt gets the localized version of:
 "trying to overwrite `%.250s', which is also in package %.250s"
the values in %.250s are filed in by dpkg.

So a string search is difficult as each language will be slightly different and dgettext("dpkg","trying to overwrite `%.250s', which is also in package %.250s"). I attach a string matcher that should work, but
I think it would be best to look for a better fix for this in dpkg itself.

Changed in apt (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Michael Vogt (mvo) wrote :
Brian Murray (brian-murray) wrote :

It seems to me that we we could at least tag the English ones as an interim step. Did you have a tag in mind Seb?

Sebastien Bacher (seb128) wrote :

not really, the upgrade bugs are tagged apport-package so what about apport-package-conflict?

Brian Murray (brian-murray) wrote :

Well I'd rather they were still searchable via apport-package so have chosen to add the tag package-conflict so these will be tagged 'apport-package' and 'package-conflict'.

Brian Murray (brian-murray) wrote :

This is actually happening in apport so I've changed the task to it.

affects: apt (Ubuntu) → apport (Ubuntu)
Changed in apport (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → In Progress
Changed in dpkg (Ubuntu):
status: New → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.21.2-0ubuntu11

---------------
apport (1.21.2-0ubuntu11) oneiric; urgency=low

  * data/general-hooks/ubuntu.py:
    - create a duplicate signature for package installation failures
    - tag install failures due to a package conflict 'package-conflict'
      (LP: #368435)
 -- Brian Murray <email address hidden> Wed, 10 Aug 2011 09:02:04 -0700

Changed in apport (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers