hook /usr/share/apport/general-hooks/automatix.py crashed

Bug #267004 reported by Juan Pablo Salazar Bertín on 2008-09-06
2
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: apport

snifer@snifer-laptop:~$ ubuntu-bug -p apport
hook /usr/share/apport/general-hooks/automatix.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/apport/report.py", line 531, in add_hooks_info
    symb['add_info'](self)
  File "/usr/share/apport/general-hooks/automatix.py", line 17, in add_info
    if apport.packaging.get_version('automatix') or \
  File "/usr/lib/python2.5/site-packages/apport/packaging_impl.py", line 56, in get_version
    return self._cache(package).installedVersion
  File "/usr/lib/python2.5/site-packages/apport/packaging_impl.py", line 51, in _cache
    raise ValueError, 'package does not exist'
ValueError: package does not exist

ProblemType: Bug
ApportLog:

Architecture: i386
CrashReports:
 600:1000:1000:480379:2008-09-01 14:21:35.000000000 -0400:2008-09-01 14:21:36.000000000 -0400:/var/crash/_usr_bin_gnome-screenshot.1000.crash
 600:1000:1000:1152486:2008-08-29 00:24:33.000000000 -0400:2008-08-29 00:28:43.000000000 -0400:/var/crash/_usr_bin_nm-connection-editor.1000.crash
 600:1000:1000:17579683:2008-08-30 04:27:45.000000000 -0400:2008-08-30 04:28:15.000000000 -0400:/var/crash/_usr_lib_firefox-3.0.1_firefox.1000.crash
 600:1000:1000:22379:2008-08-30 02:23:50.000000000 -0400:2008-08-30 02:23:55.000000000 -0400:/var/crash/_usr_lib_telepathy_telepathy-butterfly.1000.crash
DistroRelease: Ubuntu 8.10
Package: apport 0.114
PackageArchitecture: all
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: apport
Uname: Linux 2.6.27-2-generic i686

Henrik Nilsen Omma (henrik) wrote :

I get exactly the same thing when running 'ubuntu-bug gedit' or 'apport -f -p gedit'.

I don't have automatx installed, though I have installed standard restricted extras. Pedro tells me he cannot reproduce it.

I'm milestoning it because we are pointing everyone at ubuntu-bugs from https://help.ubuntu.com/community/ReportingBugs and need this to work well to get useful bug reports for beta

Changed in apport:
assignee: nobody → pitti
importance: Undecided → Medium
milestone: none → ubuntu-8.10-beta
status: New → Triaged
Martin Pitt (pitti) on 2008-09-16
Changed in apport:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.115

---------------
apport (0.115) intrepid; urgency=low

  [ Matt Zimmerman ]
  * Add apport/hookutils.py with some convenience functions for writing hook
    scripts (work in progress)
  * Extend ubuntu-bug to accept a path as an argument and look up the package
    name
  * Rename kernel_hook to kernel_crashdump (there are other kernel hooks)
  * Change kernel crash report type to KernelCrash
  * Fix automatix.py to not crash when automatix isn't installed (LP: #267004)
  * Add bin/kernel_oops hook to capture a kernel oops (eg. via kerneloops)

  [ Martin Pitt ]
  * Add AUTHORS file for collecting the list of major contributors and
    copyright holders.
  * apport/report.py: If we do not find a bug pattern file for the binary
    package, fall back to looking for one with the source package name.
  * run-tests: Provide a better error message if apport/packaging_impl.py does
    not exist.

  [ Brian Murray ]
  * apport/crashdb_impl/launchpad.py: Add regression-retracer tag to bugs
    which seem to be a regression (duplicate, and crash happens in a later
    version than the fix). (LP: #271876)

 -- Martin Pitt <email address hidden> Thu, 18 Sep 2008 18:18:03 -0700

Changed in apport:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers