apport-cli crashed with AssertionError in add_hooks_info()

Bug #203764 reported by Vojtěch Látal
8
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: apport

I tried to report a bug to Cheese through apport-cli with command
apport-cli -f -P 6697

Which outputed:

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.

and then traceback.

I think it is related only to apport. Not to Cheese.

ProblemType: Crash
Architecture: i386
Date: Wed Mar 19 00:50:21 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/apport-cli
InterpreterPath: /usr/bin/python2.5
Package: apport 0.104
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-cli -f -P 6697
PythonArgs: ['/usr/bin/apport-cli', '-f', '-P', '6697']
SourcePackage: apport
Title: apport-cli crashed with AssertionError in add_hooks_info()
Uname: Linux 2.6.24-8-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse games lpadmin mythtv netdev plugdev postgres powerdev pulse sambashare scanner tape users video

Revision history for this message
Vojtěch Látal (vojtik) wrote :
Revision history for this message
Martin Pitt (pitti) wrote :

Ah, this happens if you specify a PID that belongs to a program which is not packaged. Should get a proper error message.

Changed in apport:
assignee: nobody → pitti
importance: Undecided → Low
status: New → In Progress
Martin Pitt (pitti)
Changed in apport:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.106

---------------
apport (0.106) hardy; urgency=low

  [ Martin Pitt ]
  * apport/crashdb_impl/launchpad.py: Fix spelling mistake in p-lp-bugs API
    (now corrected there).
  * apport_python_hook.py: Catch IndexError for invalid sys.argv[0], too.
    (LP: #204940)
  * apport/ui.py: Add test_run_report_bug_unpackaged_pid() test case which
    reports a bug against a pid which belongs to an unpackaged program. This
    reproduces LP #203764.
  * apport/report.py: Drop add_hooks_info() assertion on nonexisting Package
    field, return silently instead. This conforms to the behaviour of the
    other add_*_info() functions and avoids nasty error handling.
  * apport/ui.py: Generate proper error message when calling with -f -p PID
    and PID belongs to an unpackaged program. (LP: #203764).

  [ Sebastien Bacher ]
  * po/Makevars: add the --language=python xgettext option so the translations
    template is correctly updated on build since cdbs is using intltool-update
    directly and not the corresponding makefile target

 -- Martin Pitt <email address hidden> Tue, 01 Apr 2008 16:02:46 +0200

Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers