apport-cli crashed with IOError in mark_report_seen()

Bug #201819 reported by Raúl Soriano
6
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: apport

Release: Hardy with the last updates

I was trying to report a bug and and wrote "apport-cli -c /var/crash" instead of "apport/cli -c /var/crash/crashfile".

Instead of giving an error message (it's a directory, not a crash file) or processing the whole directory (every crash file inside it) or something like that, apport crashed.

ProblemType: Crash
Architecture: amd64
Date: Thu Mar 13 15:31:14 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/apport-cli
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: apport 0.103
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-cli -c /var/crash
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=es_ES.UTF-8
PythonArgs: ['/usr/bin/apport-cli', '-c', '/var/crash']
SourcePackage: apport
Title: apport-cli crashed with IOError in mark_report_seen()
Uname: Linux 2.6.24-12-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare scanner src video

Revision history for this message
Raúl Soriano (gatoloko) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Possible regression detected

This crash has the same stack trace characteristics as bug #146464. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in bzr head, will upload to Hardy soon.

Changed in apport:
assignee: nobody → pitti
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.105

---------------
apport (0.105) hardy; urgency=low

  * apport/crashdb_impl/launchpad.py: Ignore ValueErrors when subscribing a
    team, since these are usually due to the team already being subscribed.
  * apport/report.py, anonymize(): Be robust against empty user names and only
    anonymize fields which can potentially contain user specific data.
    (LP: #195706)
  * backends/packaging-apt-dpkg.py, get_architecture(): Return 'unknown'
    instead of None if package architecture cannot be determined.
    (LP: #198548)
  * apport/ui.py, run_crash(): Intercept other IOErrors, too (such as EISDIR)
    and print out proper error message instead of crashing. (LP: #201819)
  * apport_python_hook.py: If the Python script has mutilated sys.argv so that
    even sys.argv[0] does not exist any more, fall back into readlink()ing
    /proc/pid/exe and gracefully handle the failure of that, instead of
    crashing in the crash handler (ugh). Add test case. (LP: #198183)

 -- Martin Pitt <email address hidden> Tue, 18 Mar 2008 23:04:57 +0100

Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers