incorrectly lists "snd" in NonfreeKernelModules

Bug #199927 reported by Kees Cook
2
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: apport

When reporting a crash in usplash I noticed that apport lists "snd" in NonfreeKernelModules. Strangely, the /var/crash/_sbin_usplash.0.crash file shows:

  NonfreeKernelModules: cdrom

Neither cdrom nor snd should be reported as non-free. Additionally, only free modules are loaded:

$ lsmod | grep -v ^Module | cut -d" " -f1 | xargs -n1 modinfo | grep license | sort | uniq -c
      1 license: Dual BSD/GPL
    116 license: GPL
      3 license: GPL and additional rights

Revision history for this message
Kees Cook (kees) wrote :

lsmod output

Revision history for this message
Kees Cook (kees) wrote :

Raw usplash crash with CoreDump removed.

Revision history for this message
Kees Cook (kees) wrote :

I've attached a branch with fixes for this, as well as test cases for various module types.

Changed in apport:
status: New → Triaged
Revision history for this message
Martin Pitt (pitti) wrote :

Merged into trunk, thank you! Can you please mark your branch as 'merged'?

Changed in apport:
assignee: nobody → pitti
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.104

---------------
apport (0.104) hardy; urgency=low

  [ Martin Pitt ]
  * apport/crashdb_impl/launchpad.py, get_source_version(): re-escape the
    package name so that it doesn't stumble over '+' and similar characters.
  * apport/ui.py tests: assert that ProcEnviron is also included into bug
    reports where we do not have a PID, since having the local information is
    interesting and important (and acceptable in terms of personal
    information).
  * apport/report.py: Split out method add_proc_environ() for getting
    ProcEnviron, so that we can call it separately.
  * apport/ui.py, run_report_bug(): Add ProcEnviron if we do not have a pid to
    file a bug against. This way, bugs filed against packages or distro also
    get locale information. (LP: #198514)
  * apport/fileutils.py, mark_report_seen(): Do not crash if the file does not
    exist any more, because it was removed underneath us. (LP: #199932)
  * apport/ui.py, test_collect_info_exepath(): Add a tuple argument and a
    CompressedValue to the test report. This reproduces LP #199349.
  * apport/report.py, anonymize(): Only work on string values. (LP: #199349)
  * apport/ui.py: If a report has a field "Ignore", entirely ignore the report
    without even presenting an explanatory error dialog (as
    "UnsupportableReason" does). Document this in doc/package-hooks.txt.
  * debian/control: Bump Standards-Version (no changes necessary).
  * debian/control: Fix wrongly spelt project names (Python and GTK+). Thanks
    to lintian's scrutiny.
  * gtk/apport-gtk-mime.desktop.in, qt4/apport-qt-mime.desktop.in: Add a main
    category.

  [ Kees Cook ]
  * apport/report.py: fix module license checking logic (LP: #199927).
    - nonfree_modules: being unable to find a module should not mean the
      module is non-free.
    - test_module_license_evaluation: check modinfo reporting.
  * problem_report.py: Skip atime test case if file system is mounted noatime.

 -- Martin Pitt <email address hidden> Thu, 13 Mar 2008 14:01:30 +0100

Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers