Apport dies when it tries to catch displayconfig bug

Bug #198183 reported by Scott Kitterman
2
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt

Bug Description

Binary package hint: apport

This happens every time:

Traceback (most recent call last):
  File "/usr/bin/displayconfig", line 1720, in <module>
    displayapp = DisplayApp()
  File "/usr/bin/displayconfig", line 448, in __init__
    self._buildGUI()
  File "/usr/bin/displayconfig", line 664, in _buildGUI
    w = GfxCardWidget(vbox,self.xsetup, gfxcard, self.gfxcarddialog, self.monitordialog)
  File "/usr/share/python-support/kde-guidance/displayconfigwidgets.py", line 640, in __init__
    self._syncGUI()
  File "/usr/share/python-support/kde-guidance/displayconfigwidgets.py", line 741, in _syncGUI
    self.driverlabel.setText(self.gfxcard.getGfxCardModel().getProprietaryDriver())
TypeError: argument 1 of QLabel.setText() has an invalid type
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/apport_python_hook.py", line 42, in apport_excepthook
    binary = os.path.realpath(os.path.join(os.getcwdu(), sys.argv[0]))
IndexError: list index out of range

I added a couple of debug prints to see what might be going on. "print sys.argv[0]" produces:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/apport_python_hook.py", line 40, in apport_excepthook
    print sys.argv[0]
AttributeError: 'module' object has no attribute 'argv'

I did look and sys is imported, so I'm not sure what is causing this.

Changed in apport:
status: New → Confirmed
Changed in apport:
importance: Undecided → Medium
status: Confirmed → New
Revision history for this message
Scott Kitterman (kitterman) wrote :

I just completed reviewing the open guidance bugs and I see multiple instances of this. Confirming.

Changed in apport:
status: New → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in bzr head.

Changed in apport:
assignee: nobody → pitti
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.105

---------------
apport (0.105) hardy; urgency=low

  * apport/crashdb_impl/launchpad.py: Ignore ValueErrors when subscribing a
    team, since these are usually due to the team already being subscribed.
  * apport/report.py, anonymize(): Be robust against empty user names and only
    anonymize fields which can potentially contain user specific data.
    (LP: #195706)
  * backends/packaging-apt-dpkg.py, get_architecture(): Return 'unknown'
    instead of None if package architecture cannot be determined.
    (LP: #198548)
  * apport/ui.py, run_crash(): Intercept other IOErrors, too (such as EISDIR)
    and print out proper error message instead of crashing. (LP: #201819)
  * apport_python_hook.py: If the Python script has mutilated sys.argv so that
    even sys.argv[0] does not exist any more, fall back into readlink()ing
    /proc/pid/exe and gracefully handle the failure of that, instead of
    crashing in the crash handler (ugh). Add test case. (LP: #198183)

 -- Martin Pitt <email address hidden> Tue, 18 Mar 2008 23:04:57 +0100

Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers