clutters data fields with "User Name" strings

Bug #195706 reported by Vojtěch Látal
10
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: apport

When some app crashes (dasher in this case, but it is not related to this bug - it did not depend on which app crashed) and apport catches that, it collects some info and such stuff and then opens web page in browser. But this address is evidently incorrect "https://bugs.launchpad.net/ubuntu/+source/User%20NamedUser%20NameaUser%20NamesUser%20NamehUser%20NameeUser%20NamerUser%20Name/+filebug/A0I9n0Lb4cvYaQhOKlltCUYAolp?field.title=User+NamedUser+NameaUser+NamesUser+NamehUser+NameeUser+NamerUser+Name+crashed+with+signal+User+Name1User+Name1User+Name+in+User+NamegUser+NametUser+NamekUser+Name_User+NametUser+NamerUser+NameeUser+NameeUser+Name_User+NamemUser+NameoUser+NamedUser+NameeUser+NamelUser+Name_User+NamegUser+NameeUser+NametUser+Name_User+NamevUser+NameaUser+NamelUser+NameiUser+NamesUser+NametUser+Name+User+Name()" the page title is "Error: Page not found".

I expected, that web page opened in browser will allow me to enter some details about what happened.

It seems to be related to apport package.
apport is version 0.103 (i have upgraded changes before a while and did not restarted apport nor computer)

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

Revision history for this message
Martin Pitt (pitti) wrote :

What does this command show to you (in a Terminal)?

  gconftool --get /desktop/gnome/url-handlers/http/command

Changed in apport:
status: New → Incomplete
Revision history for this message
Martin Pitt (pitti) wrote :

Also, if you do this in a Terminal:

  ubuntu-bug -p pmount

Does this guide you to https://bugs.launchpad.net/ubuntu/+source/pmount/+filebug/<somerandomnumbers> or also to a very weird URL with lots of "NamelUser" stuff?

Revision history for this message
Vojtěch Látal (vojtik) wrote :

That command (gconftool) outputs "firefox %s" without quotes.
According to what I wrote: the browser opens incorrect page.

The second command (ubuntu-bug) opens
https://bugs.launchpad.net/ubuntu/+source/User%20NamepUser%20NamemUser%20NameoUser%20NameuUser%20NamenUser%20NametUser%20Name/+filebug/bsPVtjuEleNyJPUg9jhxxIqcxjl?
So, the weird one.

If I would help somehow, feel free to let me know.

Revision history for this message
Martin Pitt (pitti) wrote :

Ah, interestingly the letters after "User%20Name" in succession are the right package name (dasher and pmount). So something inserts those "User%20Name" strings all over the place.

Revision history for this message
Martin Pitt (pitti) wrote :

Can you please do the following:

 * Create a fake crash report with: sh -c 'kill -SEGV $$'

 * Apport pops up, please let it collect data. When it asks you to send the report to Launchpad, cancel.

 * Attach /var/crash/_bin_dash.1000.crash and /var/log/apport.log here.

Thank you!

Revision history for this message
Vojtěch Látal (vojtik) wrote :
Revision history for this message
Vojtěch Látal (vojtik) wrote :
Revision history for this message
Martin Pitt (pitti) wrote :

Ah, seems all fields that the user interface adds during data collection have this crap, including the fields from gdb.

Can you please remove all old crash reports (sudo rm /var/crash/*), unless you need them for something still, and run the test suite?

  /usr/share/apport/testsuite/run-tests

Can you please copy&paste the output?

Revision history for this message
Vojtěch Látal (vojtik) wrote :
Revision history for this message
Martin Pitt (pitti) wrote :

Ah, I think I know the culprit. I bet you two have an empty real name set. I take it that

  getent passwd `id -u` | cut -f5 -d:

just produces some commas, not your real name?

I'll fix that in apport. Thanks for the report!

Changed in apport:
assignee: nobody → pitti
importance: Undecided → High
status: Incomplete → In Progress
Revision history for this message
Vojtěch Látal (vojtik) wrote :

You're right, Martin.
I think I have real name filled before upgrade to hardy. But i'm not sure.
Now I can use apport again:-)

Thanks for your work!

Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in the development version. Will upload soon.

Changed in apport:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.105

---------------
apport (0.105) hardy; urgency=low

  * apport/crashdb_impl/launchpad.py: Ignore ValueErrors when subscribing a
    team, since these are usually due to the team already being subscribed.
  * apport/report.py, anonymize(): Be robust against empty user names and only
    anonymize fields which can potentially contain user specific data.
    (LP: #195706)
  * backends/packaging-apt-dpkg.py, get_architecture(): Return 'unknown'
    instead of None if package architecture cannot be determined.
    (LP: #198548)
  * apport/ui.py, run_crash(): Intercept other IOErrors, too (such as EISDIR)
    and print out proper error message instead of crashing. (LP: #201819)
  * apport_python_hook.py: If the Python script has mutilated sys.argv so that
    even sys.argv[0] does not exist any more, fall back into readlink()ing
    /proc/pid/exe and gracefully handle the failure of that, instead of
    crashing in the crash handler (ugh). Add test case. (LP: #198183)

 -- Martin Pitt <email address hidden> Tue, 18 Mar 2008 23:04:57 +0100

Changed in apport:
status: Fix Committed → Fix Released
Revision history for this message
Pavel Mlčoch (pavkamlc) wrote :

I can confirm, It works now. Bug can be closed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers