`ubuntu-bug` fails with "UnboundLocalError: local variable 'project' referenced before assignment"

Bug #1884221 reported by Chris Guiver on 2020-06-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Brian Murray

Bug Description

I just tried to `ubuntu-bug ubiquity` on a groovy(20.10) qa-test install using Xubuntu, however `ubuntu-bug` abended with python errors.

I tried to file this with `ubuntu-bug apport` & again errors (but scanning it looks identical)

I'm filing this report on my primary box and will apport-collect after filing, plus copy/paste the details from the actual box.

"UnboundLocalError: local variable 'project' referenced before assignment"

xubuntu@xubuntu:~$ ubuntu-bug ubiquity
Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 597, in <module>
    app.run_argv()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 708, in run_argv
    return self.run_report_bug()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 549, in run_report_bug
    self.file_report()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 1396, in file_report
    url = self.crashdb.get_comment_url(self.report, ticket)
  File "/usr/lib/python3/dist-packages/apport/crashdb_impl/launchpad.py", line 247, in get_comment_url
    if not project:
UnboundLocalError: local variable 'project' referenced before assignment

xubuntu@xubuntu:~$ ubuntu-bug apport
Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 597, in <module>
    app.run_argv()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 708, in run_argv
    return self.run_report_bug()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 549, in run_report_bug
    self.file_report()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 1396, in file_report
    url = self.crashdb.get_comment_url(self.report, ticket)
  File "/usr/lib/python3/dist-packages/apport/crashdb_impl/launchpad.py", line 247, in get_comment_url
    if not project:
UnboundLocalError: local variable 'project' referenced before assignment

---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu40
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.451
CurrentDesktop: XFCE
DistroRelease: Ubuntu 20.10
LiveMediaBuild: Xubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200619)
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
Package: apport 2.20.11-0ubuntu40
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 5.4.0-26.30-generic 5.4.30
Tags: groovy
Uname: Linux 5.4.0-26-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True

apport information

tags: added: apport-collected groovy
description: updated

apport information

description: updated
summary: - `ubuntu-bug ubiquity` fails with python errors; groovy
+ `ubuntu-bug` fails with "UnboundLocalError: local variable 'project'
+ referenced before assignment"
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1884221

tags: added: iso-testing
Chris Guiver (guiverc) wrote :

(apport-gtk:42001): dbind-WARNING **: 20:13:43.547: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 597, in <module>
    app.run_argv()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 708, in run_argv
    return self.run_report_bug()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 549, in run_report_bug
    self.file_report()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 1396, in file_report
    url = self.crashdb.get_comment_url(self.report, ticket)
  File "/usr/lib/python3/dist-packages/apport/crashdb_impl/launchpad.py", line 247, in get_comment_url
    if not project:
UnboundLocalError: local variable 'project' referenced before assignment

on another run of `ubuntu ubiquity`

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Dan Watkins (oddbloke) wrote :

I've also seen this while running `ubuntu-bug /var/crash/...`.

Changed in apport (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Brian Murray (brian-murray)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.11-0ubuntu42

---------------
apport (2.20.11-0ubuntu42) groovy; urgency=medium

  * Fix pep8 errors regarding ambiguous variables.

 -- Brian Murray <email address hidden> Wed, 24 Jun 2020 09:15:51 -0700

Changed in apport (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers