apport-gtk and apport-kde install xiterm+thai as dependency (x-terminal-emulator)

Bug #1881976 reported by Adam Kosseck on 2020-06-03
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Dariusz Gadomski
Focal
Medium
Dariusz Gadomski

Bug Description

[Impact]

 * When installing apport-gtk (or apport-kde) on a non-GUI installation (cloud image, server image) as a dependency providing x-terminal-emulator xiterm+thai package is pulled in, which is not appropriate for most locales.
My understanding is it was selected due to lowest number of unsatisfied dependencies.

[Test Case]

 * lxc launch ubuntu:20.04 test
 * lxc shell test
 * apt update
 * apt install apport-gtk
 * Examine the packages listed to be installed: xiterm+thai is one of them.

[Regression Potential]

 * In dedicated archive mirrors with limited number of packages changing that may cause errors due to packages missing in the archive. However, that's unlikely.

[Other Info]

 * It is not affecting bionic, since x-terminal-emulator is listed as 'Suggests' not 'Depends' there.
 * Original bug description:

Vanilla install of Ubuntu 20.04 set to an Australian locale includes the "Thai X Terminal" package.
This package should not be included.

I noticed that it is also reported against Xubuntu and Lubuntu:
https://bugs.launchpad.net/lubuntu-next/+bug/1747341

Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1881976

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Dariusz Gadomski (dgadomski) wrote :

SRU proposal for groovy.

description: updated
tags: added: sts
no longer affects: xiterm+thai (Ubuntu Eoan)
Dariusz Gadomski (dgadomski) wrote :

SRU proposal for focal

description: updated
tags: added: patch
Changed in xiterm+thai (Ubuntu Focal):
importance: Undecided → Medium
Changed in xiterm+thai (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in xiterm+thai (Ubuntu Focal):
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in xiterm+thai (Ubuntu):
status: New → In Progress
Changed in xiterm+thai (Ubuntu Focal):
status: New → In Progress
no longer affects: xiterm+thai (Ubuntu)
no longer affects: xiterm+thai (Ubuntu Focal)
Changed in apport (Ubuntu):
status: New → In Progress
Changed in apport (Ubuntu Focal):
status: New → In Progress
Changed in apport (Ubuntu):
importance: Undecided → Medium
Changed in apport (Ubuntu Focal):
importance: Undecided → Medium
Changed in apport (Ubuntu):
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in apport (Ubuntu Focal):
assignee: nobody → Dariusz Gadomski (dgadomski)
summary: - xiterm+thai installed by default in Ubuntu 20.04 (Australian Locale)
+ apport-gtk and apport-kde install xiterm+thai as dependency (x-terminal-
+ emulator)
description: updated
Dariusz Gadomski (dgadomski) wrote :

SRU proposal for groovy

Dariusz Gadomski (dgadomski) wrote :

SRU proposal for focal.

tags: added: sts-sponsor-dgadomski
Eric Desrochers (slashd) wrote :

[sts-sponsor]

Sponsored in active development release (groovy)

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.11-0ubuntu43

---------------
apport (2.20.11-0ubuntu43) groovy; urgency=medium

  * d/control: Offer real package alternatives along with x-terminal-server
    for apport-gtk and apport-kde (LP: #1881976).

 -- Dariusz Gadomski <email address hidden> Thu, 23 Jul 2020 08:52:46 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released

Hello Adam, or anyone else affected,

Accepted apport into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apport/2.20.11-0ubuntu27.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in apport (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Marc Deslauriers (mdeslaur) wrote :

Unfortunately, this SRU has been superseded by a security update. Please re-upload the SRU. Thanks!

Timo Aaltonen (tjaalton) wrote :

Hello Adam, or anyone else affected,

Accepted apport into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apport/2.20.11-0ubuntu27.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Eric Desrochers (slashd) wrote :

[sts-sponsor note]

Package doesn't build due to new pycodestyle (2.6.0-1~20.04.1) found in focal-proposed as opposed to its former version (2.5.0-2) that now detects the following during the test:

Running pycodestyle...
./setup.py:78:33: E741 ambiguous variable name 'l'
./test/test_fileutils.py:380:13: E741 ambiguous variable name 'l'
./test/test_signal_crashes.py:141:13: E741 ambiguous variable name 'l'
./test/test_ui.py:1773:43: E741 ambiguous variable name 'l'
./backends/packaging-apt-dpkg.py:1222:13: E741 ambiguous variable name 'l'
./backends/packaging-apt-dpkg.py:1233:17: E741 ambiguous variable name 'l'
./build/lib/apport/__init__.py:67:13: E741 ambiguous variable name 'l'
./build/lib/apport/fileutils.py:332:9: E741 ambiguous variable name 'l'
./build/lib/apport/hookutils.py:620:9: E741 ambiguous variable name 'l'
./build/lib/apport/hookutils.py:630:9: E741 ambiguous variable name 'l'

This has been addressed in apport groovy where ambiguous 'l' have been replaced by 'line'.

# d/changelog
apport (2.20.11-0ubuntu42) groovy; urgency=medium

  * Fix pep8 errors regarding ambiguous variables.

 -- Brian Murray <email address hidden> Wed, 24 Jun 2020 09:15:51 -0700

Patch example:
...
- for l in lines:
- fd.write(l)
+ for line in lines:
+ fd.write(line)
...

The same fix now need to be applied into focal for the package to start building again.

Eric Desrochers (slashd) wrote :

The apport (2.20.11-0ubuntu27.6) security channel build haven't been caught in that FTBFS situation because it was tested against the former pycodestyle package:
Get:310 http://ftpmaster.internal/ubuntu focal/universe amd64 pycodestyle all 2.5.0-2 [5092 B]

Adam Kosseck (adam.kosseck) wrote :

Please advise once a focal package is available for testing.

Dariusz Gadomski (dgadomski) wrote :

The fix has been superseded by a security update. In the meantime a concurrent update of pycodestyle broke the apport build. I have backported fixes to the build issue from Groovy and uploaded the patch yesterday. Once the update is reviewed it should be available via the -proposed pocket.

Changed in apport (Ubuntu Focal):
status: Fix Committed → In Progress
Łukasz Zemczak (sil2100) wrote :

Hello Adam, or anyone else affected,

Accepted apport into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apport/2.20.11-0ubuntu27.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in apport (Ubuntu Focal):
status: In Progress → Fix Committed
Dariusz Gadomski (dgadomski) wrote :

I can verify that version 2.20.11-0ubuntu27.8 for focal fixes the issue.

Running on server install:
sudo apt install apport-gtk
apt offers gnome-terminal as dependency.

sudo apt install apport-kde
pulls in konsole as dependency.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.11-0ubuntu27.8

---------------
apport (2.20.11-0ubuntu27.8) focal; urgency=medium

  [Brian Murray]
  * Fix pep8 errors regarding ambiguous variables.

apport (2.20.11-0ubuntu27.7) focal; urgency=medium

  * d/control: Offer real package alternatives along with x-terminal-server
    for apport-gtk and apport-kde (LP: #1881976)

 -- Dariusz Gadomski <email address hidden> Sun, 09 Aug 2020 13:43:11 +0200

Changed in apport (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for apport has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers