apport-cli crashed with error in _read()

Bug #176977 reported by Dmitriy Geels
6
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: apport

looks like, that it died after i pressed Ctrl-C

ProblemType: Crash
ApportLog:
 apport (pid 19719) Mon Dec 17 20:05:49 2007: called for pid 5897, signal 11
 apport (pid 19719) Mon Dec 17 20:05:49 2007: executable: /usr/bin/compiz.real (command line "/usr/bin/compiz.real --ignore-desktop-hints --replace --loose-binding --sm-client-id default0 ccp")
 modinfo: could not open cdrom: No such device
 modinfo: could not open cdrom: No such device
 apport (pid 19719) Mon Dec 17 20:06:10 2007: wrote report /var/crash/_usr_bin_compiz.real.1017.crash
Architecture: i386
CrashReports:
 600:1017:1000:10109:2007-12-17 20:10:28.000000000 +0300:2007-12-17 20:10:29.000000000 +0300:/var/crash/_usr_bin_apport-cli.1017.crash
 600:1017:1000:7187033:2007-12-17 20:10:52.000000000 +0300:2007-12-17 20:10:53.000000000 +0300:/var/crash/_usr_bin_compiz.real.1017.crash
 0:1017:1000:1117391:2007-12-12 16:46:38.000000000 +0300:2007-12-12 16:46:34.000000000 +0300:/var/crash/_usr_lib_xscreensaver_hyperspace.1017.crash
 600:1017:1000:7125280:2007-12-13 20:12:04.000000000 +0300:2007-12-13 20:12:05.000000000 +0300:/var/crash/_usr_lib_xscreensaver_hypertorus.1017.crash
 600:1017:1000:4542001:2007-12-17 20:16:01.000000000 +0300:2007-12-17 20:16:02.000000000 +0300:/var/crash/_usr_lib_xscreensaver_moebius.1017.crash
Date: Mon Dec 17 20:10:29 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/apport-cli
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: apport 0.98
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-cli
ProcCwd: /home/dmig
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=ru_RU.UTF-8
PythonArgs: ['/usr/bin/apport-cli']
SourcePackage: apport
Title: apport-cli crashed with error in _read()
Uname: Linux dmig-desktop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Revision history for this message
Dmitriy Geels (dmig) wrote :
Revision history for this message
Dmitriy Geels (dmig) wrote :

Here is log, apport-cli spitted out before dying:

dmig@dmig-desktop:~$ apport-cli

*** The program "queens" closed unexpectedly on 2007-12-26 at 16:34:29.

If you were not doing anything confidential (entering passwords or other
private information), you can help to improve the application by reporting
the problem.

What would you like to do? Your options are:
  R: Report Problem...
  I: Cancel and ignore future crashes of this program version
  C: Cancel
Please choose (R/I/C): r

*** Collecting problem information

The collected information can be send to the developers to improve the
application. This might take a few minutes.
.Traceback (most recent call last):
  File "/usr/bin/apport-cli", line 282, in <module>
    app.run_argv()
  File "/var/lib/python-support/python2.5/apport/ui.py", line 260, in run_argv
    self.run_crashes()
  File "/var/lib/python-support/python2.5/apport/ui.py", line 101, in run_crashes
    self.run_crash(f)
  File "/var/lib/python-support/python2.5/apport/ui.py", line 179, in run_crash
    self.collect_info()
  File "/var/lib/python-support/python2.5/apport/ui.py", line 348, in collect_info
    icthread.exc_raise()
  File "/var/lib/python-support/python2.5/apport/REThread.py", line 37, in run
    self._retval = self.__target(*self.__args, **self.__kwargs)
  File "/var/lib/python-support/python2.5/apport/ui.py", line 31, in thread_collect_info
    report.add_gdb_info()
  File "/var/lib/python-support/python2.5/apport/report.py", line 405, in add_gdb_info
    self['CoreDump'].write(open(core, 'w'))
  File "/var/lib/python-support/python2.5/problem_report.py", line 54, in write
    block = gz.read(1048576)
  File "/usr/lib/python2.5/gzip.py", line 227, in read
    self._read(readsize)
  File "/usr/lib/python2.5/gzip.py", line 279, in _read
    uncompress = self.decompress.decompress(buf)
zlib.error: Error -3 while decompressing: invalid distance code

Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in bzr head.

Changed in apport:
assignee: nobody → pitti
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.102

---------------
apport (0.102) hardy; urgency=low

  [ Martin Pitt ]
  * problem_report.py: Support reading reports with legacy zlib
    compression in 'retain compressed values' mode (as used nowadays by
    apport when reporting a crash). Add a test case, too. (LP: #129616)
  * debian/control, debian/rules: Switch from python-support to
    python-central, and use 'nomove' option so that apport works during
    upgrades, too. (LP: #121341)
  * debian/rules: Use dh_icons instead of dh_iconcache.
  * debian/apport.init: Do not stop apport in any runlevel (LSB header).
  * apport/ui.py, run_crash(): Catch zlib.error on invalidly compressed core
    dumps. (LP: #176977)
  * apport/ui.py: Give a meaningful error message instead of crashing if the
    package for a crash report is not installed any more. (LP: #149739)
  * apport/ui.py: Do not include ProcCmdline in bug reports, since these are
    not ack'ed by the user and might contain sensitive data. (LP: #132800)
  * apport/ui.py: Add various test cases for crash reports whose packages have
    been uninstalled between the crash and the report. This reproduces
    LP #186684.
  * apport/ui.py, load_report(): Produce proper error message if
    executable/interpreter path do not exist any more. (LP: #186684)
  * cli/apport-cli: Intercept SIGPIPE when calling sensible-pager, to avoid
    crash when quitting it prematurely. (LP: #153872)
  * bin/apport-checkreports: Print out a list of program names/packages which
    have a pending crash report. (LP: #145117)
  * apport/ui.py, run_argv(): Add return code which indicates whether any
    report has been processed.
  * cli/apport-cli: If no pending crash reports are present, say so and refer
    to --help. (LP: #182985)
  * apport/ui.py: Waive check for obsolete packages if environment defines
    $APPORT_IGNORE_OBSOLETE_PACKAGES. Document this in the apport-cli manpage.
    (LP: #148064)

  [ Daniel Hahler ]
  * .crash file integration for KDE3 (LP: #177055)
    - debian/apport-qt.install: install added files qt4/apport-qt-mime.desktop
      and qt4/apport-qt-mimelnk.desktop
  * Fixed minor warnings/errors from desktop-file-validate in
    gtk/apport-gtk-mime.desktop.in and qt4/apport-qt.desktop.in (LP: #146957)

 -- Martin Pitt <email address hidden> Wed, 06 Feb 2008 12:55:53 +0100

Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers