ubuntu-bug ignores default browser setting

Bug #1769183 reported by Hynek Vychodil on 2018-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Undecided
Unassigned

Bug Description

When running ubuntu-bug and sending the bug report, the default web browser setting is ignored. It just launches Firefox, even I have set google-chrome as mine default browser.

$ sudo update-alternatives --config x-www-browser
[sudo] password for hynek:
There are 2 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection Path Priority Status
------------------------------------------------------------
* 0 /usr/bin/google-chrome-beta 150 auto mode
  1 /usr/bin/firefox 40 manual mode
  2 /usr/bin/google-chrome-beta 150 manual mode

Press <enter> to keep the current choice[*], or type selection number:

Description: Ubuntu 17.10
Release: 17.10
apport:
  Installed: 2.20.7-0ubuntu3.8
  Candidate: 2.20.7-0ubuntu3.8
  Version table:
 *** 2.20.7-0ubuntu3.8 500
        500 http://sk.archive.ubuntu.com/ubuntu artful-updates/main amd64 Packages
        500 http://sk.archive.ubuntu.com/ubuntu artful-updates/main i386 Packages
        100 /var/lib/dpkg/status
     2.20.7-0ubuntu3.7 500
        500 http://security.ubuntu.com/ubuntu artful-security/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu artful-security/main i386 Packages
     2.20.7-0ubuntu3 500
        500 http://sk.archive.ubuntu.com/ubuntu artful/main amd64 Packages
        500 http://sk.archive.ubuntu.com/ubuntu artful/main i386 Packages

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: apport 2.20.7-0ubuntu3.8
ProcVersionSignature: Ubuntu 4.13.0-39.44-generic 4.13.16
Uname: Linux 4.13.0-39-generic x86_64
ApportLog:

ApportVersion: 2.20.7-0ubuntu3.8
Architecture: amd64
CrashReports: 640:1000:119:1580218:2018-04-30 08:27:05.361482009 +0200:2018-04-30 08:27:03.801016602 +0200:/var/crash/_usr_bin_kactivitymanagerd.1000.crash
Date: Fri May 4 17:10:25 2018
InstallationDate: Installed on 2017-11-09 (176 days ago)
InstallationMedia: Kubuntu 17.10 "Artful Aardvark" - Release amd64 (20171017.1)
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.apport.crashdb.conf: 2018-05-04T17:01:59.655303

Hynek Vychodil (vychodil-hynek) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers