[UIFe] ubuntu-bug says that snap packages are not installed

Bug #1729491 reported by Александр on 2017-11-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Julian Andres Klode
Bionic
Medium
Julian Andres Klode
ubuntu-docs (Ubuntu)
Undecided
Unassigned

Bug Description

User Interface Freeze Exception Justification
=============================================
The interface for ubuntu-bug/apport-bug <name> is super confusing if <name> was installed as a snap.

List Notifications
==================
https://lists.ubuntu.com/archives/ubuntu-translators/2018-April/007471.html
<ubuntu-doc awaiting moderation, but probably no documentation affected?>

Original Bug Description
========================
1.
I installed the package gnome-recipes, tried to send an error report program in response to the received message:you cannot report a problem:
The report belongs to a package that was not installed.

2.
Expected that the program will be identified as installed.

3.
sudo apt -f install
[sudo] password for Alexander:
Reading package lists... Done
Building dependency tree
Reading state information... Ready
0 upgraded, 0 newly installed, for removal 0 packets are marked, and 0 packages are not updated.
sudo gnome-sudo recipes: gnome-recipes: command not found
sudo apt install gnome-recipes Reading package lists... Done
Building dependency tree
Reading state information... Ready
E: unable to locate package gnome-recipes

I installed via software-center

gnome-recipes
snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks
ubuntu-bug gnome-recipes
dpkg-query: template gnome-recipes no corresponding package
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
^C^Z
[1]+ Stopped ubuntu-bug gnome-recipes

https://youtu.be/AXtR5m2uqUg
---

1.
произвёл установку пакета gnome-recipes, попытался отправить отчёт об ошибке программы, в ответ получил сообщение:Не удаётся сообщить о неполадке:
Отчёт относится к пакету , который не был установлен.

2.
Ожидал что программа будет идентифицироваться как установленная.

3.
sudo apt -f install
[sudo] пароль для alexandr:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
sudo gnome-recipes sudo: gnome-recipes: команда не найдена
sudo apt install gnome-recipes Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Не удалось найти пакет gnome-recipes

произвёл установку через software-center

gnome-recipes
snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks
ubuntu-bug gnome-recipes
dpkg-query: шаблону gnome-recipes не соответствует ни один пакет
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
^C^Z
[1]+ Остановлено ubuntu-bug gnome-recipes

https://youtu.be/AXtR5m2uqUg

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: software-center (not installed)
Uname: Linux 4.14.0-041400rc7-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Nov 2 08:06:48 2017
InstallationDate: Installed on 2017-10-29 (3 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeremy Bicha (jbicha) wrote :

gnome-recipes is only available as a snap in Ubuntu 16.04 LTS not as a regular .deb so none of your apt commands will work. ubuntu-bug gnome-recipes won't work either.

affects: software-center (Ubuntu) → gnome-software (Ubuntu)
Download full text (4.5 KiB)

I do not understand is a standard installation via software-center do not
have to independently resolve issues with installing programs? When I
download third-party *.deb packages I assume, that something can go wrong,
but when set through the GUI implies that the program should stand
correctly, or to report problems in advance.
---
Мне не понятно, разве стандартная установка через software-center не должна
самостоятельно решать вопросы с установкой программ? Когда я скачиваю
сторонние *.deb пакеты я предполагаю, что что то может пойти не так, но
когда устанавливаю через GUI предпологаю что программа должна вставать
корректно, либо сообщать о неполадках заранее.

2017-11-02 16:36 GMT+05:00 Jeremy Bicha <email address hidden>:

> gnome-recipes is only available as a snap in Ubuntu 16.04 LTS not as a
> regular .deb so none of your apt commands will work. ubuntu-bug gnome-
> recipes won't work either.
>
> ** Package changed: software-center (Ubuntu) => gnome-software (Ubuntu)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1729491
>
> Title:
> incorrectly installed programs
>
> Status in gnome-software package in Ubuntu:
> New
>
> Bug description:
> 1.
> I installed the package gnome-recipes, tried to send an error report
> program in response to the received message:you cannot report a problem:
> The report belongs to a package that was not installed.
>
> 2.
> Expected that the program will be identified as installed.
>
> 3.
> sudo apt -f install
> [sudo] password for Alexander:
> Reading package lists... Done
> Building dependency tree
> Reading state information... Ready
> 0 upgraded, 0 newly installed, for removal 0 packets are marked, and 0
> packages are not updated.
> sudo gnome-sudo recipes: gnome-recipes: command not found
> sudo apt install gnome-recipes Reading package lists... Done
> Building dependency tree
> Reading state information... Ready
> E: unable to locate package gnome-recipes
>
> I installed via software-center
>
> gnome-recipes
> snap-confine has elevated permissions and is not confined but should be.
> Refusing to continue to avoid permission escalation attacks
> ubuntu-bug gnome-recipes
> dpkg-query: template gnome-recipes no corresponding package
> Gtk-Message: GtkDialog mapped without a transient parent. This is
> discouraged.
> ^C^Z
> [1]+ Stopped ubuntu-bug gnome-recipes
>
> https://youtu.be/AXtR5m2uqUg
> ---
>
> 1.
> произвёл установку пакета gnome-recipes, попытался отправить отчёт об
> ошибке программы, в ответ получил сообщение:Не удаётся сообщить о неполадке:
> Отчёт относится к пакету , который не был установлен.
>
> 2.
> Ожидал что программа будет идентифицироваться как установленная.
>
> 3.
> sudo apt -f install
> [sudo] пароль для alexandr:
> Чтение списков пакетов… Готово
> Построение дерева зависимостей
> Чтение информации о состоянии… Готово
> обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0
> пакетов, и 0 пакетов не обновлено.
> sudo gnome-recip...

Read more...

This is indeed confusing because the user installed a software in a recommended way and apport errors on "the program is not installed" while it is installed but not as a deb package.

moving to apport.

affects: gnome-software (Ubuntu) → apport (Ubuntu)
Changed in apport (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
summary: - incorrectly installed programs
+ ubuntu-bug says that snap packages are not installed
Changed in apport (Ubuntu):
status: Confirmed → Triaged
tags: added: rls-bb-incoming
Steve Langasek (vorlon) on 2018-02-01
tags: removed: rls-bb-incoming
tags: added: id-5a733f698ac27be676d4b705
Changed in apport (Ubuntu Bionic):
status: Triaged → In Progress
assignee: nobody → Julian Andres Klode (juliank)
tags: added: id-5ab940fe3f9097fb3600fe6d
Julian Andres Klode (juliank) wrote :

Current state:

Case 1: The user ran apport-bug against a snap, no deb with that name installed:

(1a) The report belongs to a snap published by %s. Contact them via %s for help.
(1b) The report belongs to a snap published by %s. No contact address has been provided, ask the forums at https://forum.snapcraft.io/ for help.

Case 2: The user ran apport-bug against a name for which snap and deb are both installed

(2a) The report belongs to a package, but also a snap published by %s, you can contact them via %s for help. Do you want to continue with the bug report?
(2b) The report belongs to a package, but also snap published by %s. No contact address has been provided, ask the forums at https://forum.snapcraft.io/ for help. Do you want to continue with the bug report?

cases (a) are in case a contact is set, (b) without contact, users are pointed to the forums.

Julian Andres Klode (juliank) wrote :

Merged it into a forked bionic branch, cleaned that up a bit, ensured autopkgtests pass, and opened a merge proposal at https://code.launchpad.net/~juliank/ubuntu/bionic/apport/snap/+merge/342207

summary: - ubuntu-bug says that snap packages are not installed
+ [UIFe] ubuntu-bug says that snap packages are not installed
description: updated
Julian Andres Klode (juliank) wrote :

Marking it as New for the UIFe tracking.

description: updated
Changed in apport (Ubuntu Bionic):
status: In Progress → New
Gunnar Hjalmarsson (gunnarhj) wrote :

Sounds like a well-founded change, only a few srings, and a notification sent to the ubuntu-translators mailing list.

As regards the desktop guide, it may be motivated to adjust this page:

https://help.ubuntu.com/stable/ubuntu-help/report-ubuntu-bug.html

However, that can wait until next cycle; the current wording is generic enough to not be incorrect, also with this change.

UIFe ok from a docs and translators POV.

no longer affects: ubuntu-docs (Ubuntu Bionic)
Łukasz Zemczak (sil2100) wrote :

UIFe approved. Please proceed.

Changed in apport (Ubuntu Bionic):
status: New → Triaged
Iain Lane (laney) wrote :

(cleaning up ~ubuntu-release bugs)

This has an ubuntu-docs task that may or may not be fixed for 18.04 - I'm unsubscribing the team as it's not something we need to track at the RT level.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.9-0ubuntu4

---------------
apport (2.20.9-0ubuntu4) bionic; urgency=medium

  * apport/hookutils.py: When gathering gsettings schema changes redact
    information regarding command-history and favorite-apps from gnome-shell.
    (LP: #1739531)

 -- Brian Murray <email address hidden> Thu, 05 Apr 2018 10:51:59 -0700

Changed in apport (Ubuntu Bionic):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers