gvfs-open/xdg-open shows message about 'gio open' which confuses user

Bug #1721948 reported by Norbert on 2017-10-07
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Apport
Undecided
Unassigned
gvfs
Fix Released
High
apport (Ubuntu)
Low
Unassigned
gvfs (Ubuntu)
Low
Unassigned
python3.6 (Ubuntu)
Low
Unassigned
xdg-utils (Ubuntu)
Medium
Brian Murray
Artful
Medium
Brian Murray

Bug Description

Steps to reproduce:
1. Install Ubuntu 17.10
2. Try to report bug with Apport by terminal command `apport-bug apport`

Expected results:
  apport-bug reports bug silently

Actual results:
  get output in the terminal
  $ apport-bug apport
  This tool has been deprecated, use 'gio open' instead.
  See 'gio help open' for more info.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: apport 2.20.7-0ubuntu2
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic i686
ApportVersion: 2.20.7-0ubuntu2
Architecture: i386
CurrentDesktop: MATE
Date: Sat Oct 7 13:50:23 2017
InstallationDate: Installed on 2017-08-26 (41 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha i386 (20170826)
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Norbert (nrbrtx) wrote :
Brian Murray (brian-murray) wrote :

I believe this is specific to MATE as I was unable to recreate this on an Ubuntu Artful install.

Norbert (nrbrtx) wrote :

The error message seems to be generated by xdg-open.

See this console output on MATE session:

$ xdg-open http://goo.gl
This tool has been deprecated, use 'gio open' instead.
See 'gio help open' for more info.

Norbert (nrbrtx) wrote :

gvfs-open is affected too

$ gvfs-open http://goo.gl
This tool has been deprecated, use 'gio open' instead.
See 'gio help open' for more info.

summary: - apport bug shows message about 'gio open' which confuses user
+ gvfs-open/xdg-open shows message about 'gio open' which confuses user
Changed in apport (Ubuntu):
status: New → Invalid
Norbert (nrbrtx) wrote :

Got the same message from xdg-open on GNOME and Unity sessions.

Sebastien Bacher (seb128) wrote :

that's not a gvfs issue, the command there is deprecated so it's normal that it informs the user about the new command to use

Changed in gvfs (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Norbert (nrbrtx) wrote :

It is not normal.
Original bug-report was written against apport.
I started to call xdg-open and gvfs-open directly to analyze the problem.

Apport uses xdg-open (which calls gvfs-open) in /usr/lib/python3/dist-packages/apport/ui.py .
So apport uses deprecated mechanism. It is not critical. But in 16.04 LTS I do not have such message.

Changed in apport (Ubuntu):
status: Invalid → New
Changed in gvfs:
importance: Unknown → High
status: Unknown → Fix Released
Changed in apport (Ubuntu):
status: New → Triaged
importance: Undecided → Low
tags: added: rls-bb-incoming
Brian Murray (brian-murray) wrote :

apport falls back to python's webbrowser.py module, if xdg-open is not available, which also utilizes xdg-open.

 $ ipython3
import Python 3.6.3 (default, Oct 3 2017, 21:45:48)
Type "copyright", "credits" or "license" for more information.

IPython 5.1.0 -- An enhanced Interactive Python.
? -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help -> Python's own help system.
object? -> Details about 'object', use 'object??' for extra details.

In [1]: import webbrowser

In [2]: webbrowser.open('http://www.ubuntu.com')
Out[2]: True

In [3]: This tool has been deprecated, use 'gio open' instead.
See 'gio help open' for more info.

Changed in python3.6 (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in apport:
status: New → Fix Released

This is fixed in xdg-util's current upstream release 1.1.2+

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

This is the xdg-utils commit which adds support for preferring 'gio open'.

https://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=0d6eebb27c562e8644ccf616ebdbddf82d0d2dd8

Changed in xdg-utils (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in xdg-utils (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
Sebastien Bacher (seb128) wrote :

Thanks Brian, I had started looking at that bug didn't update the bug so I'm attaching the patch I have in case it's useful. The build is failing due to a test error then though which I didn't debug

Hello Norbert, or anyone else affected,

Accepted xdg-utils into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xdg-utils/1.1.1-1ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xdg-utils (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Brian Murray (brian-murray) wrote :

I tested this by using python3 to import webbrowser and then using webbrowser.open('http://www.ubuntu.com'). With the version of xdg-utils in the release pocket I received the warning about gvfs-open being deprecated. With the new version of xdg-utils (1.1.1-1ubuntu3) in -proposed I no longer received the warning.

tags: added: verification-done-artful
removed: verification-needed verification-needed-artful
Brian Murray (brian-murray) wrote :

There were also changes to xdg-email, xdg-copy, and xdg-mime so those might be worth testing too.

Changed in python3.6 (Ubuntu):
status: Triaged → Invalid
Changed in apport (Ubuntu):
status: Triaged → Invalid
Sander Jonkers (jonkers) wrote :

Yes, that solved it for me after activating "proposed" on artful, with xdg-utils (1.1.1-1ubuntu3)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xdg-utils - 1.1.1-1ubuntu3

---------------
xdg-utils (1.1.1-1ubuntu3) artful; urgency=medium

  * debian/patches/prefer-gio.patch: switch to preferring gio commands over
    gvfs ones. (LP: #1721948)

 -- Brian Murray <email address hidden> Wed, 18 Oct 2017 17:12:39 -0700

Changed in xdg-utils (Ubuntu):
status: Fix Committed → Fix Released
Changed in xdg-utils (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xdg-utils has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.