/usr/share/apport/apport-gtk:TypeError:/usr/share/apport/apport-gtk@597:run_argv:run_crashes

Bug #1658188 reported by errors.ubuntu.com bug bridge on 2017-01-20
52
This bug affects 4 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Brian Murray
Xenial
Medium
Brian Murray
Bionic
Undecided
Unassigned
Cosmic
Undecided
Brian Murray

Bug Description

[Test Case]
Check Error Tracker bucket and make sure version from -proposed doesn't show up there. Given that this happens a whole bunch we should know pretty quick if its fixed.

[Regression Potential]
The test being modified is designed to not report crashes that happen during logout. It's possible that some reports don't have a Date in them but in that case we couldn't compare the logind_session information to the Date anyway so those crashes would have been reported anyway. Regardless, the potential is that we'll have some more crashes reported about things crashing on logout which is better than the hundreds of crashes we get like this one.

The Ubuntu Error Tracker has been receiving reports about a problem regarding apport. This problem was most recently seen with package version 2.20.3-0ubuntu8.2, the problem page at https://errors.ubuntu.com/problem/65cb22d7c29a308dad9368b971e1b8d6384c9089 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker you can request it at http://forms.canonical.com/reports/.

Brian Murray (brian-murray) wrote :

Here's the Traceback:

Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 597, in <module>
    app.run_argv()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 687, in run_argv
    return self.run_crashes()
  File "/usr/lib/python3/dist-packages/apport/ui.py", line 238, in run_crashes
    logind_session[1] > self.report.get_timestamp():
TypeError: unorderable types: float() > NoneType()

Brian Murray (brian-murray) wrote :

Fixed in upstream r3122.

Changed in apport (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.5-0ubuntu3

---------------
apport (2.20.5-0ubuntu3) artful; urgency=medium

  * Revert change to test/test_crash_digger.py to use the source's
    crash-digger.

 -- Brian Murray <email address hidden> Mon, 15 May 2017 16:00:06 -0700

Changed in apport (Ubuntu):
status: Triaged → Fix Released
Changed in apport (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
milestone: none → xenial-updates
Brian Murray (brian-murray) wrote :

This was actually fixed in the following version of apport.

apport (2.20.5-0ubuntu1) artful; urgency=medium

  * New upstream release:
    - bin/apport-retrace: Comment on bug reports when an invalid core file is
      encountered. (LP: #1647635)
    - Switch to using HxW directory names for app icons instead of just one
      number. Thanks to Jeremy Bicha for the patch.
    - apport/ui.py: Ensure the Date field exists in a report before using it in a
      comparison. (LP: #1658188)
    - bin/apport-retrace: Add in a --gdb-sandbox switch which creates or utilizes
      a sandbox with the report's distribution release and the host system's
      architecture for installing and running gdb. (LP: #1517257)
    - apport/hookutils.py: Don't crash if .xsession-errors is not readable by the
      user. (LP: #1675928)
    - bin/apport-retrace: Be specific about which required field is missing from a
      report and not retracing it.
  * debian/control: Adjust Vcs-Bzr: for artful branch.

 -- Brian Murray <email address hidden> Fri, 12 May 2017 15:11:38 -0700

Brian Murray (brian-murray) wrote :

This still needs fixing in Ubuntu 16.04.

Changed in apport (Ubuntu Xenial):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
description: updated
Robie Basak (racb) wrote :

Regression Potential?

For example, what if the if statement now unintentionally never succeeds even if get_timestamp would work?

Brian Murray (brian-murray) wrote :

The point of comparing the logind_session time is to the Date is try and determine if the crash happened during logout and not report the crash. Without a Date in the report this comparison can not be done and get_timestamp only returns None or a timestamp in seconds since epoch if Date exists in the report so requiring Date in the report is fine.

description: updated

Hello errors.ubuntu.com, or anyone else affected,

Accepted apport into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apport/2.20.1-0ubuntu2.17 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apport (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Brian Murray (brian-murray) wrote :

The new version of for xenial does not appear in the errors bucket, https://errors.ubuntu.com/problem/65cb22d7c29a308dad9368b971e1b8d6384c9089, additionally there are no other apport-gtk TypeError crashes (something that might happen because the signature changed due to different line numbers) in the error tracker for apport.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.1-0ubuntu2.17

---------------
apport (2.20.1-0ubuntu2.17) xenial; urgency=medium

  * apport/ui.py: Ensure the Date field exists in a report before using it in
    a comparison. (LP: #1658188)

 -- Brian Murray <email address hidden> Fri, 20 Apr 2018 14:39:15 -0700

Changed in apport (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for apport has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Brian Murray (brian-murray) wrote :

I happened to encounter this crash today on Disco Dingo.

Changed in apport (Ubuntu):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.20.10-0ubuntu20

---------------
apport (2.20.10-0ubuntu20) disco; urgency=medium

  * apport/ui.py: if report.get_timestamp() returns None don't try and use it
    in a comparison. (LP: #1658188)

 -- Brian Murray <email address hidden> Mon, 04 Feb 2019 14:35:36 -0800

Changed in apport (Ubuntu):
status: In Progress → Fix Released
Brian Murray (brian-murray) wrote :

Some how part of this fix got lost in Cosmic.

Changed in apport (Ubuntu Bionic):
status: New → Fix Released
Changed in apport (Ubuntu Cosmic):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress

Hello errors.ubuntu.com, or anyone else affected,

Accepted apport into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apport/2.20.10-0ubuntu13.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in apport (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
removed: verification-done
Brian Murray (brian-murray) wrote :

There are only a couple of reports in the Error Tracker bucket about this happening with version 2.20.10-0ubuntu13.3 and those are likely showing that version due to apport's late package version collection. Setting to verification-done.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers