apport-cli crashed with IOError in _fo_write_no_intr()

Bug #153872 reported by Stéphane Loeuillet
6
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: apport

Trying to use apport-cli on a crash report in /var/crash

apport-cli -c /var/crash/.....crash

I choosed to take a look at the report then I went back, ready to send it

There, it crashed

ProblemType: Crash
Architecture: amd64
CrashReports: 600:1000:1000:16531:2007-10-18 13:47:39.000000000 +0200:2007-10-18 13:59:11.000000000 +0200:/var/crash/_usr_bin_apport-cli.1000.crash

Date: Thu Oct 18 13:47:40 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/apport-cli
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: apport 0.98
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-cli -c /var/crash/_usr_bin_seahorse.1000.crash
ProcCwd: /home/leroutier/dev/Flash/code/swfdec
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
PythonArgs: ['/usr/bin/apport-cli', '-c', '/var/crash/_usr_bin_seahorse.1000.crash']
SourcePackage: apport
Title: apport-cli crashed with IOError in _fo_write_no_intr()
Uname: Linux portable-sloeuillet 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux

Revision history for this message
Stéphane Loeuillet (leroutier) wrote :
Revision history for this message
Bruce Cowan (bruce89-deactivatedaccount) wrote :

Trying to exit a crash view with 'q' causes this for me.

Revision history for this message
Martin Pitt (pitti) wrote :

Right, calling sensible-pager should intercept SIGPIPE.

Changed in apport:
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in bzr head.

Changed in apport:
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.102

---------------
apport (0.102) hardy; urgency=low

  [ Martin Pitt ]
  * problem_report.py: Support reading reports with legacy zlib
    compression in 'retain compressed values' mode (as used nowadays by
    apport when reporting a crash). Add a test case, too. (LP: #129616)
  * debian/control, debian/rules: Switch from python-support to
    python-central, and use 'nomove' option so that apport works during
    upgrades, too. (LP: #121341)
  * debian/rules: Use dh_icons instead of dh_iconcache.
  * debian/apport.init: Do not stop apport in any runlevel (LSB header).
  * apport/ui.py, run_crash(): Catch zlib.error on invalidly compressed core
    dumps. (LP: #176977)
  * apport/ui.py: Give a meaningful error message instead of crashing if the
    package for a crash report is not installed any more. (LP: #149739)
  * apport/ui.py: Do not include ProcCmdline in bug reports, since these are
    not ack'ed by the user and might contain sensitive data. (LP: #132800)
  * apport/ui.py: Add various test cases for crash reports whose packages have
    been uninstalled between the crash and the report. This reproduces
    LP #186684.
  * apport/ui.py, load_report(): Produce proper error message if
    executable/interpreter path do not exist any more. (LP: #186684)
  * cli/apport-cli: Intercept SIGPIPE when calling sensible-pager, to avoid
    crash when quitting it prematurely. (LP: #153872)
  * bin/apport-checkreports: Print out a list of program names/packages which
    have a pending crash report. (LP: #145117)
  * apport/ui.py, run_argv(): Add return code which indicates whether any
    report has been processed.
  * cli/apport-cli: If no pending crash reports are present, say so and refer
    to --help. (LP: #182985)
  * apport/ui.py: Waive check for obsolete packages if environment defines
    $APPORT_IGNORE_OBSOLETE_PACKAGES. Document this in the apport-cli manpage.
    (LP: #148064)

  [ Daniel Hahler ]
  * .crash file integration for KDE3 (LP: #177055)
    - debian/apport-qt.install: install added files qt4/apport-qt-mime.desktop
      and qt4/apport-qt-mimelnk.desktop
  * Fixed minor warnings/errors from desktop-file-validate in
    gtk/apport-gtk-mime.desktop.in and qt4/apport-qt.desktop.in (LP: #146957)

 -- Martin Pitt <email address hidden> Wed, 06 Feb 2008 12:55:53 +0100

Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers