ubuntu-bug (apport-kde) crashes every time I submit a problem report

Bug #1517030 reported by Daniel Barrett on 2015-11-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Unassigned

Bug Description

Every time I run the "ubuntu-bug" program, I get a crash report about it.

1. I run (say) "ubuntu-bug muon-updater"
2. Apport window appears, "Send problem report to developers?" with info about the bug.
3. Click Send.
4. "Uploading problem information" dialog appears and disappears.
5. Launchpad website appears. I start filing in details.
6. Sometime soon, Plasma reports a crash in its system tray. A dialog appears. See my screenshot.
7. I click the "Continue" button to submit a crash bug report. The dialog disappears, but nothing else happens that I can see.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: apport-kde 2.19.1-0ubuntu5
ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
Uname: Linux 4.2.0-18-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: KDE
Date: Tue Nov 17 07:51:26 2015
InstallationDate: Installed on 2013-08-31 (807 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: Upgraded to wily on 2015-11-08 (8 days ago)

Daniel Barrett (dbarrett-m) wrote :
summary: - ubuntu-bug crashes every time I submit a problem report
+ ubuntu-bug (apport-kde) crashes every time I submit a problem report
Daniel Barrett (dbarrett-m) wrote :

Also, when ubuntu-bug terminates, the shell prints:

Segmentation fault (core dumped)

Brian Murray (brian-murray) wrote :

This crash file might help us sort out the issue.

/var/crash/_usr_share_apport_apport-kde.1000.crash

Could you please add it as an attachment?

Changed in apport (Ubuntu):
status: New → Incomplete
Daniel Barrett (dbarrett-m) wrote :

Here's the crash file you requested

Daniel Barrett (dbarrett-m) wrote :

Hi - I uploaded the requested crash file. Should the "incomplete" status be changed? Thanks.

Launchpad Janitor (janitor) wrote :

[Expired for apport (Ubuntu) because there has been no activity for 60 days.]

Changed in apport (Ubuntu):
status: Incomplete → Expired
basse (basse) wrote :

i had problem with this too...
i was launching apport-collect form konsole so i saw the error, which was in /usr/share/apport/apport-kde python file, on line 358... str wasn't coping with some unicode strings, so I changed it to using "encode"..

358 QTreeWidgetItem(keyitem, [str(line.encode('utf-8'))])

works now..

.b

Daniel Barrett (dbarrett-m) wrote :

Someone has just posted a one-line fix, so is it possible for this fix to be incorporated?

Changed in apport (Ubuntu):
status: Expired → Confirmed
Changed in apport (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers