apport-qt crashed with ValueError in _cache()

Bug #149739 reported by Vangelis Tasoulas
6
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: apport

I had opened mozilla-thunderbird and a few other windows and when I closed thunderbird this crash report showed up.

ProblemType: Crash
ApportLog:
 apport (pid 10926) Sat Oct 6 11:05:56 2007: called for pid 6093, signal 11
 apport (pid 10926) Sat Oct 6 11:05:56 2007: executable: /usr/lib/firefox/firefox-bin (command line "/usr/lib/firefox/firefox-bin")
 apport (pid 10926) Sat Oct 6 11:05:56 2007: apport: report /var/crash/_usr_lib_firefox_firefox-bin.1000.crash already exists and unseen, doing nothing to avoid disk usage DoS
Architecture: amd64
Date: Sat Oct 6 10:51:24 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/share/apport/apport-qt
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: apport-qt 0.97
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-qt
ProcCwd: /home/cyber
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
PythonArgs: ['/usr/share/apport/apport-qt']
SourcePackage: apport
Title: apport-qt crashed with ValueError in _cache()
Uname: Linux aurora 2.6.22-13-generic #1 SMP Thu Oct 4 17:52:26 GMT 2007 x86_64 GNU/Linux

Revision history for this message
Vangelis Tasoulas (cyberang3l) wrote :
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in bzr head.

Changed in apport:
importance: Undecided → Low
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.102

---------------
apport (0.102) hardy; urgency=low

  [ Martin Pitt ]
  * problem_report.py: Support reading reports with legacy zlib
    compression in 'retain compressed values' mode (as used nowadays by
    apport when reporting a crash). Add a test case, too. (LP: #129616)
  * debian/control, debian/rules: Switch from python-support to
    python-central, and use 'nomove' option so that apport works during
    upgrades, too. (LP: #121341)
  * debian/rules: Use dh_icons instead of dh_iconcache.
  * debian/apport.init: Do not stop apport in any runlevel (LSB header).
  * apport/ui.py, run_crash(): Catch zlib.error on invalidly compressed core
    dumps. (LP: #176977)
  * apport/ui.py: Give a meaningful error message instead of crashing if the
    package for a crash report is not installed any more. (LP: #149739)
  * apport/ui.py: Do not include ProcCmdline in bug reports, since these are
    not ack'ed by the user and might contain sensitive data. (LP: #132800)
  * apport/ui.py: Add various test cases for crash reports whose packages have
    been uninstalled between the crash and the report. This reproduces
    LP #186684.
  * apport/ui.py, load_report(): Produce proper error message if
    executable/interpreter path do not exist any more. (LP: #186684)
  * cli/apport-cli: Intercept SIGPIPE when calling sensible-pager, to avoid
    crash when quitting it prematurely. (LP: #153872)
  * bin/apport-checkreports: Print out a list of program names/packages which
    have a pending crash report. (LP: #145117)
  * apport/ui.py, run_argv(): Add return code which indicates whether any
    report has been processed.
  * cli/apport-cli: If no pending crash reports are present, say so and refer
    to --help. (LP: #182985)
  * apport/ui.py: Waive check for obsolete packages if environment defines
    $APPORT_IGNORE_OBSOLETE_PACKAGES. Document this in the apport-cli manpage.
    (LP: #148064)

  [ Daniel Hahler ]
  * .crash file integration for KDE3 (LP: #177055)
    - debian/apport-qt.install: install added files qt4/apport-qt-mime.desktop
      and qt4/apport-qt-mimelnk.desktop
  * Fixed minor warnings/errors from desktop-file-validate in
    gtk/apport-gtk-mime.desktop.in and qt4/apport-qt.desktop.in (LP: #146957)

 -- Martin Pitt <email address hidden> Wed, 06 Feb 2008 12:55:53 +0100

Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers