[Wishlist] Please add a "I know what I am doing" mode in apport

Bug #148064 reported by Philipp Kern
8
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Wishlist
Martin Pitt

Bug Description

Binary package hint: apport

Somehow apport's metric on whether packages are obsolete is broken. Probably it checks if newer source packages are available, which breaks because I have Debian sources activated to conviently retrieve newer source packages.

A "I know what I am doing, but please file the bug with a coredump and in a way that allows retracing" mode be very helpful for me.

Revision history for this message
Dax Solomon Umaming (knightlust) wrote :

Thank you for reporting this bug and help make Ubuntu better.
I sure wish apport has that feature too.
Changed description, Confirmed Status, and Changed Importance to Wishlist.

Changed in apport:
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Kjell Braden (afflux) wrote :

I'd very much like to see this implemented, because I'm experiencing e.g. crashes in python apps which are definetly coding errors and apport complains about some dependency not updated. (why should I need cpp-4.2 updated when my python crashes with an obvious TypeError?)

Revision history for this message
Martin Pitt (pitti) wrote :

Sebastien was interested in this, too. Fixed in bzr head.

Changed in apport:
status: Confirmed → Fix Committed
assignee: nobody → pitti
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 0.102

---------------
apport (0.102) hardy; urgency=low

  [ Martin Pitt ]
  * problem_report.py: Support reading reports with legacy zlib
    compression in 'retain compressed values' mode (as used nowadays by
    apport when reporting a crash). Add a test case, too. (LP: #129616)
  * debian/control, debian/rules: Switch from python-support to
    python-central, and use 'nomove' option so that apport works during
    upgrades, too. (LP: #121341)
  * debian/rules: Use dh_icons instead of dh_iconcache.
  * debian/apport.init: Do not stop apport in any runlevel (LSB header).
  * apport/ui.py, run_crash(): Catch zlib.error on invalidly compressed core
    dumps. (LP: #176977)
  * apport/ui.py: Give a meaningful error message instead of crashing if the
    package for a crash report is not installed any more. (LP: #149739)
  * apport/ui.py: Do not include ProcCmdline in bug reports, since these are
    not ack'ed by the user and might contain sensitive data. (LP: #132800)
  * apport/ui.py: Add various test cases for crash reports whose packages have
    been uninstalled between the crash and the report. This reproduces
    LP #186684.
  * apport/ui.py, load_report(): Produce proper error message if
    executable/interpreter path do not exist any more. (LP: #186684)
  * cli/apport-cli: Intercept SIGPIPE when calling sensible-pager, to avoid
    crash when quitting it prematurely. (LP: #153872)
  * bin/apport-checkreports: Print out a list of program names/packages which
    have a pending crash report. (LP: #145117)
  * apport/ui.py, run_argv(): Add return code which indicates whether any
    report has been processed.
  * cli/apport-cli: If no pending crash reports are present, say so and refer
    to --help. (LP: #182985)
  * apport/ui.py: Waive check for obsolete packages if environment defines
    $APPORT_IGNORE_OBSOLETE_PACKAGES. Document this in the apport-cli manpage.
    (LP: #148064)

  [ Daniel Hahler ]
  * .crash file integration for KDE3 (LP: #177055)
    - debian/apport-qt.install: install added files qt4/apport-qt-mime.desktop
      and qt4/apport-qt-mimelnk.desktop
  * Fixed minor warnings/errors from desktop-file-validate in
    gtk/apport-gtk-mime.desktop.in and qt4/apport-qt.desktop.in (LP: #146957)

 -- Martin Pitt <email address hidden> Wed, 06 Feb 2008 12:55:53 +0100

Changed in apport:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers