"ubuntu-bug" does not work on Aquaris 4.5 for packages from ci-train PPA

Bug #1467830 reported by Robie Basak on 2015-06-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Unassigned

Bug Description

Any attempt to run "ubuntu-bug" seems to fail on my phone (Aquaris 4.5 running r23). This includes running it against "webbrowser-app", "/usr/bin/webbrowser-app" and "apport". Whichever way it refuses telling me that "This is not an official Ubuntu package. Please remove any third party package and try again.".

Expected behaviour: "ubuntu-bug" should work against any executable on my phone - certainly for apport itself, preferably for webbrowser-app that seems to be a pre-installed Debian package, and preferably for executables from Clicks too where they have a bug tracker in Launchpad.

Actual behaviour: it works for none of the above. I get: http://paste.ubuntu.com/11761165/

apport is 2.17.2-0ubuntu1.1 and lsb_release reports that I am running Vivid.

I'm not sure if this is a bug in apport, system-image or something else.

This reproduces for me every time, but:

09:53 <popey> i dont get that
09:54 <popey> http://paste.ubuntu.com/11761169/
09:55 <popey> ubuntu-touch/rc-proposed/bq-aquaris.en image 47 on krillin

I am using r23 on an Aquaris 4.5.

The only thing I've really done apart from installing apps is to enable ssh using http://askubuntu.com/a/601972/7808

Robie Basak (racb) wrote :

09:58 <ogra_> rbasak, how are you logged in ... ?
09:58 <rbasak> ogra_: ssh

affects: system-image (Ubuntu) → apport (Ubuntu)
Brian Murray (brian-murray) wrote :

This is likely because the packages come from the ci-train overlay-ppa. You could confirm this by using 'apt-cache policy' and the name of the affected package.

It's possible to white list that specific PPA so that one could report bugs about packages from it to Launchpad, however please don't do that because of bug 1470572. Once that bug is fixed (and SRUed) and my PPA retracing branch are merged, then we can sort this bug out.

summary: - "ubuntu-bug" does not work on Aquaris 4.5
+ "ubuntu-bug" does not work on Aquaris 4.5 for packages from ci-train PPA
Changed in apport (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Robie Basak (racb) wrote :
Download full text (5.3 KiB)

Thanks.

> This is likely because the packages come from the ci-train overlay-ppa.

This seems to be the case for webbrowser-app but not for apport, and ubuntu-bug still doesn't let me file a bug against apport, in case this helps you understand this issue better. Is this because 2.17.2-0ubuntu1.1 is somehow not in an apt repository from the perspective of "apt-cache policy"? Though "apt-cache show apport" can see it, so I'm not sure what's going on here.

phablet@ubuntu-phablet:~$ apt-cache policy apport
apport:
  Installed: 2.17.2-0ubuntu1.1
  Candidate: 2.17.2-0ubuntu1.1
  Version table:
 *** 2.17.2-0ubuntu1.1 0
        100 /var/lib/dpkg/status
     2.17.2-0ubuntu1 0
        500 http://ports.ubuntu.com/ubuntu-ports/ vivid/main armhf Packages
phablet@ubuntu-phablet:~$ apt-cache policy webbrowser-app
webbrowser-app:
  Installed: 0.23+15.04.20150522.1-0ubuntu1
  Candidate: 0.23+15.04.20150522.1-0ubuntu1
  Version table:
 *** 0.23+15.04.20150522.1-0ubuntu1 0
       1001 http://ppa.launchpad.net/ci-train-ppa-service/stable-snapshot/ubuntu/ vivid/main armhf Packages
        100 /var/lib/dpkg/status
     0.23+15.04.20150416-0ubuntu1 0
        500 http://ports.ubuntu.com/ubuntu-ports/ vivid/main armhf Packages

phablet@ubuntu-phablet:~$ ubuntu-bug apport

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.
.............................................
*** It seems you have modified the contents of "/etc/default/apport". Would you like to add the contents of it to your bug report?

What would you like to do? Your options are:
  Y: Yes
  N: No
  C: Cancel
Please choose (Y/N/C): y
.

*** Problem in apport

The problem cannot be reported:

This is not an official Ubuntu package. Please remove any third party package and try again.

Press any key to continue...

No pending crash reports. Try --help for more information.

phablet@ubuntu-phablet:~$ apt-cache show apport
Package: apport
Status: install ok installed
Priority: optional
Section: utils
Installed-Size: 740
Maintainer: Martin Pitt <email address hidden>
Architecture: all
Version: 2.17.2-0ubuntu1.1
Replaces: python-apport (<< 2.2-0ubuntu1)
Depends: python3, python3-apport (>= 2.17.2-0ubuntu1.1), lsb-base (>= 4.1+Debian11ubuntu7), python3-gi, gir1.2-glib-2.0 (>= 1.29.17), sysv-rc (>= 2.86.ds1-14.1ubuntu2)
Recommends: apport-symptoms, policykit-1
Suggests: apport-gtk | apport-kde
Breaks: python-apport (<< 2.2-0ubuntu1)
Conffiles:
 /etc/apport/blacklist.d/README.blacklist c2ed1eb9a17ec2550747b4960cf4b73c
 /etc/apport/blacklist.d/apport 44503501302b80099552bac0204a45c1
 /etc/apport/crashdb.conf 0bb3a2832a92a0401e00583bf2d23e93
 /etc/bash_completion.d/apport_completion dfe766d9328bb5c895038b44185133f9
 /etc/cron.daily/apport df5d3bc9ab3a67b58156376318077304
 /etc/default/apport 3446c6cac185f44237f59786e006ebe4
 /etc/init.d/apport c9764ae43c4c0a23f36042244cd720f4
 /etc/init/apport.conf 37507fafcb91622ecee2e844da91d1ac
 /etc/logrotate.d/apport fa54dab59ef899b48d5455c976008df4
Description-en: automatically generate crash reports for debugging
 apport automatically collects data from crashed processes ...

Read more...

Robie Basak (racb) wrote :

Ah, "apt-cache show" can probably see it because it's installed locally maybe? I don't see the updates pocket in /var/lib/apt/lists/:

phablet@ubuntu-phablet:/var/lib/apt/lists$ ls
lock
partial
ports.ubuntu.com_ubuntu-ports_dists_vivid_Release
ports.ubuntu.com_ubuntu-ports_dists_vivid_Release.gpg
ports.ubuntu.com_ubuntu-ports_dists_vivid_main_binary-armhf_Packages
ports.ubuntu.com_ubuntu-ports_dists_vivid_main_i18n_Translation-en
ports.ubuntu.com_ubuntu-ports_dists_vivid_restricted_binary-armhf_Packages
ports.ubuntu.com_ubuntu-ports_dists_vivid_restricted_i18n_Translation-en
ports.ubuntu.com_ubuntu-ports_dists_vivid_universe_binary-armhf_Packages
ports.ubuntu.com_ubuntu-ports_dists_vivid_universe_i18n_Translation-en
ppa.launchpad.net_ci-train-ppa-service_stable-snapshot_ubuntu_dists_vivid_Release
ppa.launchpad.net_ci-train-ppa-service_stable-snapshot_ubuntu_dists_vivid_Release.gpg
ppa.launchpad.net_ci-train-ppa-service_stable-snapshot_ubuntu_dists_vivid_main_binary-armhf_Packages
ppa.launchpad.net_ci-train-ppa-service_stable-snapshot_ubuntu_dists_vivid_main_i18n_Translation-en

However sources.list does have "deb http://ports.ubuntu.com/ubuntu-ports/ vivid-updates universe" but maybe it wasn't present during image generation.

Robie Basak (racb) wrote :

(oh, and sources.list does also have "deb http://ports.ubuntu.com/ubuntu-ports/ vivid-updates main restricted")

Brian Murray (brian-murray) wrote :

@Robie - I reported the apt lists part of this bug in bug 1471903. Thanks!

Brian Murray (brian-murray) wrote :

I've uploaded the fix for bug 1470572 to the vivid proposed queue now.

Brian Murray (brian-murray) wrote :

I tested this again today on the following:

phablet@ubuntu-phablet:~$ cat /etc/system-image/channel.ini
[service]
base: system-image.ubuntu.com
http_port: 80
https_port: 443
channel: ubuntu-touch/rc-proposed/ubuntu
device: mako
build_number: 268
version_detail: ubuntu=20151020,device=20150911,custom=20151020,version=268

It seems that the fix for LP: #1489410 makes whitelisting the PPA as I suggested in comment #2 unnecessary.

Changed in apport (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers