Can not report bug: SSL Certificate Verify Failure

Bug #1439687 reported by Benedikt
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Confirmed
Undecided
Unassigned
whoopsie (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

I called apport with apport-bug linux, because I wanted to report a kernel bug.

However I could not send the logs to launchpad because of the following error message:

<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:600)>

Distribution: Kubuntu 15.04 64 Bit

Tags: kubuntu vivid
Revision history for this message
Benedikt (benedikt-klotz) wrote :

It seems it also affects whoopsie:

Apr 4 17:17:34 benediktZ50-70 whoopsie[784]: [17:17:34] Parsing /var/crash/_usr_share_apport_apport-kde.1000.crash.
Apr 4 17:17:34 benediktZ50-70 whoopsie[784]: [17:17:34] Uploading /var/crash/_usr_share_apport_apport-kde.1000.crash.
Apr 4 17:17:34 benediktZ50-70 whoopsie[784]: [17:17:34] Sent; server replied with: Peer certificate cannot be authenticated with given CA certificates
Apr 4 17:17:34 benediktZ50-70 whoopsie[784]: [17:17:34] Response code: 0

affects: apport → apport (Ubuntu)
affects: whoopsie → whoopsie (Ubuntu)
tags: added: kubuntu vivid
Revision history for this message
Benedikt (benedikt-klotz) wrote :

Ok I think it was my fault. I had not installed the python-sso-client package

Changed in apport (Ubuntu):
status: New → Invalid
Changed in whoopsie (Ubuntu):
status: New → Invalid
Revision history for this message
Numan Demirdöğen (if.gnu.linux) wrote :

This bug is totally valid. I can reproduce this bu with apport-gtk on Ubuntu 16.04. I added a strace of apport-gtk.

LC_ALL=C apt-cache policy apport-gtk
apport-gtk:
  Installed: 2.20-0ubuntu3
  Candidate: 2.20-0ubuntu3
  Version table:
 *** 2.20-0ubuntu3 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status

Changed in apport (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Jon W (88jwilson) wrote :

Also confirmed in ubuntu-bug at "S: Send Report" step.

What would you like to do? Your options are:
  S: Send report (32.5 KB)
  V: View report
  K: Keep report file for sending later or copying to somewhere else
  I: Cancel and ignore future crashes of this program version
  C: Cancel
Please choose (S/V/K/I/C): s

*** Uploading problem information

The collected information is being sent to the bug tracking system.
This might take a few minutes.
0%
*** Error: Network problem

Cannot connect to crash database, please check your Internet connection.

<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:645)>

Press any key to continue... q

Revision history for this message
Umut Özdemir (exclipit) wrote :

When I try to say in terminal:

apport-bug nautilus, i get this:

/usr/share/apport/apport-gtk:16: PyGIWarning: Wnck was imported without specifying a version first. Use gi.require_version('Wnck', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GLib, Wnck, GdkX11, Gdk
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

And in apport gui, at the last window: "<urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:645)>"

With these bug, I can't even truly report other bugs.

Revision history for this message
Numan Demirdöğen (if.gnu.linux) wrote :

This bug still exists in Ubuntu 16.10.

LC_ALL=C apt-cache policy apport-gtk
apport-gtk:
  Installed: 2.20.3-0ubuntu8
  Candidate: 2.20.3-0ubuntu8
  Version table:
 *** 2.20.3-0ubuntu8 500
        500 http://archive.ubuntu.com/ubuntu yakkety/main amd64 Packages
        500 http://archive.ubuntu.com/ubuntu yakkety/main i386 Packages
        100 /var/lib/dpkg/status

Revision history for this message
Numan Demirdöğen (if.gnu.linux) wrote :

If I am not rude, may I ask what the status of this bug is? I think the severity of this bug is high because when reporting a bug, I can not fill a bug report with enough relevant information that is collected by apport. If we want good bug reports from anyone, this bug is an hindrance to this.

Revision history for this message
Ulf (ulf-bremer) wrote :

For me the issue seems to be cause as the VMhost for this Ubuntu guest has netskope / goskope.com installed and https traffic is inspected by way of a wildcard certificate.
So yes, there is an issue with the cert, but it should be possible to manually allow this operation to proceed anyway like all browsers do.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers