Cannot examine crash report locally: "Error while creating the child process": (No such file or directory)

Bug #1361447 reported by Daniel Hahler on 2014-08-26
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Unassigned

Bug Description

When using "Examine locally" after "ubuntu-bug /var/crash/..." and selecting to run a gdb session, the following error dialog pops up:

    Error while creating the child process:
    Failed to execute child process "apport-retrace --gdb '/var/crash/....crash'" (No such file or directory)

It looks like apport is calling the process wrong: instead of as a command plus arguments, the whole string might get used as command.

It works fine from the shell.

(btw: it would be nice, if copy'n'paste would work for the text of such popups)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: apport 2.14.1-0ubuntu3.3
ProcVersionSignature: Ubuntu 3.13.0-34.60-generic 3.13.11.4
Uname: Linux 3.13.0-34-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
CrashReports:
 640:0:114:198430:2014-08-17 16:42:49.715965167 +0200:2014-08-17 16:42:49.711965167 +0200:/var/crash/susres.2014-08-17_16:42:49.718598.crash
 640:1000:114:185625:2014-08-20 18:38:13.700118400 +0200:2014-08-20 18:38:13.520118396 +0200:/var/crash/_usr_bin_redshift.1000.crash
 640:1000:114:5702851:2014-08-26 02:18:55.313115119 +0200:2014-08-26 02:19:13.153115552 +0200:/var/crash/_usr_bin_vim.gnome.1000.crash
CurrentDesktop: GNOME
Date: Tue Aug 26 02:20:45 2014
InstallationDate: Installed on 2012-05-28 (819 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: Upgraded to trusty on 2014-05-01 (116 days ago)
mtime.conffile..etc.apport.crashdb.conf: 2014-05-07T17:51:23.631588

Daniel Hahler (blueyed) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
tags: added: utopic vivid
Changed in apport (Ubuntu):
importance: Undecided → High
Fabio Marconi (fabiomarconi) wrote :

Mark as high because I can no more open bug reports.
Best regards

Changed in apport (Ubuntu):
status: Confirmed → Incomplete
Brian Murray (brian-murray) wrote :

I tested this on Eoan Ermine, which will become Ubuntu 19.10, and a terminal was opened and I was presented with a gdb session from which I could examine the stack trace. Subsequently, I am setting this to Fix Released.

Changed in apport (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers