apport-retrace crashed with UnicodeEncodeError in _print_message(): 'ascii' codec can't encode character u'\xe1' in position 615: ordinal not in range(128)

Bug #1358734 reported by Cristian Aravena Romero on 2014-08-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Martin Pitt

Bug Description

Start Ubuntu Utopic and crash.

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: apport-retrace 2.14.6-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-9.14-generic 3.16.1
Uname: Linux 3.16.0-9-generic x86_64
ApportLog:

ApportVersion: 2.14.6-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Aug 19 08:51:23 2014
ExecutablePath: /usr/bin/apport-retrace
InstallationDate: Installed on 2014-04-27 (114 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/apport-retrace --help
PythonArgs: ['/usr/bin/apport-retrace', '--help']
SourcePackage: apport
Title: apport-retrace crashed with UnicodeEncodeError in _print_message(): 'ascii' codec can't encode character u'\xe1' in position 615: ordinal not in range(128)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip kvm libvirtd lpadmin plugdev sambashare sudo

tags: removed: need-duplicate-check
Changed in apport (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
information type: Private → Public
Martin Pitt (pitti) on 2014-09-04
Changed in apport (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Fixed in trunk r2856.

Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.7-0ubuntu2

---------------
apport (2.14.7-0ubuntu2) utopic; urgency=medium

  [ Brian Murray ]
  * data/general-hooks/ubuntu.py: check to see if system-image-cli is
    available rather than if /etc/system-image/client.ini exists.

  [ Martin Pitt ]
  * ui.py: Robustify check if apport-retrace is installed. This brings back
    the "Examine locally" UI option. (LP: #1358734) (Cherry-picked from
    trunk).
 -- Martin Pitt <email address hidden> Thu, 04 Sep 2014 12:30:27 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers