apport-gtk crashed with EOFError in _read_exact(): Compressed file ended before the end-of-stream marker was reached

Bug #1345653 reported by Todd-mcghee on 2014-07-20
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Brian Murray

Bug Description

Errors Bucket
-------------
https://errors.ubuntu.com/bucket/?id=/usr/share/apport/apport-gtk%3AEOFError%3A/usr/share/apport/apport-gtk%40594%3Arun_argv%3Arun_crashes%3Arun_crash%3Acollect_info%3Aexc_raise%3Arun%3Asearch_bug_patterns%3A_check_bug_patterns%3A_check_bug_pattern%3Aget_value%3Aread%3A_read%3A_read_eof%3A_read_exact

upgrade from 10.04 to 12.10

ProblemType: CrashDistroRelease: Ubuntu 14.10
Package: apport-gtk 2.14.4-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-4.9-generic 3.16.0-rc5
Uname: Linux 3.16.0-4-generic i686
NonfreeKernelModules: nvidia
ApportLog:

ApportVersion: 2.14.4-0ubuntu2
Architecture: i386
CrashReports:
 640:0:128:33732:2014-07-20 13:38:34.401147127 -0400:2014-07-20 13:38:35.401147127 -0400:/var/crash/_usr_share_apport_apport-gtk.0.crash
 640:0:128:1093249:2014-07-20 13:38:33.744819164 -0400:2014-07-20 13:38:34.744819164 -0400:/var/crash/cgmanager.0.crash
Date: Sun Jul 20 13:38:35 2014
ExecutablePath: /usr/share/apport/apport-gtk
InstallationDate: Installed on 2013-12-21 (211 days ago)InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gtk
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
 LANGUAGE=en_US
 PATH=(custom, no user)
PythonArgs: ['/usr/share/apport/apport-gtk']SourcePackage: apport
Title: apport-gtk crashed with EOFError in _read_exact(): Compressed file ended before the end-of-stream marker was reached
UpgradeStatus: Upgraded to utopic on 2014-07-20 (0 days ago)
UserGroups:

Related branches

Todd-mcghee (todd-mcghee) wrote :
tags: removed: need-duplicate-check
Changed in apport (Ubuntu):
importance: Undecided → Medium
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Changed in apport (Ubuntu):
importance: Medium → High
description: updated
Paul Spain (pvspain) wrote :

Occurred during upgrade from 14.04 to 14.10.
Error occurred trying to submit a bug report after failing to install syslinux-themes-debian.

Occurred during upgrade from 14.10 to 15.04.

Brian Murray (brian-murray) wrote :

So systems seem to encounter an error when checking bug patterns:

  File "/usr/lib/python3/dist-packages/apport/report.py", line 893, in search_bug_patterns
    url = _check_bug_patterns(self, patterns)
  File "/usr/lib/python3/dist-packages/apport/report.py", line 170, in _check_bug_patterns
    url = _check_bug_pattern(report, pattern)
  File "/usr/lib/python3/dist-packages/apport/report.py", line 142, in _check_bug_pattern
    v = v.get_value()
  File "/usr/lib/python3/dist-packages/problem_report.py", line 62, in get_value
    return gzip.GzipFile(fileobj=BytesIO(self.gzipvalue)).read()
  File "/usr/lib/python3.4/gzip.py", line 360, in read
    while self._read(readsize):
  File "/usr/lib/python3.4/gzip.py", line 449, in _read
    self._read_eof()
  File "/usr/lib/python3.4/gzip.py", line 482, in _read_eof
    crc32, isize = struct.unpack("<II", self._read_exact(8))
  File "/usr/lib/python3.4/gzip.py", line 286, in _read_exact
    raise EOFError("Compressed file ended before the "
EOFError: Compressed file ended before the end-of-stream marker was reached

Changed in apport (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :
Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.16.2-0ubuntu1

---------------
apport (2.16.2-0ubuntu1) vivid; urgency=medium

  * New upstream bug fix release:
    - ProblemReport: Set a timestamp of 0 in gzip compressed fields; they are
      meaningless and cause unnecessary jitter in the output.
    - launchpad backend: Fix unclosed file in upload().
    - launchpad backend: Fix wrong use of filter() with Python 3.
    - launchpad backend download(): Try to convert textual values from byte
      arrays into into strings.
    - ui.py, collect_info(): Fix crash on bug pattern checking with broken
      gzipped values. (LP: #1345653)
    - hookutils, attach_drm_info(): Avoid UnicodeDecodeErrors in Python 3 when
      reading binary files. Thanks Chad Miller. (LP: #1425254)
    - apport-gtk: Update legacy icon names to modern GTK ones, to fix icons
      under GNOME. Thanks Scott Sanbar. (LP: #1422176)
    - Move backend_apt_dpkg testsuite to use Ubuntu 14.04 LTS.
    - hookutils, attach_dmesg(): Only attach dmesg as CurrentDmesg, drop
      BootDmesg as /var/log/dmesg is upstart specific and thus not reliably
      correct any more.
    - hookutils, recent_syslog(): Read system logs from the journal when
      running under systemd, and fall back to /var/log/syslog if not.
    - hookutils, attach_mac_events(): Read kernel violation messages from
      dmesg instead of /var/log/kern.log, as that's specific to rsyslog and
      its configuration.
 -- Martin Pitt <email address hidden> Mon, 02 Mar 2015 11:37:32 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers