ubuntu-bug fails with "whoopsie-upload-all: error: unrecognized arguments" when /var/lib/apport/autoreport exists

Bug #1339663 reported by Jean-Baptiste Lallement on 2014-07-09
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt
Trusty
High
Brian Murray

Bug Description

TEST CASE:
1. touch /var/lib/apport/autoreport
2. Run the command:
$ ubuntu-bug some_package

ACTUAL RESULT
ubuntu-bug fails with:
$ ubuntu-bug some_package
usage: whoopsie-upload-all [-h] [-t TIMEOUT]
whoopsie-upload-all: error: unrecognized arguments: some_package

EXPECTED RESULT
Reporting process starts

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: apport 2.14.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.15.0-6.11-generic 3.15.0
Uname: Linux 3.15.0-6-generic x86_64
ApportLog:

ApportVersion: 2.14.4-0ubuntu1
Architecture: amd64
CrashReports:
 640:1000:136:5676215:2014-07-09 09:48:24.545641183 +0200:2014-07-09 09:48:25.545641183 +0200:/var/crash/_usr_bin_indicator-weather.1000.crash
 640:0:136:205090:2014-07-08 09:18:29.153270255 +0200:2014-07-08 09:18:29.125270256 +0200:/var/crash/gnuplot.0.crash
CurrentDesktop: Unity
Date: Wed Jul 9 13:10:21 2014
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: Upgraded to utopic on 2012-01-31 (889 days ago)
modified.conffile..etc.apport.crashdb.conf: [modified]
mtime.conffile..etc.apport.crashdb.conf: 2014-04-14T14:45:04.033266

Jean-Baptiste Lallement (jibel) wrote :
Iain Lane (laney) wrote :

Looks like this is the same as bug #1336685, making so

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
description: updated
Changed in apport (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

Fixed in trunk r2816.

Changed in apport (Ubuntu):
importance: Medium → Undecided
status: Triaged → Fix Committed
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.4-0ubuntu2

---------------
apport (2.14.4-0ubuntu2) utopic; urgency=medium

  * Merge from trunk:
    - apport-bug: Stop checking the autoreport flag and calling
      whoopsie-upload-all; these two are different tasks, and that breaks bug
      reporting. (LP: #1339663)
 -- Martin Pitt <email address hidden> Thu, 10 Jul 2014 17:18:33 +0200

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Amr Ibrahim (amribrahim1987) wrote :

I have this bug in Trusty. Should I open a new bug?

tags: added: trusty
Amr Ibrahim (amribrahim1987) wrote :

Please backport the fix to Trusty.

Jarno Suni (jarnos) wrote :

Still not fixed in Trusty. What does /var/lib/apport/autoreport exists for? Is it safe to remove to work around the bug and to be able to make bug reports?

Amr Ibrahim (amribrahim1987) wrote :

In Trusty, I removed /var/lib/apport/autoreport. apport worked fine.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu Trusty):
status: New → Confirmed
Changed in apport (Ubuntu Trusty):
status: Confirmed → Triaged
importance: Undecided → High
Changed in apport (Ubuntu Trusty):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
Brian Murray (brian-murray) wrote :

apport can and does send report to two separate systems, Launchpad and the Ubuntu Error Tracker. Sending of reports to the Ubuntu Error Tracker is non-interactive and crashes can be sent to it automatically if whoopsie-upload-all is installed and /var/lib/apport/autoreport exists. This is useful to Ubuntu developers as we then know what which crashes are affecting a lot of users.

Unfortunately, there was a bug in ubuntu-bug which made it impossible for people to report bugs to Launchpad if whoopsie-upload-all was installed. This has not yet been resolved in Trusty although I just uploaded a fix for this for the SRU queue team to review.

Removing /var/lib/apport/autoreport isn't a good workaround as then you won't be automatically reporting crashes to the Error Tracker.

Jarno Suni (jarnos) wrote :

/usr/share/apport/whoopsie-upload-all is part of apport package. But what package is responsible for /var/lib/apport/autoreport and should the file have some content?

P.S. I had to use sudo mkdir /var/lib/apport; sudo touch /var/lib/apport/autoreport
to create the file.

Jarno Suni (jarnos) wrote :

Brian Murray, what workaround do you recommend, if not removing /var/lib/apport/autoreport?

On Tue, May 17, 2016 at 08:24:22AM -0000, Jarno Suni wrote:
> /usr/share/apport/whoopsie-upload-all is part of apport package. But
> what package is responsible for /var/lib/apport/autoreport and should
> the file have some content?

apport-noui creates /var/lib/apport/autoreport. The file needs no
content its existence indicates that whoopsie should automatically
upload crashes to the Error Tracker.

> P.S. I had to use sudo mkdir /var/lib/apport; sudo touch /var/lib/apport/autoreport
> to create the file.

You should only be encountering this issue, not being able to use
ubuntu-bug, if you have apport-noui installed. Do you?

--
Brian Murray

Brian Murray (brian-murray) wrote :

On Tue, May 17, 2016 at 08:26:29AM -0000, Jarno Suni wrote:
> Brian Murray, what workaround do you recommend, if not removing
> /var/lib/apport/autoreport?

An updated version of apport which allows you to have apport-noui
installed and use ubuntu-bug will appear in -proposed for Trusty this
week, so I suggest waiting for that.

--
Brian Murray

Jarno Suni (jarnos) wrote :

No, I do not have apport-noui installed.

Hello Jean-Baptiste, or anyone else affected,

Accepted apport into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/apport/2.14.1-0ubuntu3.21 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apport (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Amr Ibrahim (amribrahim1987) wrote :

apport in trusty-proposed fixes this bug.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.1-0ubuntu3.21

---------------
apport (2.14.1-0ubuntu3.21) trusty-proposed; urgency=medium

  * apport-bug: Stop checking the autoreport flag and calling
    whoopsie-upload-all; these two are different tasks, and that breaks bug
    reporting. (LP: #1339663)

 -- Brian Murray <email address hidden> Mon, 16 May 2016 13:24:02 -0700

Changed in apport (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for apport has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers