apportcheckresume does not create a duplicate signature

Bug #1316841 reported by Brian Murray on 2014-05-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Daisy
Low
Unassigned
apport (Ubuntu)
High
Brian Murray
Trusty
Undecided
Unassigned
Utopic
High
Brian Murray

Bug Description

[Test Case]
1) create the file /var/lib/pm-utils/status with the contents resume
2) run /usr/share/apport/apportcheckresume
3) choose to send the error report
4) verify that DuplicateSignature exists in /var/crash/susres.$DATE.crash and contains a value with contents like resume:MACHINE TYPE:BIOS VERSION
5) go to your user page at errors.ubuntu.com/user/ and verify that the latest crash reported which should be your suspend resume crash contains the same DuplicateSignature

There is no StacktraceAddressSignature nor a DuplicateSignature in these crashes so they are never consolidated by the Ubuntu Error Tracker and subsequently do not appear in the top crashes for linux.

Changed in apport (Ubuntu):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

This is an example of a suspend / resume bug created by apport - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1296044.

Brian Murray (brian-murray) wrote :

Oh, maybe all we need to do is call report.crash_signature().

    def crash_signature(self):
        '''Get a signature string for a crash.

        This is suitable for identifying duplicates.
        ....
        For suspend/resume failures, this concatenates whether it was a suspend
        or resume failure with the hardware identifier and the BIOS version, if
        it exists.
        '''

Brian Murray (brian-murray) wrote :

That looks about right.

ipdb> report.crash_signature()
u'suspend/resume:Acer TravelMate 5740:V1.13'

Brian Murray (brian-murray) wrote :

This should be SRU'ed to all supported releases.

Additionally, a job should be run against the cassandra database to create crash signatures for existing suspend / resume failures.

Changed in apport (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: New → In Progress
affects: apport → daisy
Changed in daisy:
status: New → Triaged
importance: Undecided → Medium
Martin Pitt (pitti) on 2014-05-10
Changed in apport (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

I uploaded a trusty SRU for this.

Changed in apport (Ubuntu Trusty):
status: New → In Progress

Hello Brian, or anyone else affected,

Accepted apport into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/apport/2.14.1-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apport (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

I created the file /var/lib/pm-utils/status with the contents resume so that a the Failure key in the report would not be empty and did receive a 'DuplicateSignature' in my /var/crash/susres.$DATE.crash file when using the version of apport from trusty-proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.1-0ubuntu3.1

---------------
apport (2.14.1-0ubuntu3.1) trusty-proposed; urgency=medium

  * Move error handling for invalid .crash files into collect_info(), so that
    it also applies when using the "Show Details..." button in the UI.
    Otherwise the UI just hangs eternally at this point when encountering
    broken core dumps. Cherry-picked from trunk r2789. (LP: #1282349)
  * Add kernel package version to the various kernel-related hooks. Thanks
    Brian Murray. Cherry-picked from trunk r2799. (LP: #1316845)
  * Add a duplicate signature to suspend resume failures. Thanks Brian Murray.
    Cherry-picked from trunk r2800. (LP: #1316841)
 -- Martin Pitt <email address hidden> Mon, 12 May 2014 16:28:57 +0200

Changed in apport (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for apport has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Brian Murray (brian-murray) wrote :

There should also be a job run against the database to create duplicate signatures for these failures.

Brian Murray (brian-murray) wrote :

The duplicate signature was actually incomplete and missing information as 'MachineType' is not known to apport when apportcheckresume is run, rather this information is gathered by the apport package hook for linux so the duplicate signature creation belongs there.

You can see the incomplete signatures in the error tracker:

https://errors.ubuntu.com/oops/73891a08-dc8d-11e3-94de-fa163e707a72

Changed in apport (Ubuntu Utopic):
status: Fix Committed → Triaged
Changed in apport (Ubuntu Trusty):
status: Fix Released → Triaged
Brian Murray (brian-murray) wrote :

A job to create duplicate signatures for the suspend resume failures *can not* be created as whoopsie does not upload MachineType or dmi.bios.version. It might be worth just removing existing suspend resume failures from the database.

Brian Murray (brian-murray) wrote :

I've uploaded a fix for Trusty to the -proposed queue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.2-0ubuntu4

---------------
apport (2.14.2-0ubuntu4) utopic; urgency=medium

  * data/package-hooks/source_linux.py: create a duplicate signature for
    suspend resume failures. (LP: #1316841)
 -- Brian Murray <email address hidden> Fri, 16 May 2014 09:46:51 -0700

Changed in apport (Ubuntu Utopic):
status: Triaged → Fix Released
description: updated

Hello Brian, or anyone else affected,

Accepted apport into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/apport/2.14.1-0ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apport (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

I installed apport from the trusty-proposed repository and confirm that a duplicate signature includes information about the system and BIOS version. I actually set up daisy to stop accepting suspsend resume reports because of the earlier issue with them being too generic, but removing this from a staging server I verified that the submitted crash did have a correct duplicate signature.

DuplicateSignature: late resume:LENOVO 0831CTO:1.23

tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

This should be released once the diasy frontends are running r444, something for which I've just submitted and RT.

Brian Murray (brian-murray) wrote :

The daisy frontends have been updated to r444 and we can see a good suspend resume failure here:

https://errors.ubuntu.com/oops/1d3d3c20-e132-11e3-a12d-fa163e339c81

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.1-0ubuntu3.2

---------------
apport (2.14.1-0ubuntu3.2) trusty-proposed; urgency=medium

  * Move duplicate signature creation for suspend resume failures from
    apportcheckresume which does not have all the information we need to
    the kernel package hook. (LP: #1316841)
 -- Brian Murray <email address hidden> Fri, 16 May 2014 10:03:10 -0700

Changed in apport (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in daisy:
importance: Medium → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers