Crashes on invalid/broken core dumps when using "Show details..."

Bug #1282349 reported by ariel sandoval on 2014-02-20
144
This bug affects 30 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Martin Pitt
Trusty
High
Martin Pitt
Utopic
High
Martin Pitt

Bug Description

TEST CASE:
- Produce a crash report: sh -c 'kill -SEGV $$'; close the Apport popup window.
- Edit /var/crash/_bin_dash.1000.crash; remove a few characters at the end of the CoreDump field (at the very end of the file)
- Apport pops up again; click on "Show Details...", analysis will start, and hang forever
- Apport should pop up a second time, for apport-gtk itself.

FIX: http://bazaar.launchpad.net/~apport-hackers/apport/trunk/revision/2789 (This includes a new test case which reproduces this bug; the test suite already contains a regression test for clicking the "Continue" button without showing details.)

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: apport-gtk 2.13.2-0ubuntu5
ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
Uname: Linux 3.13.0-11-generic x86_64
ApportLog:
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
Date: Wed Feb 19 20:56:48 2014
ExecutablePath: /usr/share/apport/apport-gtk
InstallationDate: Installed on 2013-12-16 (65 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
InterpreterPath: /usr/bin/python3.4
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gtk
ProcEnviron:
 SHELL=/bin/bash
 LANG=es_CO.UTF-8
 LANGUAGE=es_CO:es
 PATH=(custom, no user)
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with EOFError in _read_exact(): Compressed file ended before the end-of-stream marker was reached
UpgradeStatus: Upgraded to trusty on 2013-12-18 (64 days ago)
UserGroups:

ariel sandoval (arielsanflo) wrote :
tags: removed: need-duplicate-check
Changed in apport (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

e.u.c report on https://errors.ubuntu.com/problem/e67fd662efbdaeb1e233c97c2122fb7e3aecc8e3

Seems like the issue started with 2.13.2-0ubuntu4 or 2.13.2-0ubuntu5, it's ranked 9 on the daily trusty report

information type: Private → Public
Changed in apport (Ubuntu):
importance: Medium → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Marcos Sanchez (marchezior) wrote :

This only happens after an update in Ubuntu 14.04 Beta 1.

Sebastien Bacher (seb128) wrote :

Hey Martin, do you think we could do anything better if those are corrupted reports? We could perhaps bail out without trigger an apport dialog in those cases?

bluescreen (s-drei) wrote :

Marcos:
Yes, after a kernel update, but not only 14.04, I had the same problem on and off in 13.10, approx. from Jan till beginning of March, before I went 14.04.
I do not know if it made a difference: whenever these errors popped up I was not able to update using the Software Updater, but if I ran sudo apt-get update and upgrade enough times, all would be peachy again.

Martin Pitt (pitti) wrote :

Ah, now I know why this suddenly starts happening. The exception apparently got changed with http://bugs.python.org/issue1159051 .

Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
Changed in apport (Ubuntu Trusty):
status: In Progress → Triaged
Changed in apport (Ubuntu Untitled):
status: New → In Progress
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

The errors are intercepted correctly when using the "Continue" button. But when using "Show details", the exceptions flow a different way.

description: updated
summary: - apport-gtk crashed with EOFError in _read_exact(): Compressed file ended
- before the end-of-stream marker was reached
+ Crashes on invalid/broken core dumps when using "Show details..."
Changed in apport (Ubuntu Untitled):
importance: Undecided → High
Martin Pitt (pitti) on 2014-04-23
no longer affects: python
Martin Pitt (pitti) wrote :

Fixed in trunk r2789.

Changed in apport (Ubuntu Untitled):
status: In Progress → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.2-0ubuntu1

---------------
apport (2.14.2-0ubuntu1) utopic; urgency=medium

  * New upstream release:
    - Move error handling for invalid .crash files into collect_info(), so
      that it also applies when using the "Show Details..." button in the UI.
      Otherwise the UI just hangs eternally at this point when encountering
      broken core dumps. (LP: #1282349)
    - apt/dpkg install_packages(): Try to install the requested package
      version instead of always picking the most recent one. This should
      improve retracing results for older crash reports. Thanks to Brian
      Murray for inspiring this.
    - sandboxutils.py, make_sandbox(): When determining packages to install
      from ProcMaps, look up and use the package versions from the reporter,
      to improve retracing results. Thanks Brian Murray for the initial patch!
    - iwlwifi_error_dump: Make reports private, and subscribe
      canonical-kernel-team. Thanks Seth Forshee. (LP: #1313818)
    - signal_crashes test: Time out after 5 seconds if the test process does
      not terminate on the specified signal, to avoid eternal hangs.
    - signal_crashes test: Ensure that we don't inherit an ignored SIGQUIT
      from the caller.
  * Switch Vcs-* to utopic branch.
  * Add build-essential test dependency, some tests call gcc.
  * Install iwl_wifi_error_dump and corresponding udev rules. (Second part of
    LP: #1313818)
 -- Martin Pitt <email address hidden> Wed, 30 Apr 2014 14:07:17 +0200

Changed in apport (Ubuntu Utopic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

I uploaded a trusty SRU for this.

Changed in apport (Ubuntu Trusty):
status: Triaged → In Progress

Hello ariel, or anyone else affected,

Accepted apport into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/apport/2.14.1-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apport (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.14.1-0ubuntu3.1

---------------
apport (2.14.1-0ubuntu3.1) trusty-proposed; urgency=medium

  * Move error handling for invalid .crash files into collect_info(), so that
    it also applies when using the "Show Details..." button in the UI.
    Otherwise the UI just hangs eternally at this point when encountering
    broken core dumps. Cherry-picked from trunk r2789. (LP: #1282349)
  * Add kernel package version to the various kernel-related hooks. Thanks
    Brian Murray. Cherry-picked from trunk r2799. (LP: #1316845)
  * Add a duplicate signature to suspend resume failures. Thanks Brian Murray.
    Cherry-picked from trunk r2800. (LP: #1316841)
 -- Martin Pitt <email address hidden> Mon, 12 May 2014 16:28:57 +0200

Changed in apport (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for apport has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Heike Harnack (h-harnack) wrote :

Hi,

after install (L)Ubuntu 14.04 new, I get the same affect. The button "show details" in crash become a new crash "Crash report dosn't work". In this new crash the button work, so I can see, what could help and apt-get each package I see in the details.
I just wrote this, because I think, it is helpfull. When I get the same affect after install all packages or apt-get update, I write again!

Yours
Heike
P.S: Should I add the first crash? I have no permission to see it (only with root)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.