Apport package hooks might be incomplete, when file a bug against the kernel in 12.04.3, only Dependency.txt will be uploaded

Bug #1229611 reported by Po-Hsu Lin on 2013-09-24
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Low
Andy Whitcroft
Precise
High
Andy Whitcroft
Trusty
Low
Andy Whitcroft

Bug Description

== SRU Justification ==

[Impact]

Bugs found and filed against the LTS backports kernels will be missing vital information which will then lead to the reporter being asked for the information later and delay resolution of the bug.

[Test Case]

Install an LTS backports kernel (linux-lts-quantal or linux-lts-raring) on a precise system (or install the most recent point release). Attempt to file a bug with ubuntu-bug linux and note that almost no information is included.

Install the fixed version and confirm that a full kernel report is generated from ubuntu-bug linux.

[Regression Potential]

This changes code common to all kernel reporting. It would be prudent to also confirm that a base precise kernel also reports correctly with these changes.

[Other Info]

I have tested these changes in a precice VM installed from the .3 point release.

=========

When file a bug against the kernel using "ubuntu-bug linux" in fresh installed 12.04.3 (3.8 kernel)
The package will be change to linux-lts-raring automatically, which is a normal behavior according to bug 1218183
But the problem is only the "Dependency.txt" will be appended to the bug report.

I have to change the affected package from linux-lts-raring to linux on launchpad and run apport-collect to upload other log files.

Maybe there is something to do with the package hook.

Po-Hsu Lin (cypressyew) on 2013-09-24
summary: - Apport package hooks might be incomplete when file a bug against the
+ Apport package hooks might be incomplete, when file a bug against the
kernel in 12.04.3, only Dependency.txt will be uploaded

 to bug 1218183 heb ik een fout gemaakt met het bug ?

Andy Whitcroft (apw) on 2013-09-24
Changed in apport (Ubuntu):
status: New → Invalid
status: Invalid → New
Andy Whitcroft (apw) on 2013-09-24
Changed in apport (Ubuntu Precise):
status: New → In Progress
assignee: nobody → Andy Whitcroft (apw)
importance: Undecided → High
description: updated
Changed in apport (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Andy Whitcroft (apw) on 2013-09-24
Changed in apport (Ubuntu):
importance: Medium → Low
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

Attaching the debdiff for this change as uploaded.

Changed in apport (Ubuntu Precise):
status: In Progress → Fix Committed
Andy Whitcroft (apw) wrote :

The core changes here likely should be injected into T when that opens.

Andy Whitcroft (apw) wrote :

Current development is not affected because it is not an LTS and these are LTS specific changes.

Hello Po-Hsu, or anyone else affected,

Accepted apport into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/apport/2.0.1-0ubuntu17.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in apport (Ubuntu):
milestone: none → ubuntu-14.04
tags: added: verification-needed
Po-Hsu Lin (cypressyew) wrote :

Hello Brian,

The proposed apport package (version 2.0.1-0ubuntu17.5) works.

Test case:
1. Install 12.04.3 on 201302-12678 (Dell Optiplex 9020)
2. Enable -proposed.
3. Upgrade the apport package.
4. Run "ubuntu-bug linux" to report a bug against kernel.

Expected result:
Log files should be uploaded.

Actual result:
Log files correctly uploaded. Please see bug 1232975.
VERIFICATION DONE

Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.0.1-0ubuntu17.5

---------------
apport (2.0.1-0ubuntu17.5) precise-proposed; urgency=low

  * fix up apport reporting for linux-lts-raring kernels (LP: #1229611)
   - generalise linux-meta* to linux* mapping so we do not have to add
     each backport kernel explicitly.
   - remove linux-lts-quantal hack which was introduced for when packages
     were shipped via the x-swap PPA and so there was no real source
     package in the archive.
   - add links for linux-lts-raring to the package to map those to
     the source_linux.py hooks.
   - add links for linux-lts-saucy to the package to map those to
     the source_linux.py hooks.
 -- Andy Whitcroft <email address hidden> Tue, 24 Sep 2013 13:05:38 +0100

Changed in apport (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

tags: added: patch
Andy Whitcroft (apw) wrote :

Pulled these fixes up to apport for trusty.

Changed in apport (Ubuntu Trusty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.12.7-0ubuntu1

---------------
apport (2.12.7-0ubuntu1) trusty; urgency=low

  [ Martin Pitt ]
  * New upstream release:
    - Properly fall back to lsb_release if /etc/os-release is invalid.
    - report.py, add_proc_info(): Add "CurrentDesktop" field with the value of
      $XDG_CURRENT_DESKTOP, if present. (LP: #1247904)
    - fileutils.py, get_all_system_reports(): Filter out "guest..." users,
      they might have a system UID. (LP: #1250679)
    - apt/dpkg: Don't call dpkg-divert with full path, it moved in Ubuntu
      14.04. (LP: #1252305)
  * launchpad.py: Ignore "MarkForUpload" field, it's just for internal
    communication with whoopsie.

  [ Andy Whitcroft ]
  * package-hooks/source_linux.py: pull forward fix to generify linux-meta
    to linux mapping. (LP: #1229611)
  * package-hooks/source_linux.py: pull forward kernel tagging for
    linux-lts- family kernels. (LP: #1229611)
 -- Martin Pitt <email address hidden> Tue, 19 Nov 2013 09:11:53 +0100

Changed in apport (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Patches