apport-gtk crashed with UnicodeEncodeError in body_encode(): 'utf-8' codec can't encode character '\udce2' in position 352: surrogates not allowed

Bug #1227381 reported by madmedicus on 2013-09-18
178
This bug affects 23 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Critical
Martin Pitt

Bug Description

just trying to be a good beta tester...

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: apport-gtk 2.12.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-7.14-generic 3.11.1
Uname: Linux 3.11.0-7-generic i686
ApportVersion: 2.12.2-0ubuntu1
Architecture: i386
Date: Wed Sep 18 23:51:55 2013
ExecutablePath: /usr/share/apport/apport-gtk
InstallationDate: Installed on 2013-04-26 (145 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release i386 (20130424)
InterpreterPath: /usr/bin/python3.3
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gtk /var/crash/_usr_bin_gjs-console.1000.crash
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/apport/apport-gtk', '/var/crash/_usr_bin_gjs-console.1000.crash']
SourcePackage: apport
Title: apport-gtk crashed with UnicodeEncodeError in body_encode(): 'utf-8' codec can't encode character '\udce2' in position 352: surrogates not allowed
UpgradeStatus: Upgraded to saucy on 2013-09-13 (5 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

madmedicus (jwesterinkjr) wrote :
tags: removed: need-duplicate-check
Changed in apport (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Martin Pitt (pitti) wrote :

This is due to a recent change in MIMEText() in python3.3. Adjusted in apport trunk r2704.

information type: Private → Public
Changed in apport (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Medium → Critical
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.12.3-0ubuntu1

---------------
apport (2.12.3-0ubuntu1) saucy; urgency=low

  * New upstream bug fix release:
    - ProblemReport.write_mime(): Adjust MIMEText handling to latest Python
      3.3 upstream changes which now don't tolerate passing bytes any more.
      (LP: #1227381)
    - apport-gtk: Don't use obsolete add_with_viewport() method any more.
    - Fix ui_present_report_details() "modal_for" keyword for all UI
      implementations, so that --hanging works for -cli and -kde, too.
      (LP: #1213790)
 -- Martin Pitt <email address hidden> Thu, 19 Sep 2013 10:36:06 -0500

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
vlotho (gdalmas) wrote :

same problem on 64bit architecture

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers