Apport gets stuck and sucks CPU

Bug #1155115 reported by Ted Gould on 2013-03-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
High
Evan

Bug Description

Occasionally apport gets stuck and starts taking all of my CPU. It seems to be related to the attached crash file.

Strace looks like this:
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigreturn(0xb) = 1

The open files look like this:
root@vee:/proc/9368/fd# ls -al
total 0
dr-x------ 2 root root 0 Mar 14 12:37 .
dr-xr-xr-x 9 root root 0 Mar 14 11:30 ..
lr-x------ 1 root root 64 Mar 14 12:38 0 -> pipe:[1314229]
l-wx------ 1 root root 64 Mar 14 12:38 1 -> /var/crash/.lock
l-wx------ 1 root root 64 Mar 14 12:38 2 -> /var/log/apport.log
lr-x------ 1 root root 64 Mar 14 12:38 3 -> /var/crash/_usr_bin_gwibber-service.1000.crash

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: apport 2.9.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-11.20-generic 3.8.2
Uname: Linux 3.8.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportLog:

ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
Date: Thu Mar 14 12:40:58 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2010-05-17 (1031 days ago)
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: apport
UpgradeStatus: Upgraded to raring on 2013-03-07 (6 days ago)

Ted Gould (ted) wrote :
Ted Gould (ted) on 2013-03-14
Changed in apport (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
Evan (ev) on 2013-05-30
Changed in apport (Ubuntu):
assignee: Evan Dandrea (ev) → nobody
Evan (ev) wrote :

Easily confirmed by running the crash file through apport-cli on quantal.

Changed in apport (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → High
status: New → Triaged
Evan (ev) wrote :

Ah, it just finished, after taking some significant amount of time:

*** Invalid problem report

This problem report applies to a program which is not installed any more. (/usr/bin/gwibber-service)

Evan (ev) wrote :

And it's probably worth noting that I actually processed that using the Raring version of apport, 2.9.2-0ubuntu8.

tags: added: xenial
pleabargain (dennisgdaniels) wrote :

getting a gtk error while running apport-bug
you can see it here:
https://www.youtube.com/watch?v=DfHaVNUSh34&feature=youtu.be

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers