apport-gtk crashed with ValueError in _apt_pkg(): package skype-bin does not exist

Bug #1097773 reported by Cristian Aravena Romero on 2013-01-09
226
This bug affects 49 people
Affects Status Importance Assigned to Milestone
apport (Ubuntu)
Medium
Unassigned
Raring
Medium
Unassigned

Bug Description

Crash skype and crash apport. bug #1097771

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: apport-gtk 2.8-0ubuntu1
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
Date: Wed Jan 9 11:10:20 2013
ExecutablePath: /usr/share/apport/apport-gtk
InstallationDate: Installed on 2012-11-27 (43 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20121126)
InterpreterPath: /usr/bin/python3.3
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/share/apport/apport-gtk
PythonArgs: ['/usr/share/apport/apport-gtk']
SourcePackage: apport
Title: apport-gtk crashed with ValueError in _apt_pkg(): package skype-bin does not exist
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

tags: removed: need-duplicate-check
Changed in apport (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2013-03-07
information type: Private → Public
fabio (trickfun) wrote :

same problem in kernel 3.8.0.12

Genadi Saltikov (carmageddon-2) wrote :

It happens pretty much on every time Skype is started either after reboot (auto start), when trying manually - nothing happens.

etab3ta (i6qkl) wrote :

Same problem in kernel 3.8.0-13

Crashed on bootup. I have skype installed but it was not running

Aske Bluhme (askebluhme) wrote :

Ubuntu bug upload says I have the same bug. Kernel 3.8.0-14

kura (dash29-free) wrote :

It affect me with the kernel 3.8.0.15 in 64 bits

phiro (phiro) wrote :

Workaround worked for me:
Start skype with:
LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype

After that is starts up ok.

Alex Andrascu (s0-ofk2ce-id) wrote :

#11 Works for me too

fabio (trickfun) wrote :

#11 Works for me too

tags: added: saucy
Brian Murray (brian-murray) wrote :

This is occurring quite frequently in Ubuntu 13.04 as we can see in the error tracker - https://errors.ubuntu.com/problem/6c6e58622198dbb4577349d83c9d6cf27a149f60

Changed in apport (Ubuntu):
status: Confirmed → Triaged
Changed in apport (Ubuntu Raring):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Brian Murray (brian-murray)
Martin Pitt (pitti) on 2013-08-19
Changed in apport (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 2.12.1-0ubuntu2

---------------
apport (2.12.1-0ubuntu2) saucy; urgency=low

  * Don't provide arguments to whoopsie-upload-all. It doesn't take any.
  * Do not attempt to install the now dead apport-noui frontend.
 -- Evan Dandrea <email address hidden> Mon, 19 Aug 2013 15:25:05 +0100

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in apport (Ubuntu Raring):
status: Triaged → Won't Fix
Changed in apport (Ubuntu Raring):
assignee: Brian Murray (brian-murray) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers